Portail Captif + Free Radius + Snort + Traffic Shaper



  • Bonjour à tous! Je suis nouveau sur ce forum que je visite depuis quelques temps  :)

    J'ai un projet à mettre en place dans mon entreprise: mise en place d'un hotspot wi-fi avec un portail captif (FreeRadius pour l'auth), un contrôle des intrusions réseau avec SNORT ainsi qu'une gestion de la BP avec Traffic Shaper.

    Je dispose d'une machine avec 3 carte eth. J'ai installé la dernière version BETA de pfSense.

    FAI BOX <–> AP en WDS <--> WAN [192.168.1.100] <–-> PfSense <--> LAN [192.168.1.1]

    Je dois maintenant configurer une troisième carte réseau pour que je puisse connecter mon AP (WRT54GL) sur lequel le portail captif sera "actif".

    Je penses je dois mettre comme IP pour l'AP, 192.168.2.100 par exemple?

    On parlera du reste plus tard..  :)



  • Manque d'info, ce qui fait qu'on ne peux pas donner de réponse (il faudrait des jour pour vous énumérer toute les possibilité).

    La preuve:

    WAN [192.168.1.100] <–-> PfSense <--> LAN [192.168.1.1]

    On ne connais pas le masque, mais à vue d'œil je pense ne pas me trompé pour un 255.255.255.0 (/24), ce qui me ferais dire que vous avez déjà un premier souci!

    Je penses je dois mettre comme IP pour l'AP, 192.168.2.100 par exemple?

    Oui et non, en faite cela dépend … de la question, ... c'est quoi la question?



  • Il y a plusieurs objectifs : il faudra donc faire 1 fil par sujet !

    Premier sujet : disposer d'une borne wifi.

    Forcément, il y aura 3 interfaces ethernet dans le pfSense : WAN + LAN + WIFI.
    Forcément, il y aura 3 adressages ip différents sur chacune de ces interfaces.
    Forcément, sur l'interface Wifi, il y aura un câble vers un AP (ou un routeur wifi dont on utilise pas le WAN).
    Forcément, l'AP s'occupera de la partie wifi : open ou crypté, c'est selon !



  • En relisant, effectivement, j'étais assez évasif sur de très nombreux points.

    On ne connais pas le masque, mais à vue d'œil je pense ne pas me trompé pour un 255.255.255.0 (/24), ce qui me ferais dire que vous avez déjà un premier souci!

    Le masque est bien en /24.
    Je suppose que c'est une erreur concernant l'adressage IP qui n'est pas le bon. Je dois par exemple mettre 192.168.1.*** pour le WAN et 192.168.2.*** pour le LAN ?

    Premier sujet : disposer d'une borne wifi.

    Pour ça, c'est bon, j'ai un AP ;)

    Je débute dans pfSense…



  • Je suppose que c'est une erreur concernant l'adressage IP qui n'est pas le bon. Je dois par exemple mettre 192.168.1.*** pour le WAN et 192.168.2.*** pour le LAN ?

    Vous supposé bien  ;D et votre proposition d'adressage est maintenant correcte.

    Je débute dans pfSense…

    Surement, mais d'après ce qu'on peux lire vous débuté aussi dans le réseau.
    Je vous conseille d'aller faire un tour sur le site de Christian Caleca si vous ne le connaissez pas encore, il vous serra très utile.

    Pour le reste, allez au fond de votre penser, dite nous tous, même si je pense que jdh est dans le vrai (je veux dire qu'il à compris ce que vous chercher à faire).



  • Surement, mais d'après ce qu'on peux lire vous débuté aussi dans le réseau.
    Je vous conseille d'aller faire un tour sur le site de Christian Caleca si vous ne le connaissez pas encore, il vous serra très utile.

    Pour le reste, allez au fond votre penser, dite nous tous, même si je pense que jdh est dans le vrai (je veux dire qu'il à compris ce que vous chercher à faire).

    Merci pour le site (que j'avais trop rapidement visité il y a quelques temps)

    Effectivement, il m'a bien compris. Je test tout ça et je vous fais un retour le plus tôt possible.  :)



  • Bonjour!

    Le portail captif fonctionne maintenant (de façon basique, certes).

    Je me connecte en Wi-Fi sur mon point d'accès, je suis automatique dirigé vers le portail captif et après avoir indiqué nom d'utilisateur et mot de passe, la connexion s'établit.

    Le DHCP est activé sur le OPT1 (où est relié mon AP en 192.168.3.1).

    Par contre, je souhaite mettre en place l'authentification sur le portail captif en HTTPS:

    HTTPS certificate
    –---BEGIN CERTIFICATE-----

    -----END CERTIFICATE-----
    Paste a signed certificate in X.509 PEM format here.

    HTTPS private key
    -----BEGIN RSA PRIVATE KEY-----

    -----END RSA PRIVATE KEY-----
    Paste an RSA private key in PEM format here.

    HTTPS intermediate certificate
    -----BEGIN CERTIFICATE-----
    ??
    -----END CERTIFICATE-----
    Paste a certificate in X.509 PEM format here.

    Pour les deux premiers certificats, c'est bon, j'ai pris directement depuis le webconfigurator. Par contre, je bloque pour le HTTPS intermediate certificate

    Je dois mettre quoi pour ce certificat?

    Je précise que je suis sous le dernière version de pfsense (Beta 5)

    Merci



  • Bon, bizarrement, après mise à jour avec une dernière release (toujours en Beta 5), j'ai mis pour le HTTPS intermediate certificate le même certificat que le HTTPS certificate et ça fonctionne…

    Maintenant, je passe au reste ;)


Log in to reply