[résolu] Intel PRO/1000 PT Quad Port low profile



  • Bonjour,

    J'ai besoin de votre aide pour l'installation d'une carte réseau. Je possède un serveur dell R310 muni d'une carte Intel PRO/1000 PT Quad Port low profile (ref intel : EXPI9404PTL)
    J'ai un petit problème à l'installation, la carte n'est pas reconnue.
    <network,ethernet>at device 0.0 (no driver attached)</network,ethernet>
    je suis donc allez chercher le driver chez intel (Network Adapter Gigabit Base Driver for FreeBSD* 7.x:em-7.1.7.tar.gz), je l'ai compilé sur un frebsd 7.2, mis sur pfsense 1.2.3 dans /boot/kernel et j’ai ajouter la ligne :
    if_em_load="YES"
    J'ai toujours le même message.

    J’ai vu sur le forum que quelques personnes utilisent cette carte, je ne pense pas que ce soit un pb de compatibilité. Si quelqu’un peu m’orienter sur l’installation cette carte, cette personne me rendrai un grand service.

    merci.



  • La ligne if_em_load="YES" doit être insérée dans /boot/loader.conf

    Cependant le probleme doit provenir du fait que le driver est deja compilé en statique dans le kernel.
    Il faudrait recompiler le kernel avec ce nouveau driver (ou sans, pour pouvoir le kldload).



  • Merci pour ta réponse Juve, j’avais bien mis la ligne dans le /boot/loader.conf

    J’ai remarqué que tu avais déjà installé ce type de carte en prod. Ces carte son automatiquement reconnu ou faut-il les activés avec la ligne  if_em_load="YES".

    Je te ferai en retour sur le déroulement.



  • En fait il faut connaitre le chipset exact présent sur la carte pour comparer à la liste des chipset supportés par le driver em intégré dans le kernel.

    As-tu tenté un boot sans ACPI ?



  • le chipset est un 82571GB

    le driver em est compatible avec : Intel PRO/1000 PT Quad Port Server Adapter chipset 82571

    Je pense que j'ai fait une belle bourde.

    Est-il dans ce cas possible d'intégré le driver fournit par intel pour freebsd 7.* ?



  • as tu tenté sans ACPI ? option 2 au boot?
    De mémoire ce chipset est reconnu mais il faut booter sans ACPI, enfin je pense que c'était celui-ci.



  • Oui j'ai bien tenté le redémarrage sans ACPI. Pas mieux.



  • En installant une Debian j'ai vu que le chipset n'était pas le même que les cartes que j'avais préconisées. Comme c'est une installation distante je n'avais pas pu personnellement vérifier. En tout cas je te remercie pour ton aide Juve, je ferai un retour lorsque j'aurai réussi à installer les bonnes cartes.
    Mais je regardait pour changer de carte 4 ports en pci-e, il en existe peu qui sont compatible avec pfsense.



  • Oui en ce moment c'est compliqué, les drivers Intel pour BSD ont une bonne buglist.

    Soit tu prends du chipset Intel, ce qui marche le mieux mais qui depuis un certain temps pose pas mal de problèmes à cause du driver IGB (notamment la gestion du Large Receive Offload, à désactiver en 1.2.3 sinon débit de 80ko/s).

    Soit tu prends du chipset Broadcom. Si tu n' as pas beaucoup d'interfaces ca peut le faire mais si tu en as 8 (ou plus)  avec le driver BGE/BCE tu peux te retrouver dans une situation ou il n'y a plus assez d'espace memoire pour le kernel car le driver est trop gourmand.

    Il faut essayer de prendre des cartes pas trop récentes, qui sont commercialisée depuis au moins 1 à 2 ans.


Log in to reply