Set interface speed



  • Is there a way to force the interface speed to on a wireless interface?  I would like to force the speed of the interface down to 1MB in the config file, so after a reboot it holds.  We can do it via Shell , but if you reboot the unit it wipes that change.  The wireless chipset we are using is mini-PCI Broadcom BCM94318MPAGH (Rev. A01) in a 128MB WRAP board.  We are wrapping in a NDIS driver to allow support.





  • I have set them in the config file as you said, but it just ignores them and stays with auto.  This is a driver wrapped using NDIS, could that be why?

    <media>DS/1Mbps</media>



  • u can use shellcommand's
    <shellcmd>commando</shellcmd>



  • Well I could consider that, but I just logged in to Shell and ran "ifconfig ndis0 media DS/1Mbps mode 11b" (tried w/ and w/o the "mode 11b") and when I'd run "ifconfig ndis0" it still shows it's on auto because it's still connect to the 802.11G AP at OFDM/54Mbps.  I had already checked and the media and mode I am trying to use is support according to the "ifconfig -m" output.



  • you can also hardcode this in the php where the wireless settings are generated.
    Take a look at /etc/inc/interfaces.inc scroll down to the wireless section.
    Almost at the bottom of the wireles setup funtion you will see all that is written out to the .sh script that activates the changes.
    Here you can add whatever settings you would like to hardcode. The settings will stick untill that file is updated during firmware updates and such. Or you could add a bounty to get the speed settings added to the GUI.
    I will be taking a bounty for updating the wireless with new funtions that i have been working on. It's a work in progress so feel free to set up a bounty with whatever requests you have for wireless enhancements.



  • Thank you very much for that additional information.  My biggest problem is right now that even from Shell I can not force the rate down and am confused if this is a glitch in FreeBSD or an issue because the driver is using an NDIS wrapped driver so we can have CCX support in the drivers as there are no open sourced drivers with CCX support.  As mentioned the "ifconfig -m" shows it as an optional media and mode and if I set the AP down to that media/mode only then it connects like that but otherwise it will only try to connect at the max the AP is offering.
    Does anyone else have any suggestions on why I can't even force the media/mode down from Shell directly?  If I could get this to work I could write it into the .xml file and load it.


Log in to reply