SquidGuard



  • Bonjour

    Je viens de découvrir PfSense, j'ai donc dépoussiéré mon fidèle PIII.

    Je ne connais Linux que de nom. Je suis néophyte en sécurité informatique.  ::)

    PfSense est opérationnel (enfin je crois    ???). Après de nombreux problèmes entre mon siège et mon clavier.

    Je tente depuis deux jours de mettre en œuvre Squiguard. Les packages sont installés, la blacklist est je crois chargée (comment faire pour le contrôler ?)
    Mais le Proxy ne filtre rien. J’ai cherché sur le forum PfSense et sur Google, mais je ne trouve pas de tutoriel adapté à mon niveau plus que débutant.

    Si quelqu’un pouvait de donner un coup de main, je serai très content.

    En vous souhaitant un bon week-end.

    Christophe



  • Si squid n'est pas en mode transparent, il faut indiquer l'adresse du proxy dans le navigateur: IP du proxy, port 3128
    Il faudrait détailler un peu plus:adressage du réseau, etc…



  • Bonsoir

    –> FreeBox --> DHCP --> PfSense -->  IP : 192.168.200.1 --> Routeur --> PC : IP : 192.168.200.100
                    DNS : 212.27.40.240          No DHCP 
                              212.27.40.241

    Mode Transparent ....??? Mais si les PC doivent pointer vers le proxy alors il faut désactiver le mode sans proxy ??

    A+



  • Si le mode "transparent" de squid est activé, pas besoin d'indiquer une adresse de proxy dans le navigateur d'un poste client.
    Si ce mode n'est pas activé, alors il faut obligatoire indiquer l'adresse de proxy.



  • Salut

    Vérifie d'avoir bien utilisé le bouton "apply" dans la config de squidguard, je me suis souvent fait avoir après des réglages de blacklist.
    Si tu veux tu peux poster ici ton fichier de configuration du serveur proxy (squid) et celui du filtre (squidguard)
    Le contenu des deux fichier sont tout deux accessibles via
    Proxy Filter => Log => onglet : Proxy Filter  et Proxy Server.



  • Bonjour

    Me revoilà et toujours pas de filtrage…

    Proxy Config

    # Do not edit manually !
    http_port 192.168.200.1:3128
    http_port 127.0.0.1:80 transparent
    icp_port 0
    
    pid_filename /var/run/squid.pid
    cache_effective_user proxy
    cache_effective_group proxy
    error_directory /usr/local/etc/squid/errors/French
    icon_directory /usr/local/etc/squid/icons
    visible_hostname localhost
    cache_mgr admin@localhost
    access_log /dev/null
    cache_log /var/squid/logs/cache.log
    cache_store_log none
    shutdown_lifetime 3 seconds
    uri_whitespace strip
    
    cache_mem 8 MB
    maximum_object_size_in_memory 32 KB
    memory_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA
    cache_dir ufs /var/squid/cache 100 16 256
    minimum_object_size 0 KB
    maximum_object_size 10 KB
    offline_mode off
    
    # No redirector configured
    
    # Setup some default acls
    acl all src 0.0.0.0/0.0.0.0
    acl localhost src 127.0.0.1/255.255.255.255
    acl safeports port 21 70 80 210 280 443 488 563 591 631 777 901 443 3128 1025-65535 
    acl sslports port 443 563 443 
    acl manager proto cache_object
    acl purge method PURGE
    acl connect method CONNECT
    acl dynamic urlpath_regex cgi-bin ?
    cache deny dynamic
    http_access allow manager localhost
    
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !safeports
    http_access deny CONNECT !sslports
    
    # Always allow localhost connections
    http_access allow localhost
    
    request_body_max_size 0 KB
    reply_body_max_size 0 deny all
    delay_pools 1
    delay_class 1 2
    delay_parameters 1 -1/-1 -1/-1
    delay_initial_bucket_level 100
    delay_access 1 allow all
    
    # Setup allowed acls
    # Custom options
    redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf
    redirector_bypass on
    redirect_children 3
    # Default block all to be sure
    http_access deny all
    
    

    Filter config

    # ============================================================
    # SquidGuard configuration file
    # This file generated automaticly with SquidGuard configurator
    # (C)2006 Serg Dvoriancev
    # email: dv_serg@mail.ru
    # ============================================================
    
    logdir /var/squidGuard/log
    dbhome /var/db/squidGuard
    
    # 
    dest blk_squidGuard-1.2.0_test_blacklist {
    	domainlist blk_squidGuard-1.2.0_test_blacklist/domains
    	expressionlist blk_squidGuard-1.2.0_test_blacklist/expressions
    	urllist blk_squidGuard-1.2.0_test_blacklist/urls
    }
    
    # 
    rew safesearch {
    	s@(google..*/search?.*q=.*)@&safe=active@i
    	s@(google..*/images.*q=.*)@&safe=active@i
    	s@(google..*/groups.*q=.*)@&safe=active@i
    	s@(google..*/news.*q=.*)@&safe=active@i
    	s@(yandex..*/yandsearch?.*text=.*)@&fyandex=1@i
    	s@(search.yahoo..*/search.*p=.*)@&vm=r&v=1@i
    	s@(search.live..*/.*q=.*)@&adlt=strict@i
    	s@(search.msn..*/.*q=.*)@&adlt=strict@i
    	s@(.bing..*/.*q=.*)@&adlt=strict@i
    }
    
    # 
    acl  {
    	# 
    	default  {
    		pass none
    		redirect http://192.168.200.1:443/sgerror.php?url=403%20&a=%a&n=%n&i=%i&s=%s&t=%t&u=%u
    	}
    }
    

    Merci pour le temps que vous me consacrez



  • Dans ta configuration actuelle tu n'as pas besoin de configurer l'ordinateur, tu es en proxy transparent.
    Essaye de rechercher des site porno sur Google, si Squidguard est actif les résultat seront normalement censurés (safesearch).


Log in to reply