OpenVPN not working properly after switching to 2.0



  • Hello,

    I had installed two new virtual machines with pfsense 2.0, with the same settings as my older ones.
    Between them, there is a TCP OpenVPN tunnel through a proxy, and all traffic from that site is routed through the tunnel.
    On my old config based on 1.2.3, I had no problems, it did not require any special tweaks on the MTU.
    When using 2.0, the tunnel gets up just fine, samba traffic works ok at 1MB/s between sites but when trying to browse the web the tunnel breaks.
    I also tried pinging, ping -l 1376 crashes the tunnel, -l 1375 is ok.
    Now, I have tried different settings for the tun-mtu: tun-mtu 1300 is ok for ping -l 1376, but web traffic crashes the tunnel. Also, ping -l 5000 crashes the tunnel too.
    Trying to set MTU 1400 on the network interfaces, web browsing is ok for 90% of the sites - gmail, yahoo, msn.com are not working, ping -l 5000 also crashes the tunnel.

    Any clues?



  • It works after changing the MTU only for the wan interface facing the proxy to 1200, 1300 won't work. Weird thing…


Log in to reply