Captive Portal: Does not prompt users to authenticate



  • I'm having an issue with the captive portal authentication page not showing up to prompt users. I've done a clean install of pfSense 1.2.3 and have configured it from the ground up a few times. What I have is:

    Captive portal:
        Running with local user authentication or no user authentication. They both work, however the end user still isn't prompted with the login page. I've got traffic shaping setup limiting the users. I've got a custom login page with the code here:

    
    <title>removed: Internet Portal</title>
    
    				Welcome to: 
     the removed 
     Free WiFi Portal! 
    
    				To access the Internet click the login button below.
    
    <center>![Welcome to removed!](captiveportal-logo.png)</center>
    
    		 | 					
    
    Copyright © 2011 removed, Ltd. All rights reserved.
    
    Please read our [Privacy Statement](tac.html) and [Terms of Use](captiveportal-tac.html).
    
    

    I also have some firewall rules setup:

    1. Block all traffic from the portal heading to the private network.
    2. Block all traffic from the portal on non business hours.

    Any help would be great! I've been working at this for a while now and it seems like I'm doing something wrong here…  I can post more information if need. Thank you.



  • I am still doing some testing, so far all my firewall rules are working including the scheduling. Right now the captive portal is still not functioning. I can reach the portal page at 192.168.2.1:8000 so I know that's working. I am guessing it might be an issue with my DNS server settings. I've got the LAN IP for the first DNS, second I've got set to 8.8.8.8. Any advice would be great!

    Thanks!


  • Rebel Alliance Developer Netgate

    Depending on your firewall rules there, you probably need to have a pass rule for tcp/udp port 53 to the firewall's IP on that network, and you probably need to add 8.8.8.8 to the captive portal IP bypass if that DNS server is being directly assigned to clients.


Log in to reply