Site to Site OpenVPN Question



  • Hi, I've been working on this for 2 weeks and haven't gotten it to work.  I'm very novice when it comes to things like this so I'm about ready to quit my job cuz of this.  Needless to say, I have almost no clue as to what I am doing.

    I'm at a main campus that needs a main site and a remote site to connect.  We're running a VPN pfSense instance here and have a physical box out at 2 other remote sites.  I'm trying to set up one for a 3rd site and can't get it to work.

    pfSense 1.2.3                                                                                     pfSense 2.0 RC1
    [Main Campus|172.16.x.x]-[VPN Tunnel|172.27.1.9]–---[The Interwebs]–---[VPN Tunnel|172.27.1.10]–[Remote Site|172.18.x.x]

    What else, what else…I'm using Shared Key (that's how the other sites are set up), and LZO Compression and UDP.

    I can ping everything...sort of.  I'm getting a ton of packet loss (30-40%... sometimes more) so while I can ping the remote side, when I'm there, I can't do anything.

    Thankfully this is all in my office for now, as I have an external IP to use.  Once I get it working it here, I can take it out to the field.

    On top of that, once I get VPN working, I need to set up the remote site so that the pfSense box creates a Wireless Bridge to my dd-wrt box, so that the person in their office (which doesn't have network ports or even a phone line) can connect to us.

    I'm not sure what I need to provide so that this makes more sense to anyone available to help, but please let me know.  I'll do what I can to get the information.  I'm very new to this.


Locked