[OpenVPN] Push DNS



  • Bonjour à tous!

    Voilà je vous explique. Je tourne actuellement sur une PfSense 2.0RC1, avec un client OpenVPN dessus.

    Seul problème, le push dns ne fonctionne pas. J'ai bien le redirect def1 par contre.

    Est-ce un problème connu?



  • Personne?



  • Je m'excuse, en utilisant Google Translate

    Ne devrait pas être un problème tant que vous utilisez les serveurs DNS de dépose sur le fond de la configuration ainsi que la force tout le trafic par le tunnel.






  • Avec la VO on comprendrait sans doute un peu mieux…
    Votre problème est bien de "pousser" les option dns vers le client lors de l'établissement de la connexion vpn ?
    Qu'est ce qui vous fait dire que cela ne marche pas ?



  • Bonjour.

    Oui en effet. Le redirect-gateway def 1 fonctionne bien mais apparemment, le DNS serai poussé mais non pris en compte par pfSense.



  • le DNS serai poussé mais non pris en compte par pfSense

    Désolé, c'est incompréhensible pour moi !

    Soit dans la config openVPN de pfSense on indique un serveur dns (par exemple, celui du réseau LAN) et il est fourni au client (vérification à faire par "ipconfig /all")

    Soit on dit d'une voix forte "OpenVPN ouvre-toi" (à moins que ce soit "Susanne ouvre toi" …)



  • @jdh:

    le DNS serai poussé mais non pris en compte par pfSense

    Désolé, c'est incompréhensible pour moi !

    J'allais le dire. Si l'info est envoyé au client je ne comprend ni comment, ni pourquoi Pfsense pourrait la prendre en compte.



  • ah je vient de comprendre…Enfin je ne me suis pas bien fait comprendre plutôt.

    C'est le pfSense le client! Le serveur étant sur une Debian.

    Dans la config du serveur, j'ai une ligne qui permet de "pusher" le DNS au client, mais pfSense ne le prend pas en compte.

    Désolé si je peut paraitre confus.

    EDIT : Ligne du serveur : push "dhcp-option DNS 10.7.0.1"



  • En fait vous êtes en vpn site à site ? Sinon Pfsense en client vpn prenant l'option Push du dhcp ????



  • Oui je suis en site-à-site.

    Sinon Pfsense en client vpn prenant l'option Push du dhcp Huh?

    Je ne comprend pas…



  • Dans OpenVPN: Server comment avez vous configuré Server mode ?
    Le plus simple serait de poster la copie d'écran de votre configuration vpn.



  • Voici le CCD pour le pfSense :

    
    iroute 10.3.0.0 255.255.255.0
    push "route 10.10.0.16 255.255.255.240"
    push "redirect-gateway def1"
    push "dhcp-option DNS 10.7.0.1"
    
    


  • A nouveau :

    Dans OpenVPN: Server comment avez vous configuré Server mode ?

    Et une copie d'écran.



  • C'est le pfSense le client! Le serveur étant sur une Debian.



  • Pfsense est soit serveur pour des nomades, soit passerelle dans le mode site à site. Mais pas client. Terminé pour moi.



  • Je confirme le problème (même s'il est pas très bien décrit).

    Une config que je gère :

    • un site central avec pfSense (1.2.3 / SDSL)
    • un petit site distant avec un pfSense (1.2.3 / ADSL / box)
      La box empêche ipsec de fonctionner donc j'ai configuré le pfSense distant en client OpenVPN.
      J'ai ajouté un "client-specific configuration" avec un "iroute" + une route statique sur l'ip fixe optenu par le client OpenVPN.

    Le pfSense distant reçoit sans doute le dns fourni par le pfSense central (config habituelle pour road-warrior) mais ne s'en sert pas !

    Néanmoins, dans le dhcp que le pfSense distant fournit aux pc locaux, j'indique le dns central de façon à ce qu'il ne soit pas différent des pc centraux !

    Peut-être eut-il fallu indiquer le dns central comme premier dns du pfsense distant et non la box ?



  • Pfsense est soit serveur pour des nomades, soit passerelle dans le mode site à site. Mais pas client. Terminé pour moi.

    Bon…

    1. Mon OpenVPN ( sur le pfSense ) est un client
    2. Le-dit pfSense est également passerelle pour les machines du réseau et le réseau distant.

    Donc si, mon pfSense est un client malgré tout.

    Si effectivement je m'exprime mal, veuillez m'en excuser.

    EDIT : @jdh : Normalement, le client OVPN est sensé recevoir et tenir compte de la config pushé par le serveur... DNS compris. Est-ce un bug?



Log in to reply