Linksys WUSB54G rev C wifi AP problem



  • trying to setup Alfa AWUS036NH as AP in 2.0 but looks like driver is not supported:

    Apr 1 11:16:09 php: /interfaces.php: Cloning new wireless interface urtw0_wlan0
    Apr 1 11:16:09 php: /interfaces.php: Failed to clone interface urtw0 with error code 1, output ifconfig: SIOCIFCREATE2: Operation not supported
    Apr 1 11:16:09 kernel: urtw0: HOSTAP mode not supported

    I wish this could work with 2.0 :(

    Thank You



  • FreeBSD doesn't support Access Point (AP) mode on your wireless NIC, see the FreeBSD urtw manpage. Buy one that supports AP mode, e.g. Tenda W311U or TP-LInk TL-WN321G, supported by run and rum drivers respectively. Both of these use Ralink chipsets. It appears there are a number of other brands and models using the same chipsets.



  • thx

    i hva ejust noticed that http://www.freebsd.org/releases/7.2R/hardware.html#WLAN

    it is all compatybile list that should work with pfsense as AP …..



  • OK I give up …..

    I have found that I owned •Linksys WUSB54G rev C that is compatybile in AP mode but after setuing it up and trying to connect client I have cernel panic in pfsesne 2.0

    [2.0-RC1][root@pfsense.home]/root(1): ifconfig
    bge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=8009b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,linkstate>ether 00:0f:20:74:27:b7
            inet 192.168.99.1 netmask 0xffffff00 broadcast 192.168.99.255
            inet6 fe80::20f:20ff:fe74:27b7%bge0 prefixlen 64 scopeid 0x1
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    fxp0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=209b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic>ether 00:0e:0c:aa:a1:1b
            inet6 fe80::20e:cff:feaa:a11b%fxp0 prefixlen 64 scopeid 0x2
            inet 24.13.142.245 netmask 0xfffff800 broadcast 255.255.255.255
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    em0: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
            options=209b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic>ether 00:1b:21:08:81:0b
            media: Ethernet autoselect
            status: no carrier
    plip0: flags=8810 <pointopoint,simplex,multicast>metric 0 mtu 1500
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
            nd6 options=3 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
            syncpeer: 224.0.0.240 maxupd: 128
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    enc0: flags=0<> metric 0 mtu 1536
    rum0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 00:1e:e5:fc:9f:3e
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    rum0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 00:1e:e5:fc:9f:3e
            inet6 fe80::21e:e5ff:fefc:9f3e%rum0_wlan0 prefixlen 64 scopeid 0xa
            inet 192.168.98.1 netmask 0xffffff00 broadcast 192.168.98.255
            nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
            ssid pf-home channel 1 (2412 MHz 11g) bssid 00:1e:e5:fc:9f:3e
            country US authmode OPEN privacy OFF txpower 0 scanvalid 60
            protmode OFF -apbridge dtimperiod 1 -dfs
    ovpns1: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
            options=80000 <linkstate>inet6 fe80::20f:20ff:fe74:27b7%ovpns1 prefixlen 64 scopeid 0xb
            inet 10.0.7.1 –> 10.0.7.2 netmask 0xffffffff
            nd6 options=3 <performnud,accept_rtadv>Opened by PID 23233
    ovpnc2: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
            options=80000 <linkstate>inet6 fe80::20f:20ff:fe74:27b7%ovpnc2 prefixlen 64 scopeid 0xc
            inet 10.0.8.2 --> 10.0.8.1 netmask 0xffffffff
            nd6 options=3 <performnud,accept_rtadv>Opened by PID 24816
    [2.0-RC1][root@pfsense.home]/root(2):</performnud,accept_rtadv></linkstate></up,pointopoint,running,multicast></performnud,accept_rtadv></linkstate></up,pointopoint,running,multicast></hostap></performnud,accept_rtadv></up,broadcast,running,simplex,multicast></hostap></up,broadcast,running,simplex,multicast></promisc></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></pointopoint,simplex,multicast></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic></broadcast,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,linkstate></up,broadcast,running,simplex,multicast>



  • message is

    fatal trap 18 integrer deivide fault while inkernel mode

    stopped at rum_setup_tx_desc …...................

    ANY ADVICE??????????????????



  • looking at

    rum0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 00:1e:e5:fc:9f:3e
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    rum0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 00:1e:e5:fc:9f:3e
            inet6 fe80::21e:e5ff:fefc:9f3e%rum0_wlan0 prefixlen 64 scopeid 0xa
            inet 192.168.98.1 netmask 0xffffff00 broadcast 192.168.98.255
            nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
            ssid pf-home channel 1 (2412 MHz 11g) bssid 00:1e:e5:fc:9f:3e
            country US authmode OPEN privacy OFF txpower 0 scanvalid 60
            protmode OFF -apbridge dtimperiod 1 -dfs

    looks ok</hostap></performnud,accept_rtadv></up,broadcast,running,simplex,multicast></hostap></up,broadcast,running,simplex,multicast>



  • Try enabling encryption: WPA2/AES and/or apbridge.

    I had to temporarily take my "rum0" out of service to use in another machine. It looks line your configuration differs from the one I was using in those two parameters.



  • thank you for help

    any way does not work :(  Easier was pluging WRT54G to DMZ and this way works ….... I believe the only way is buying some wifi card that is already checked with pfsense 2.0 and approved by forum.

    thank you


Locked