Уже второй раз обрывается связь PPPoE.



  • Ситуация в следующем. На этих выходных пропал доступ через инет к шлюзу. Поехал на работу, из локали захожу на шлюз и вижу, что связи PPPoE нет, жму "соединиться" и ноль эмоций. Тупо грузанул его и все поехало. Сейчас снова какие-то танцы.
    Вобщем, что где искать, на что смотреть? А то каждые три дня ездить его перегружать - не вариант :(

    Спасибо.



  • @denis-k:

    Ситуация в следующем. На этих выходных пропал доступ через инет к шлюзу. Поехал на работу, из локали захожу на шлюз и вижу, что связи PPPoE нет, жму "соединиться" и ноль эмоций. Тупо грузанул его и все поехало. Сейчас снова какие-то танцы.
    Вобщем, что где искать, на что смотреть? А то каждые три дня ездить его перегружать - не вариант :(

    Спасибо.

    Логи в студию и посмотри что с arp !!!!



  • Этот system.log скопировал перед перезагрузкой:

    
    Apr  2 17:39:15 pfsense syslogd: kernel boot file is /boot/kernel/kernel
    Apr  2 17:39:26 pfsense syslogd: exiting on signal 15
    Apr  2 17:39:26 pfsense syslogd: kernel boot file is /boot/kernel/kernel
    Apr  2 17:55:35 pfsense mpd: [pppoe] LCP: no reply to 1 echo request(s)
    Apr  2 17:55:45 pfsense mpd: [pppoe] LCP: no reply to 2 echo request(s)
    Apr  2 18:19:45 pfsense mpd: [pppoe] LCP: no reply to 1 echo request(s)
    Apr  2 18:19:55 pfsense mpd: [pppoe] LCP: no reply to 2 echo request(s)
    Apr  2 18:41:05 pfsense mpd: [pppoe] LCP: no reply to 1 echo request(s)
    Apr  2 19:01:15 pfsense mpd: [pppoe] LCP: no reply to 1 echo request(s)
    Apr  2 19:01:25 pfsense mpd: [pppoe] LCP: no reply to 2 echo request(s)
    Apr  2 19:44:26 pfsense mpd: [pppoe] LCP: no reply to 1 echo request(s)
    Apr  2 19:44:36 pfsense mpd: [pppoe] LCP: no reply to 2 echo request(s)
    Apr  2 20:44:36 pfsense mpd: [pppoe] LCP: no reply to 1 echo request(s)
    Apr  2 20:45:06 pfsense mpd: [pppoe] LCP: no reply to 1 echo request(s)
    Apr  2 20:45:51 pfsense mpd: [pppoe] PPPoE connection closed
    Apr  2 20:45:51 pfsense mpd: [pppoe] device: DOWN event in state UP
    Apr  2 20:45:51 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:45:51 pfsense mpd: [pppoe] link: DOWN event
    Apr  2 20:45:51 pfsense mpd: [pppoe] LCP: Down event
    Apr  2 20:45:51 pfsense mpd: [pppoe] LCP: state change Opened --> Starting
    Apr  2 20:45:51 pfsense mpd: [pppoe] LCP: phase shift NETWORK --> DEAD
    Apr  2 20:45:51 pfsense mpd: [pppoe] setting interface ng0 MTU to 1500 bytes
    Apr  2 20:45:51 pfsense mpd: [pppoe] up: 0 links, total bandwidth 9600 bps
    Apr  2 20:45:51 pfsense mpd: [pppoe] IPCP: Down event
    Apr  2 20:45:51 pfsense mpd: [pppoe] IPCP: state change Opened --> Starting
    Apr  2 20:45:51 pfsense mpd: [pppoe] IPCP: LayerDown
    Apr  2 20:45:51 pfsense mpd: [pppoe] IFACE: Down event
    Apr  2 20:45:51 pfsense mpd: [pppoe] exec: /sbin/route delete 0.0.0.0 80.80.111.97
    Apr  2 20:45:51 pfsense mpd: [pppoe] exec: /sbin/route delete ***.***.***.*** -iface lo0
    Apr  2 20:45:51 pfsense mpd: [pppoe] exec: /sbin/ifconfig ng0 down delete -link0
    Apr  2 20:45:51 pfsense mpd: [pppoe] LCP: LayerDown
    Apr  2 20:45:51 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:45:51 pfsense mpd: [pppoe] pausing 6 seconds before open
    Apr  2 20:45:51 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:45:54 pfsense mpd: [pppoe] closing link "pppoe"...
    Apr  2 20:45:54 pfsense mpd: [pppoe] link: CLOSE event
    Apr  2 20:45:54 pfsense mpd: [pppoe] LCP: Close event
    Apr  2 20:45:54 pfsense mpd: [pppoe] LCP: state change Starting --> Initial
    Apr  2 20:45:54 pfsense mpd: [pppoe] LCP: LayerFinish
    Apr  2 20:45:54 pfsense mpd: [pppoe] device: CLOSE event in state DOWN
    Apr  2 20:45:54 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:45:57 pfsense mpd: [pppoe] opening link "pppoe"...
    Apr  2 20:45:57 pfsense mpd: [pppoe] link: OPEN event
    Apr  2 20:45:57 pfsense mpd: [pppoe] LCP: Open event
    Apr  2 20:45:57 pfsense mpd: [pppoe] LCP: state change Initial --> Starting
    Apr  2 20:45:57 pfsense mpd: [pppoe] LCP: LayerStart
    Apr  2 20:45:57 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:45:57 pfsense mpd: [pppoe] device is now in state OPENING
    Apr  2 20:45:57 pfsense mpd: [pppoe] rec'd ACNAME "asr3-ats32"
    Apr  2 20:46:06 pfsense mpd: [pppoe] PPPoE connection timeout after 9 seconds
    Apr  2 20:46:06 pfsense mpd: [pppoe] device: DOWN event in state OPENING
    Apr  2 20:46:06 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:46:06 pfsense mpd: [pppoe] link: DOWN event
    Apr  2 20:46:06 pfsense mpd: [pppoe] LCP: Down event
    Apr  2 20:46:06 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:46:06 pfsense mpd: [pppoe] pausing 4 seconds before open
    Apr  2 20:46:06 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:46:10 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:46:10 pfsense mpd: [pppoe] pausing 2 seconds before open
    Apr  2 20:46:10 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:46:12 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:46:12 pfsense mpd: [pppoe] device is now in state OPENING
    Apr  2 20:46:18 pfsense mpd: [pppoe] rec'd ACNAME "asr2-ats32"
    Apr  2 20:46:21 pfsense mpd: [pppoe] PPPoE connection timeout after 9 seconds
    Apr  2 20:46:21 pfsense mpd: [pppoe] device: DOWN event in state OPENING
    Apr  2 20:46:21 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:46:21 pfsense mpd: [pppoe] link: DOWN event
    Apr  2 20:46:21 pfsense mpd: [pppoe] LCP: Down event
    Apr  2 20:46:21 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:46:21 pfsense mpd: [pppoe] pausing 6 seconds before open
    Apr  2 20:46:21 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:46:27 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:46:27 pfsense mpd: [pppoe] device is now in state OPENING
    Apr  2 20:46:36 pfsense mpd: [pppoe] PPPoE connection timeout after 9 seconds
    Apr  2 20:46:36 pfsense mpd: [pppoe] device: DOWN event in state OPENING
    Apr  2 20:46:36 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:46:36 pfsense mpd: [pppoe] link: DOWN event
    Apr  2 20:46:36 pfsense mpd: [pppoe] LCP: Down event
    Apr  2 20:46:36 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:46:36 pfsense mpd: [pppoe] pausing 4 seconds before open
    Apr  2 20:46:36 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:46:40 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:46:40 pfsense mpd: [pppoe] pausing 1 seconds before open
    Apr  2 20:46:40 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:46:41 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:46:41 pfsense mpd: [pppoe] device is now in state OPENING
    Apr  2 20:46:43 pfsense mpd: [pppoe] rec'd ACNAME "asr2-ats32"
    Apr  2 20:46:49 pfsense mpd: [pppoe] PPPoE connection successful
    Apr  2 20:46:49 pfsense mpd: [pppoe] device: UP event in state OPENING
    Apr  2 20:46:49 pfsense mpd: [pppoe] device is now in state UP
    Apr  2 20:46:49 pfsense mpd: [pppoe] link: UP event
    Apr  2 20:46:49 pfsense mpd: [pppoe] link: origination is local
    Apr  2 20:46:49 pfsense mpd: [pppoe] LCP: Up event
    Apr  2 20:46:49 pfsense mpd: [pppoe] LCP: state change Starting --> Req-Sent
    Apr  2 20:46:49 pfsense mpd: [pppoe] LCP: phase shift DEAD --> ESTABLISH
    Apr  2 20:46:49 pfsense mpd: [pppoe] LCP: SendConfigReq #24
    Apr  2 20:46:49 pfsense mpd:  MRU 1492
    Apr  2 20:46:49 pfsense mpd:  MAGICNUM 471202e9
    Apr  2 20:46:49 pfsense mpd: [pppoe] LCP: rec'd Configure Ack #24 link 0 (Req-Sent)
    Apr  2 20:46:49 pfsense mpd:  MRU 1492
    Apr  2 20:46:49 pfsense mpd:  MAGICNUM 471202e9
    Apr  2 20:46:49 pfsense mpd: [pppoe] LCP: state change Req-Sent --> Ack-Rcvd
    Apr  2 20:46:53 pfsense mpd: [pppoe] LCP: rec'd Configure Request #3 link 0 (Ack-Rcvd)
    Apr  2 20:46:53 pfsense mpd:  MRU 1492
    Apr  2 20:46:53 pfsense mpd:  AUTHPROTO PAP
    Apr  2 20:46:53 pfsense mpd:  MAGICNUM 8e6ba482
    Apr  2 20:46:53 pfsense mpd: [pppoe] LCP: SendConfigAck #3
    Apr  2 20:46:53 pfsense mpd:  MRU 1492
    Apr  2 20:46:53 pfsense mpd:  AUTHPROTO PAP
    Apr  2 20:46:53 pfsense mpd:  MAGICNUM 8e6ba482
    Apr  2 20:46:53 pfsense mpd: [pppoe] LCP: state change Ack-Rcvd --> Opened
    Apr  2 20:46:53 pfsense mpd: [pppoe] LCP: phase shift ESTABLISH --> AUTHENTICATE
    Apr  2 20:46:53 pfsense mpd: [pppoe] LCP: auth: peer wants PAP, I want nothing
    Apr  2 20:46:53 pfsense mpd: [pppoe] PAP: using authname "eprapads_ll121"
    Apr  2 20:46:53 pfsense mpd: [pppoe] PAP: sending REQUEST
    Apr  2 20:46:53 pfsense mpd: [pppoe] LCP: LayerUp
    Apr  2 20:46:55 pfsense mpd: [pppoe] PAP: using authname "eprapads_ll121"
    Apr  2 20:46:55 pfsense mpd: [pppoe] PAP: sending REQUEST
    Apr  2 20:46:57 pfsense mpd: [pppoe] PAP: using authname "eprapads_ll121"
    Apr  2 20:46:57 pfsense mpd: [pppoe] PAP: sending REQUEST
    Apr  2 20:47:13 pfsense mpd: [pppoe] LCP: authorization timer expired
    Apr  2 20:47:13 pfsense mpd: [pppoe] LCP: authorization failed
    Apr  2 20:47:13 pfsense mpd: [pppoe] device: CLOSE event in state UP
    Apr  2 20:47:13 pfsense mpd: [pppoe] device is now in state CLOSING
    Apr  2 20:47:13 pfsense mpd: [pppoe] device: DOWN event in state CLOSING
    Apr  2 20:47:13 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:47:13 pfsense mpd: [pppoe] link: DOWN event
    Apr  2 20:47:13 pfsense mpd: [pppoe] LCP: Down event
    Apr  2 20:47:13 pfsense mpd: [pppoe] LCP: state change Opened --> Starting
    Apr  2 20:47:13 pfsense mpd: [pppoe] LCP: phase shift AUTHENTICATE --> DEAD
    Apr  2 20:47:13 pfsense mpd: [pppoe] LCP: LayerDown
    Apr  2 20:47:13 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:47:13 pfsense mpd: [pppoe] pausing 6 seconds before open
    Apr  2 20:47:13 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:47:19 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:47:19 pfsense mpd: [pppoe] device is now in state OPENING
    Apr  2 20:47:28 pfsense mpd: [pppoe] PPPoE connection timeout after 9 seconds
    Apr  2 20:47:28 pfsense mpd: [pppoe] device: DOWN event in state OPENING
    Apr  2 20:47:28 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:47:28 pfsense mpd: [pppoe] link: DOWN event
    Apr  2 20:47:28 pfsense mpd: [pppoe] LCP: Down event
    Apr  2 20:47:28 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:47:28 pfsense mpd: [pppoe] pausing 4 seconds before open
    Apr  2 20:47:28 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:47:32 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:47:32 pfsense mpd: [pppoe] pausing 2 seconds before open
    Apr  2 20:47:32 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:47:34 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:47:34 pfsense mpd: [pppoe] device is now in state OPENING
    Apr  2 20:47:34 pfsense mpd: [pppoe] rec'd ACNAME "asr3-ats32"
    Apr  2 20:47:43 pfsense mpd: [pppoe] PPPoE connection timeout after 9 seconds
    Apr  2 20:47:43 pfsense mpd: [pppoe] device: DOWN event in state OPENING
    Apr  2 20:47:43 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:47:43 pfsense mpd: [pppoe] link: DOWN event
    Apr  2 20:47:43 pfsense mpd: [pppoe] LCP: Down event
    Apr  2 20:47:43 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:47:43 pfsense mpd: [pppoe] pausing 4 seconds before open
    Apr  2 20:47:43 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:47:47 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:47:47 pfsense mpd: [pppoe] pausing 1 seconds before open
    Apr  2 20:47:47 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:47:48 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:47:48 pfsense mpd: [pppoe] device is now in state OPENING
    Apr  2 20:47:48 pfsense mpd: [pppoe] rec'd ACNAME "asr2-ats32"
    Apr  2 20:47:57 pfsense mpd: [pppoe] PPPoE connection timeout after 9 seconds
    Apr  2 20:47:57 pfsense mpd: [pppoe] device: DOWN event in state OPENING
    Apr  2 20:47:57 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:47:57 pfsense mpd: [pppoe] link: DOWN event
    Apr  2 20:47:57 pfsense mpd: [pppoe] LCP: Down event
    Apr  2 20:47:57 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:47:57 pfsense mpd: [pppoe] pausing 6 seconds before open
    Apr  2 20:47:57 pfsense mpd: [pppoe] device is now in state DOWN
    Apr  2 20:48:03 pfsense mpd: [pppoe] device: OPEN event in state DOWN
    Apr  2 20:48:03 pfsense mpd: [pppoe] device is now in state OPENING
    Apr  2 20:48:05 pfsense mpd: [pppoe] rec'd ACNAME "asr2-ats32"
    Apr  2 20:48:05 pfsense mpd: [pppoe] PPPoE connection successful
    Apr  2 20:48:05 pfsense mpd: [pppoe] device: UP event in state OPENING
    Apr  2 20:48:05 pfsense mpd: [pppoe] device is now in state UP
    Apr  2 20:48:05 pfsense mpd: [pppoe] link: UP event
    Apr  2 20:48:05 pfsense mpd: [pppoe] link: origination is local
    Apr  2 20:48:05 pfsense mpd: [pppoe] LCP: Up event
    Apr  2 20:48:05 pfsense mpd: [pppoe] LCP: state change Starting --> Req-Sent
    Apr  2 20:48:05 pfsense mpd: [pppoe] LCP: phase shift DEAD --> ESTABLISH
    Apr  2 20:48:05 pfsense mpd: [pppoe] LCP: SendConfigReq #25
    Apr  2 20:48:05 pfsense mpd:  MRU 1492
    Apr  2 20:48:05 pfsense mpd:  MAGICNUM 45d19699
    Apr  2 20:48:05 pfsense mpd: [pppoe] LCP: rec'd Configure Ack #25 link 0 (Req-Sent)
    Apr  2 20:48:05 pfsense mpd:  MRU 1492
    Apr  2 20:48:05 pfsense mpd:  MAGICNUM 45d19699
    Apr  2 20:48:05 pfsense mpd: [pppoe] LCP: state change Req-Sent --> Ack-Rcvd
    Apr  3 06:05:00 pfsense check_reload_status: check_reload_status is starting
    Apr  3 10:00:00 pfsense check_reload_status: check_reload_status is starting
    Apr  4 08:57:34 pfsense mpd: [pppoe] rec'd signal usr1, opening
    Apr  4 08:57:34 pfsense mpd: [pppoe] IPCP: Open event
    Apr  4 08:57:34 pfsense mpd: [pppoe] bundle: OPEN event in state OPENED
    Apr  4 08:57:34 pfsense mpd: [pppoe] opening link "pppoe"...
    Apr  4 08:57:34 pfsense mpd: [pppoe] link: OPEN event
    Apr  4 08:57:34 pfsense mpd: [pppoe] LCP: Open event
    Apr  4 08:58:09 pfsense mpd: [pppoe] rec'd signal usr1, opening
    Apr  4 08:58:09 pfsense mpd: [pppoe] IPCP: Open event
    Apr  4 08:58:09 pfsense mpd: [pppoe] bundle: OPEN event in state OPENED
    Apr  4 08:58:09 pfsense mpd: [pppoe] opening link "pppoe"...
    Apr  4 08:58:09 pfsense mpd: [pppoe] link: OPEN event
    Apr  4 08:58:09 pfsense mpd: [pppoe] LCP: Open event
    Apr  4 08:58:34 pfsense mpd: [pppoe] rec'd signal usr1, opening
    Apr  4 08:58:34 pfsense mpd: [pppoe] IPCP: Open event
    Apr  4 08:58:34 pfsense mpd: [pppoe] bundle: OPEN event in state OPENED
    Apr  4 08:58:34 pfsense mpd: [pppoe] opening link "pppoe"...
    Apr  4 08:58:34 pfsense mpd: [pppoe] link: OPEN event
    Apr  4 08:58:34 pfsense mpd: [pppoe] LCP: Open event
    
    


  • Сегодня снова :(
    Ппц, FreeBSD с uptime не более двух дней…



  • Не надо на FreeBSD грешить. Какая версия pfSense?



  • @denis-k:

    Сегодня снова :(
    Ппц, FreeBSD с uptime не более двух дней…

    Пока разбираюсь с Сенсом, работает FBR-4000 от Level1 (разруливает и НАТит 3 ПППоЕ канала). Так эта сволочь, при потере соединения даже в лог как правило ничего не пишет ( !!!



  • @QWERTik:

    @denis-k:

    Сегодня снова :(
    Ппц, FreeBSD с uptime не более двух дней…

    Пока разбираюсь с Сенсом, работает FBR-4000 от Level1 (разруливает и НАТит 3 ПППоЕ канала). Так эта сволочь, при потере соединения даже в лог как правило ничего не пишет ( !!!

    1. Может быть проблема с физикой проблему можно решить подняв LCP таймаут но качество не добавит. Пропингуй сервер 1 и 2 килобайтными пакетами
    2. Может быть плохой сервер, перегружен запросами так что не успевает на ответы LCP (такое у меня было дома когда поключился к билайну, перешел на другого провайдера и все ок).
    3. А какой канал как построен, какая физика  ????



  • Нет, моё возмущение касалось именно китайской сырой поделки у которой при поддержке 4х ВАНов (ПППоЕ, ППТП, фэйловер и ещё кое-чего) системная флэш 2МБ, образ фирмвари - чуть более 700КБ, и рамы 8 или 16 МБ (уже не помню точно). От того на Сенс и переползаю!


Log in to reply