Is PPPOE working for you guys?



  • So I have thise 2wire f90 mode. i tried PPPOE on my windows xp laptop, works A OK.
    Now, I configured pfsense to do it, set the interface to PPPOE, put my username and pass, but it doesn't get an IP.

    I don't think it's even attempting to connect, using the Mar26 build.

    AMD64
    anyone else have similar problems?

    http://permalink.gmane.org/gmane.comp.security.firewalls.pfsense.support/22108

    I saw this, so that is why I am going to guess it's a pfsense 2.0 issue…



  • More detail

    Apr 7 15:30:29	ppp: [opt2_link0] LCP: Down event
    Apr 7 15:30:29	ppp: [opt2_link0] Link: reconnection attempt 459 in 2 seconds
    Apr 7 15:30:31	ppp: [opt2_link0] Link: reconnection attempt 459
    Apr 7 15:30:31	ppp: [opt2_link0] PPPoE: Skipping link "opt2_link0" with undefined interface
    Apr 7 15:30:31	ppp: [opt2_link0] PPPoE node for link is not initialized
    Apr 7 15:30:31	ppp: [opt2_link0] Link: DOWN event
    Apr 7 15:30:31	ppp: [opt2_link0] LCP: Down event
    Apr 7 15:30:31	ppp: [opt2_link0] Link: reconnection attempt 460 in 2 seconds
    Apr 7 15:30:33	ppp: [opt2_link0] Link: reconnection attempt 460
    Apr 7 15:30:33	ppp: [opt2_link0] PPPoE: Skipping link "opt2_link0" with undefined interface
    Apr 7 15:30:33	ppp: [opt2_link0] PPPoE node for link is not initialized
    Apr 7 15:30:33	ppp: [opt2_link0] Link: DOWN event
    Apr 7 15:30:33	ppp: [opt2_link0] LCP: Down event
    Apr 7 15:30:33	ppp: [opt2_link0] Link: reconnection attempt 461 in 4 seconds
    Apr 7 15:30:37	ppp: [opt2_link0] Link: reconnection attempt 461
    Apr 7 15:30:37	ppp: [opt2_link0] PPPoE: Skipping link "opt2_link0" with undefined interface
    Apr 7 15:30:37	ppp: [opt2_link0] PPPoE node for link is not initialized
    Apr 7 15:30:37	ppp: [opt2_link0] Link: DOWN event
    Apr 7 15:30:37	ppp: [opt2_link0] LCP: Down event
    Apr 7 15:30:37	ppp: [opt2_link0] Link: reconnection attempt 462 in 3 seconds
    Apr 7 15:30:40	ppp: [opt2_link0] Link: reconnection attempt 462
    Apr 7 15:30:40	ppp: [opt2_link0] PPPoE: Skipping link "opt2_link0" with undefined interface
    Apr 7 15:30:40	ppp: [opt2_link0] PPPoE node for link is not initialized
    Apr 7 15:30:40	ppp: [opt2_link0] Link: DOWN event
    Apr 7 15:30:40	ppp: [opt2_link0] LCP: Down event
    Apr 7 15:30:40	ppp: [opt2_link0] Link: reconnection attempt 463 in 4 seconds
    Apr 7 15:30:44	ppp: [opt2_link0] Link: reconnection attempt 463
    Apr 7 15:30:44	ppp: [opt2_link0] PPPoE: Skipping link "opt2_link0" with undefined interface
    Apr 7 15:30:44	ppp: [opt2_link0] PPPoE node for link is not initialized
    Apr 7 15:30:44	ppp: [opt2_link0] Link: DOWN event
    Apr 7 15:30:44	ppp: [opt2_link0] LCP: Down event
    Apr 7 15:30:44	ppp: [opt2_link0] Link: reconnection attempt 464 in 1 seconds
    Apr 7 15:30:45	ppp: [opt2_link0] Link: reconnection attempt 464
    Apr 7 15:30:45	ppp: [opt2_link0] PPPoE: Skipping link "opt2_link0" with undefined interface
    Apr 7 15:30:45	ppp: [opt2_link0] PPPoE node for link is not initialized
    Apr 7 15:30:45	ppp: [opt2_link0] Link: DOWN event
    Apr 7 15:30:45	ppp: [opt2_link0] LCP: Down event
    Apr 7 15:30:45	ppp: [opt2_link0] Link: reconnection attempt 465 in 3 seconds
    Apr 7 15:30:48	ppp: [opt2_link0] Link: reconnection attempt 465
    Apr 7 15:30:48	ppp: [opt2_link0] PPPoE: Skipping link "opt2_link0" with undefined interface
    Apr 7 15:30:48	ppp: [opt2_link0] PPPoE node for link is not initialized
    Apr 7 15:30:48	ppp: [opt2_link0] Link: DOWN event
    Apr 7 15:30:48	ppp: [opt2_link0] LCP: Down event
    Apr 7 15:30:48	ppp: [opt2_link0] Link: reconnection attempt 466 in 3 seconds
    Apr 7 15:30:51	ppp: [opt2_link0] Link: reconnection attempt 466
    Apr 7 15:30:51	ppp: [opt2_link0] PPPoE: Skipping link "opt2_link0" with undefined interface
    Apr 7 15:30:51	ppp: [opt2_link0] PPPoE node for link is not initialized
    Apr 7 15:30:51	ppp: [opt2_link0] Link: DOWN event
    Apr 7 15:30:51	ppp: [opt2_link0] LCP: Down event
    Apr 7 15:30:51	ppp: [opt2_link0] Link: reconnection attempt 467 in 4 seconds
    


  • Actually it was just misconfigured, fixed the configuration, but still a no go

    Apr 7 16:35:43	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:35:43	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:35:43	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:35:43	ppp: [opt2_link0] Link: reconnection attempt 1 in 4 seconds
    Apr 7 16:35:47	ppp: [opt2_link0] Link: reconnection attempt 1
    Apr 7 16:35:47	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:35:56	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:35:56	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:35:56	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:35:56	ppp: [opt2_link0] Link: reconnection attempt 2 in 3 seconds
    Apr 7 16:35:59	ppp: [opt2_link0] Link: reconnection attempt 2
    Apr 7 16:35:59	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:36:08	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:36:08	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:36:08	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:36:08	ppp: [opt2_link0] Link: reconnection attempt 3 in 3 seconds
    Apr 7 16:36:11	ppp: [opt2_link0] Link: reconnection attempt 3
    Apr 7 16:36:11	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:36:20	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:36:20	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:36:20	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:36:20	ppp: [opt2_link0] Link: reconnection attempt 4 in 1 seconds
    Apr 7 16:36:21	ppp: [opt2_link0] Link: reconnection attempt 4
    Apr 7 16:36:21	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:36:30	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    

    Tried rebooting pfsense and everything…

    EDIT: Tried pfsense 1.2.3 livecd, and PPPOE is not an option of the interface I want... I think I rmemeber reading somewhere only the WAN interface can be PPPOE in pfsense 1.2.3

    Just tried an old ass linksys router, and that worked. Shame pfsense, shame.



  • On the interface you are trying to set up…

    Go to interfaces/assign and delete it.

    Go to interfaces/assign/PPPs and set it up there...  You can choose your interface there.

    See if it gets you better results.



  • jigglywiggly,
    I was having the same issue on 2.0. Somehow the interfaces & PPP sections get out of sync or something. I ended up setting all PPPoE interfaces to non PPPoE, saved & applied. Went & deleted all PPP entries, rebooted, checked logs to make sure there were no PPPoE attempts then changed each interface back to PPPoE entering settings on that screen & saving WITHOUT clicking on advanced 'click here' link as that might be what I did to muck it up. Also, I noticed one of my WAN connections requires NULL service namje box to be checked but that is only available on the PPP settings screen itself not on the interface screen. (It says you can leave it blank but it doesn't work for me if left blank).

    PPPoE on multiple wan's seems to work great in 2.0 once you get past the hurdles (WHATEVER YOU DO, DO NOT PICK THE WRONG INTERFACE ON PPP SCREEN! I did that & pfsense would no longer boot!  It'd get to some screen where it was trying to bind to the pppoe & puke with cryptic messages. I ended up having to reinstall pfsense so glad it was a test box.) but seems the web interface still has some work to be done. In meantime trick seems to be to avoid clicking advanced (especially when initially setting up or the linked PPP is foobar), avoid entering values in fields you don't use (DoD & idle timeout fields were a bitch for me once I made mistake of entering 0 & what seemed no going back) and realizing it might require deleting them & starting over like I described above if some stray setting gets saved on accident. :D (That odd logging you posted seems to be tell-tale sign PPP is F'd & needs above to start over)
    Bill



  • Good news, I've decided to not use pfsense for pppoe at all and just let my modem handle it after reading that post  :P



  • I am and it is working reliably now. Was a bit of a pig to setup however, i think it had something to do adding a new pppoE connecting then assigning it to the interface rather than setting the interface to pppoE ( I cant remember the exact screens!)

    I do know one thing though, first time round it took upto 15mins to connect. Im not sure if it was something to do with the sessions at the ISP but after days of messing it eventually just connected all by itself.

    PS my log looked just like that too. Try tunning tpcdump -i <interface name="">you should see a few PADI packets going by.</interface>



  • Hello,

    I've exactly the same behaviour jigglywiggly had in his 3rd message.

    Whatever way I use to configure PPPoE gets me to the same result:
    ppp: [wan_link0] Link: reconnection attempt 3 in 3 seconds
    ppp: [wan_link0] Link: reconnection attempt 3
    ppp: [wan_link0] PPPoE: Connecting to '*'
    ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    ppp: [wan_link0] Link: DOWN event
    ppp: [wan_link0] LCP: Down event
    I tried by setting the "configure NULL service name" check box on and off.

    The physical configuration is exactly the same I used before with 1.2.3 (modem in bridge mode, connected to vr1 port of an Alix 2D13 board through HP switches on VLAN 10) and that worked flawlessly.

    I've tried various ways to configure this connection:

    • directly in the WAN interface (set it to PPPoE, configure)
    • indirectly, using the assign method, first create a PPPoE session on vr1, than assign PPPoE(vr1) to WAN
    • indirectly through VLAN, create the VLAN tag, assign OPTx to this, create the PPPoE session on OPTx assign PPPoE(OPTx) to WAN)
      None of these get further than "PPPoE connection timeout after XX seconds" (interfaces are correctly assigned - I had the second log message of jigglywiggly too).

    Nothing else than this laconic error comes in logs.
    Could someone come with an hint or give me a direction about what I could try?

    Thanks
    ChristOff



  • Hi all,

    I've had problems few days ago too with PPPOE, was transferring my old backup file to a new machine.
    After going through the logs, i remember that the interfaces were the issues.
    And i double checked and found out that the Bridge setting for WAN and LAN was gone on the new machine.
    So I went back to the new machine, corrected the interfaces, and added the Bridge. It solved my problem.




  • Thanks for your reply Newgen.

    I hadn't any bridge before (and don't understand why I would want one between Wan and Lan, as this is where I should have routing).
    Did it solve PPPoE timeout errors for you?



  • My PPPOE didn't work at all before I bridge the Wan and Lan interfaces.
    So yes, it did solve my problem.
    Why not just give it a try and repost logs that you get.

    Cheers



  • i've tried setting up pppoe on my machine and here is a snippet of the system log after trying to get it working

    May 2 15:44:29 php: : rc.newwanip: Informational is starting xl0.
    May 2 15:44:29 php: : rc.newwanip: on (IP address: 99.102.185.18) (interface: wan) (real interface: xl0).
    May 2 15:44:30 php: : The command 'route add -host 99.102.185.1' returned exit code '1', the output was 'route: writing to routing socket: Invalid argument add host 99.102.185.1: Invalid argument'
    May 2 15:44:30 php: : Resyncing configuration for all packages.
    May 2 15:44:32 php: : ROUTING: change default route to 99.102.185.1
    May 2 15:44:33 check_reload_status: reloading filter
    May 2 15:44:33 apinger: Starting Alarm Pinger, apinger(2755)



  • I can not get PPPoE to work at all

    In my opinion, the setup of wan connections got extremely more complex in 2.0.

    Tested yesterdays svn build of 2.0RC1 to see if PPPoE is finally working and it is still not…. :S

    Interfaces -> assign -> PPP's -> edit interface which is from 1.2.3

    NO INTERFACES ARE SELECTABLE - until I re-select PPPoE AGAIN in the drop down list.
    Why does WAN and LAN appear there? thats not a physical interface. :S
    Entered the username and pass.

    But even then, PPPoE is not working:
    System log reports this when trying to connect: May 5 22:02:20 - php: : Could not find gateway for interface(wan).

    Reverted to the iamge i took from 1.2.3. That one is working nicely and one hell of a lot easier to setup PPPoE.



  • Tested yesterdays svn build of 2.0RC1 to see if PPPoE is finally working and it is still not…. :S

    It's working perfectly for me on RC1.  Interfaces, Wan, PPPoE, enter username/password and choose details, and it's been up without issues.  Including over a few firmware updates.  :)



  • I have had no problems with pppoe on pfSense 2.0 including changing from pppoe over a physical interface to pppoe over a VLAN. I upgraded from pfSense 1.2.3 but didn't start using ppp until some months after the upgrade.



  • @Derek:

    Tested yesterdays svn build of 2.0RC1 to see if PPPoE is finally working and it is still not…. :S

    It's working perfectly for me on RC1.  Interfaces, Wan, PPPoE, enter username/password and choose details, and it's been up without issues.  Including over a few firmware updates.  :)

    May I ask which build you are running?

    I have:

    • em0 - Lan
    • em1 - wan

    What I did was:
    1. Interfaces -> assign -> PPP's -> edit interface
    2. inside that present (migrated) PPPoE, there is no interface (em0 / em1) selectable.
    3. at least not as long as i tick the dropdown menu where PPPoE is selected, and select PPPoE again.
    4. then it lists all interfaces (including LAN and WAN…. :S) and I can select em1
    5. i then add user and pass for PPPoE, but still. it does not work - the wan stays down - manually trying to connect only results in log as seen in 6. and status = "down"
    6. System log reports this when trying to connect: May 5 22:02:20 - php: : Could not find gateway for interface(wan).

    am I missing some step in setup of PPPoE in 2.0?



  • The new PPP capabilities for MLPPP and other circumstances apparently has left some issues with lacking input validation that allows invalid configurations in a way that some people are screwing up. I've yet to determine exactly what that is.

    If it's not working, reset to defaults, assign interfaces after the reboot, log into the web interface on LAN, when going through the setup wizard configure your PPPoE info, and you're done. Don't ever touch PPP-related settings outside of Interfaces>WAN (or whichever interface is your PPPoE WAN) unless you have reason to (such as MLPPP).



  • @cmb:

    The new PPP capabilities for MLPPP and other circumstances apparently has left some issues with lacking input validation that allows invalid configurations in a way that some people are screwing up. I've yet to determine exactly what that is.

    Can I help you with finding out what causes this?
    I have reverted back to an working image of 1.2.3. So I can upgrade to any build of 1.2.0 RC easiely.

    I can give you the files/info pre and post the upgrade. Just tell me which. :)



  • If you can get a backup of a config that isn't working that could help. You can email it to me (cmb at pfsense dot org) with a link to this thread.



  • @cmb:

    If you can get a backup of a config that isn't working that could help. You can email it to me (cmb at pfsense dot org) with a link to this thread.

    Will do that doring the weekend when I get back from my business trip. Thanks for your help! :)



  • Here are conf backups of 123 before the upgrade and from 2.0RC after the upgrade. PPPoE was not working after the upgrade - could not connect

    If you need any further infos/files please let me know! :)

    edit
    .zip not allowed as attachment? :S
    neiter is .xml….. so i had to rename the backup to .txt.



  • Removed the attachments since you posted your ISP password and other things you don't want public to the world, that's why I requested them via email.

    There aren't any config issues there, the 2.0 config is fine. Your password isn't the same in the 2.0 config as it is in the 1.2.3 config. Maybe that's the issue.



  • @cmb:

    Removed the attachments since you posted your ISP password and other things you don't want public to the world, that's why I requested them via email.

    oops thanks!

    @cmb:

    There aren't any config issues there, the 2.0 config is fine. Your password isn't the same in the 2.0 config as it is in the 1.2.3 config. Maybe that's the issue.

    I did not touch the configuration after the upgrade to 2.0. So whatever the password is in the 2.0 config, it was set by the upgrade routine.
    Any idea why this happens?

    After the first upgrade (the conf files were from the 2nd attempt), I did set the PPPoE user and pass again manually - yet the WAN did stay "down" still.
    Will have a look again this evening.
    Thanks for your help!



  • the config upgrade code has no ability to change the password, you had to have changed it at some point.



  • @cmb:

    the config upgrade code has no ability to change the password, you had to have changed it at some point.

    Here is what I did:
    1. restored an image (TrueImage) of 1.2.3 final
    2. started PC
    3. 1.2.3 was working - WAN was up
    4. downloaded latest build of 2.0RC
    5. created/exported a backup of 1.2.3 config
    6. upgraded to 2.0 RC
    7. after upgrdae was done, PfSense started up
    8. WAN was down
    9. pressed "connect" in the interfaces dialog
    10. WAN stayed down
    11. created/exported a backup of 2.0 RC config
    12. attached both config backups to this thread
    13. restored an image (TrueImage) of 1.2.3 final

    At no point, I even entered the WAN configuration of 2.0RC when I did the upgrade to export the logs. :-/

    Additional information:
    The WAN-PPPoE user and password was changed by my ISP ~8 months ago.
    Is it possible that this old info is still stored "somewhere" in 1.2.3 and the upgrade takes that instead of the new one which is configured and working in 1.2.3?



  • aaaaaand just did it one more time.

    1. working 1.2.3 setup
    2. upgraded to pfSense-Full-Update-2.0-RC1-i386-20110518-1955.tgz
    3. upgrade finishes
    4. WAN stays down

    as i said, I did not touch any config at all.
    what now?


  • Rebel Alliance Developer Netgate

    Can you e-mail me the before and after configuration from latest try?

    jimp (at) pfsense <dot>org.

    I committed some fixes a few weeks ago for the PPPoE WAN upgrade, it worked in my (admittedly limited) testing.</dot>



  • If you have an empty 'Service name' in your configuration try to check 'Configure a NULL Service name' on the PPPs configuration page. It is not available on the WAN configuration page so it's easy to miss it.



  • @azzido:

    If you have an empty 'Service name' in your configuration try to check 'Configure a NULL Service name' on the PPPs configuration page. It is not available on the WAN configuration page so it's easy to miss it.

    That is correct, the 1.2.3 config does not have an service name set - my ISP does not require that.
    Will have a look at this option in 2.0.

    @jimp
    I will have a look at this service name option and get back to you then. :)

    Thanks for your help guys!



  • @jigglywiggly:

    Actually it was just misconfigured, fixed the configuration, but still a no go

    Apr 7 16:35:43	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:35:43	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:35:43	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:35:43	ppp: [opt2_link0] Link: reconnection attempt 1 in 4 seconds
    Apr 7 16:35:47	ppp: [opt2_link0] Link: reconnection attempt 1
    Apr 7 16:35:47	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:35:56	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:35:56	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:35:56	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:35:56	ppp: [opt2_link0] Link: reconnection attempt 2 in 3 seconds
    Apr 7 16:35:59	ppp: [opt2_link0] Link: reconnection attempt 2
    Apr 7 16:35:59	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:36:08	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:36:08	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:36:08	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:36:08	ppp: [opt2_link0] Link: reconnection attempt 3 in 3 seconds
    Apr 7 16:36:11	ppp: [opt2_link0] Link: reconnection attempt 3
    Apr 7 16:36:11	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:36:20	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:36:20	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:36:20	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:36:20	ppp: [opt2_link0] Link: reconnection attempt 4 in 1 seconds
    Apr 7 16:36:21	ppp: [opt2_link0] Link: reconnection attempt 4
    Apr 7 16:36:21	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:36:30	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    

    Tried rebooting pfsense and everything…

    EDIT: Tried pfsense 1.2.3 livecd, and PPPOE is not an option of the interface I want... I think I rmemeber reading somewhere only the WAN interface can be PPPOE in pfsense 1.2.3

    Just tried an old ass linksys router, and that worked. Shame pfsense, shame.

    I have the same problem on RC1, just on WAN in my case .
    Pfsense was connected about 13-14 hours and then got same error as this person above.
    I unplugged WAN cable and connected it to notebook and was able to connect to internet using PPPOE on this notebook.
    Then plugged again WAN cable to pfsense box and it connected without problems , so seems unplugging ethernet cable worked.
    But it shouldn't be like that , I am not bot to stay near router 24h and unplug cable when needed  >:(



  • More info - WAN working now!

    I have just upgraded by pfsense 1.2.3 install to “pfSense-Full-Update-2.0-RC1-i386-20110521-2001”.
    After the upgrdae, my WAN connection stayed down. I did some more digging and found the cause – or fix. Enabeling the “configure null servicename” option brings my WAN connection back to life.

    Even though I found a way to get it working, I’d be very happy if you could have a look at my step-by-step description below.
    I did spot a few errors, and a rather big useability problem, realted to that null service name option.

    1.went to “Interfaces –> “WAN”
    2.username and password were present
    3.servicename field was empty (as in my 1.2.3 config) – imo. inconsitent config screen, “Configure a NULL Service name” missing
    4.IDLE timout was empty
    5.entered “Advanced MLPPP”
    6.Linktype PPPoE –> Correct
    7.Link interface –> em1 –> correct
    8.username and password present
    9.service name –> empty as in my 1.2.3 config
    10.enabled “Configure a NULL Service name”
    11.pressed “save”
    12.“Idle Timeout not configured”
    13.opened “advanced options” and entered “0”
    14.pressed “save” again"
    15.“interface not assigned”….. this was set to em1
    16.selected interface “em1” again
    17.pressed “save”
    18.went over to “status – interfaces”
    19.WAN “down”
    20.pressed “connect”
    21.now wan is finally up and i got an IP!
    22.went back to “Interfaces –> “WAN”
    23.“Idle Timeout” –> empty, even though I configured “0” before

    I see several problems in 2.0 RC1 after the upgrade:

    Step 15: the interface assigment got lost when trying to save the config without the “Idle Timeout” set
    Step 23: the “Idle Timeout” is empty, even though it was set to “0”
    “Idle Timeout”: when the field is empty, shouldnt that be simply detected as “0” = dissabled? – far better useability imo.

    “configure null servicename”:

    • not available inside “Interfaces WAN” – user can not be expected to know that it is only inside the advanced screen
    • not automatically enabled after an upgrade from 1.2.3 where the servicename was empty – root cause of my issue

    But the better question is why there even is such an option now in 2.0? Without knowing the reason why you added this option, I can only say that in my opinion, that option should be removed, and PfSense should detect the emtpy servicename field and enable the behaviour which “configure null servicename” would trigger. This option only causes huge useability issues right now. Especialy with the "inconsitent" config screens.

    I fear that once 2.0 gets final, you will get a lot more reports from users who upgrade from 1.2.* and end up with a "down" wan because of this "problem".

    I hope that my feedback is of use for you to improve PfSense even further. :)

    regards,
    Chris


  • Rebel Alliance Developer Netgate

    Some of this is copied from the e-mail I sent back to you, but others may find it useful as well:

    Leaving the service name blank sends no service name to the ISP at all. Sending a null service name sends a name and that name is blank. You can check that by looking at /var/etc/mpd_<interfacename>.conf with the option checked/unchecked. Those are two distinct things.

    The option isn't there on the main PPPoE config screen because that is an "advanced" (read: not normally needed) option and it is different than leaving the service name blank. Some services may not work with sending the null service name, but there may not be a good way to tell.

    As for why it worked on 1.2.3 and not on 2.0, it may be the difference in the MPD version used on both systems.

    The errors you saw when changing options there is definitely not normal though, but that is a separate issue from what you are seeing here. We usually discourage editing any settings on the PPP tab but in your case you have to.

    It would also help to see your /var/etc/mpd_<interfacename>.conf files when it is broken and when it works, with the username/password blanked
    out of course.</interfacename></interfacename>



  • @Mitar:

    @jigglywiggly:

    Actually it was just misconfigured, fixed the configuration, but still a no go

    Apr 7 16:35:43	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:35:43	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:35:43	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:35:43	ppp: [opt2_link0] Link: reconnection attempt 1 in 4 seconds
    Apr 7 16:35:47	ppp: [opt2_link0] Link: reconnection attempt 1
    Apr 7 16:35:47	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:35:56	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:35:56	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:35:56	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:35:56	ppp: [opt2_link0] Link: reconnection attempt 2 in 3 seconds
    Apr 7 16:35:59	ppp: [opt2_link0] Link: reconnection attempt 2
    Apr 7 16:35:59	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:36:08	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:36:08	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:36:08	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:36:08	ppp: [opt2_link0] Link: reconnection attempt 3 in 3 seconds
    Apr 7 16:36:11	ppp: [opt2_link0] Link: reconnection attempt 3
    Apr 7 16:36:11	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:36:20	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    Apr 7 16:36:20	ppp: [opt2_link0] Link: DOWN event
    Apr 7 16:36:20	ppp: [opt2_link0] LCP: Down event
    Apr 7 16:36:20	ppp: [opt2_link0] Link: reconnection attempt 4 in 1 seconds
    Apr 7 16:36:21	ppp: [opt2_link0] Link: reconnection attempt 4
    Apr 7 16:36:21	ppp: [opt2_link0] PPPoE: Connecting to '*'
    Apr 7 16:36:30	ppp: [opt2_link0] PPPoE connection timeout after 9 seconds
    

    Tried rebooting pfsense and everything…

    EDIT: Tried pfsense 1.2.3 livecd, and PPPOE is not an option of the interface I want... I think I rmemeber reading somewhere only the WAN interface can be PPPOE in pfsense 1.2.3

    Just tried an old ass linksys router, and that worked. Shame pfsense, shame.

    I have the same problem on RC1, just on WAN in my case .
    Pfsense was connected about 13-14 hours and then got same error as this person above.
    I unplugged WAN cable and connected it to notebook and was able to connect to internet using PPPOE on this notebook.
    Then plugged again WAN cable to pfsense box and it connected without problems , so seems unplugging ethernet cable worked.
    But it shouldn't be like that , I am not bot to stay near router 24h and unplug cable when needed  >:(

    exact same above issue, haven't been able to solve it till date, any help? actually mu alix connects to the isp fiber optic device using pppoe, now suppose for some reason i unplug the fiber optic device or it reboots or something like that then pfsense wont connect and keep going in loops and the only way to make it connect is by rebooting only.



  • basically when pfsense boots, the steps it follows to connect to pppoe seem different than when a link is brought down and then it loops trying to reconnect and thats where i think this bug is and many like me suffer coz in older version, lower than pfsense v2, it used to work perfectly fine and it did also reconnect fine so basically the link was up at all times and recovered from a failure.



  • should it be considered that this cant be solved at all?


  • Rebel Alliance Developer Netgate

    There is always the possibility that it can be solved, we just need more detail. If the behavior is different when it first logs in vs when it reconnects, the logs should be different as well.



  • im always ready to provide details but ill need some commands etc so i can post the results to u.

    actually when pf reboots, that time it connects perfectly fine without any issues at all but if my fiber optic device from isp reboots or if i click the disconnect from the web gui then it wont connect and the connection attempt keeps going in loops.

    i can provide the access to my box if u require or u can simply tell me the commands etc to run so i can get u those results based on the replicated scenario.


  • Rebel Alliance Developer Netgate

    No real commands to run. Check /var/etc/mpd_<interfacename>.conf when it works and when it doesn't, post them here (with your username and password removed/redacted). Also check the system logs when it works and when it doesn't, there should be log entries there about what it's doing.</interfacename>



  • @jimp:

    No real commands to run. Check /var/etc/mpd_<interfacename>.conf when it works and when it doesn't, post them here (with your username and password removed/redacted). Also check the system logs when it works and when it doesn't, there should be log entries there about what it's doing.</interfacename>

    the configuration wise i tried with that nulls ervice name etc but like i said, on reboot of pfsense it conencts fine but after that if i do it manually or happens by isp then the reconnection attempt just keeps looping, this issue is since the change of mpd and i personally feel there is some difference in the way it connects during boot compared to if done manually or happens due to disconnection.

    the conf file is as below which i have used since a long time, used to work with older mpd in v1.2.3

    startup:
    	# configure the console
    	set console close
    	# configure the web server
    	set web close
    
    default:
    pppoeclient:
    	create bundle static wan
    	set iface name pppoe0
    	set iface route default
    	set iface disable on-demand
    	set iface idle 0
    	set iface enable tcpmssfix
    	set iface up-script /usr/local/sbin/ppp-linkup
    	set iface down-script /usr/local/sbin/ppp-linkdown
    	set ipcp ranges 0.0.0.0/0 0.0.0.0/0
    	set ipcp no vjcomp
    	#log -bund -ccp -chat -iface -ipcp -lcp -link
    
    	create link static wan_link0 pppoe
    	set link action bundle wan
    	set link disable multilink
    	set link keep-alive 10 60
    	set link max-redial 0
    	set link disable chap pap
    	set link accept chap pap eap
    	set link disable incoming
    	set link mtu 1492
    	set auth authname "username"
    	set auth password passwod
    	set pppoe iface vr1
    	open
    

  • Rebel Alliance Developer Netgate

    And there is no difference in that config at all when it works and when it doesn't?

    The logs would probably be more helpful then.


Log in to reply