How to change RRD Quality IP?



  • @Gitsum:

    Yeah, me to. Using latest snapshot.
    I added the use_rrd_gateway with a pingable address, but it still doesn't work.

    Show us the xml.



    • <pfsense><version>2.3</version>
        <lastchange><theme>nervecenter</theme>
    • <system><use_rrd_gateway>208.67.222.222</use_rrd_gateway>
        <optimization>normal</optimization>
        <hostname>pfsense</hostname>
        <domain>local</domain>
        <username>admin</username>
        <password>$1$rXQXI.xG$K0UhU.e3ci0AgQoyBs.Oi.</password>
        <timezone>America/Los_Angeles</timezone>
        <time-update-interval><timeservers>pool.ntp.org</timeservers>
    • <webgui><protocol>http</protocol>
        <port><certificate><private-key></private-key></certificate></port></webgui>
        <disablenatreflection>yes</disablenatreflection>
        <enablesshd>yes</enablesshd>

    <maximumstates><dnsallowoverride></dnsallowoverride></maximumstates></time-update-interval></system>

    • <interfaces>-<lan></lan></interfaces></lastchange></pfsense>


  • Click save on the Interfaces -> WAN screen and see if it fixes it.

    RRD needs to be instructed to recreate its info



  • Nope. Even after restart, it's still showing 100% loss.



  • Run this from a shell.

    cat /var/db/rrd/updaterrd.sh | grep out_wan  | grep ping

    Does your WAN IP gateway appear correctly?



  • yes, it does.



  • So, since my WAN gateway seems to be pingable, what would be causing the RRD quality graph to not function properly?



  • There seems to be a bug in the latest version that maybe is causing this issues: http://forum.pfsense.org/index.php/topic,3514.0.html



  • I suppose the issue is solved, isn't it?

    I still get 100% loss even though I'm using an rrd_gateway in the config.xml which is pingable.

    cat /var/db/rrd/updaterrd.sh | grep out_wan | grep pin
    shows the ISP gateway instead of what I entered. I saved on Interfaces|WAN and rebooted but without luck. Any ideas?

    For the records: I am on 1.0.1-SNAPSHOT-03-27-2007 built on Tue Apr 3 07:30:15 EDT 2007



  • Did you remove /tmp/config.cache after updating config.xml?  If not then your manual changes where lost.



  • @sullrich:

    Did you remove /tmp/config.cache after updating config.xml?  If not then your manual changes where lost.

    Well, no.
    I edited config.xml (without package infos) on a WS and restored the configuratiion through the webGUI. Shouldn't that do the trick? After the automatic reboot the new IP is still there but not used…



  • Yes that should do the trick.  I imagine you added the IP to the wrong location.

    The setting goes in the wan xml area.



  • @sullrich:

    I imagine you added the IP to the wrong location. The setting goes in the wan xml area.

    Isn't it stored under <system>any longer?

    
     <pfsense><version>2.9</version>
    	 <lastchange><theme>nervecenter</theme>
    	 <system><use_rrd_gateway>217.6.10.12</use_rrd_gateway>
    		<optimization>normal</optimization>
    		<hostname>gateway</hostname></system></lastchange></pfsense> 
    

    I followed your instructions. Sorry if they this is outdated…

    @sullrich:

    <system><use_rrd_gateway>XXX.XXX.XXX.XXX</use_rrd_gateway></system>

    Does it matter where exactly it goes here? I would insert it right after the <if>tags… ???

    		 <wan><if>rl0</if>
    			 <mtu><blockpriv><media><mediaopt><bandwidth>100</bandwidth>
    			<bandwidthtype>Mb</bandwidthtype>
    			 <blockbogons><spoofmac><ipaddr>pppoe</ipaddr>
    			 <pppoe><pppoe-reset-type>custom</pppoe-reset-type></pppoe></spoofmac></blockbogons></mediaopt></media></blockpriv></mtu></wan> 
    
    ```</if></system>


  • Needs to be between:

    <wan></wan>

    Placing it right behind <wan>is the safest bet.

    If you remove /tmp/config.cache and edit /cf/conf/config.xml and change it then click on Save on the wan screen you should be set.</wan>



  • That would be correct, since february the use rrd gateway setting applies to each interface. That, because we now monitor quality on all outbound links.

    So if you have a multiwan config with wan and opt1 you could place use rrd gateway tags on both these interface sections.

    If you upgrade from a previous version the system tag will automatically be moved to the wan interface section.

    Hope this helps.



  • I inserted it where <use_rrd_gateway>was previously in the WAN section but pfSense doesn't seem to be impressed.
    It still (tries to) ping my ISP's WAN gateway and I get 100% packet loss.

    		 <wan><if>fxp0</if>
    			<mtu>1490</mtu>
    			 <media><mediaopt><bandwidth>100</bandwidth>
    			<bandwidthtype>Mb</bandwidthtype>
    			 <spoofmac><blockbogons><blockpriv><use_rrd_gateway>217.6.10.12</use_rrd_gateway>
    			 <pppoe><pppoe-reset-type>custom</pppoe-reset-type></pppoe> 
    			 <disableftpproxy><ipaddr>pppoe</ipaddr></disableftpproxy></blockpriv></blockbogons></spoofmac></mediaopt></media></wan> 
    

    This is from my pfSense at home with Intel NICs, not the one in the office (where the behavior is the same)…

    # ping 217.6.10.12
    PING 217.6.10.12 (217.6.10.12): 56 data bytes
    64 bytes from 217.6.10.12: icmp_seq=0 ttl=249 time=38.284 ms
    64 bytes from 217.6.10.12: icmp_seq=1 ttl=249 time=38.025 ms
    

    If this is still valid, it pings my ISP's gateway:

    cat /var/db/rrd/updaterrd.sh | grep out_wan | grep pin
            out_wan=` ping -c 5 -q 217.0.116.226 `
    

    Any ideas?</use_rrd_gateway>



  • Fixed in CVS.

    Snapshot in 2 hours.



  • Thanks for the fast correction, pfSense is pinging the right IP now!

    I don't wanna be picky, but shouldn't it look a bit different than this:




  • It might take RRD some time to gather data?



  • That is correct, nan implies there is not enough data available.



  • How much data/time does it need?

    I mean, the graphic is for a full span of 4h and 1min and it already ran for more than 17 hours without meaningful output…
    If you collect data for a time frame of 4h then all required data to draw the graph is available after 4h and 1 seconds. If we don't have a graph after 4 to 5 times this frame I assume something broken...








  • Yeah, that seems a bit excessive.  Try clicking save in the Interfaces -> WAN screen.



  • @sullrich:

    Try clicking save in the Interfaces -> WAN screen.

    Did that already on both currently available boxes. The result is shown above…  ;-)
    The Senses were rebootet as well.

    What more can I do/test/report to help you fixing it?





  • OK, I deleted what's in /var/db/rrd and rebooted the machine.
    Graphs for 'System', 'Traffic' and 'Packets' are starting from scratch (as expected) but quality isn't built at all any more.

    And the drop down box only shows 'Allgraphs' and 'Outbound' missing 'Wan' etc…

    I can live without the graphs if it's only affecting me but would try to investigate further if others have the same problem!




  • Delete all the rrd database files. It should recreate everything from scratch on reboot.



  • @hoba:

    Delete all the rrd database files. It should recreate everything from scratch on reboot.

    What more should I delete than what's in /var/db/rrd  ???



  • I thought you only deleted the wan rrd graphs like described in the thread I posted. no matter then.



  • I think I found the solution for RRD Quality gateway ip change with just slightly changing "/etc/inc/pfsense-utils.inc" file.

    Here is my solution.

    1. Open "/etc/inc/pfsense-utils.inc" at "Diagnostics -> Edit File" and then find below line.

    $monitorip = $config['system']['interfaces'][$ifname]['use_rrd_gateway'];

    2. Then, change this line to below and then save it.

    $monitorip = $config['interfaces'][$ifname]['use_rrd_gateway'];

    3. And open "/cf/conf/config.xml" and add "<use_rrd_gateway>XXX.XXX.XXX.XXX</use_rrd_gateway>" into <interfaces><wan>instead of <system>as like below. And then save.

    <interfaces><lan><if>fxp0</if>
    <ipaddr>192.168.4.1</ipaddr>
    <subnet>24</subnet>
    <media><mediaopt><bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype></mediaopt></media></lan>
    <wan><if>fxp1</if>
    <mtu><media><mediaopt><bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>
    <spoofmac><disableftpproxy><ipaddr>192.168.2.196</ipaddr>
    <subnet>24</subnet>
    <gateway>192.168.2.1</gateway>
        <use_rrd_gateway>xxx.xxx.xxx.xxx</use_rrd_gateway></disableftpproxy></spoofmac></mediaopt></media></mtu></wan>

    4. Now reboot pfsense and check RRD graph if it works.</interfaces></system></wan></interfaces>



  • @sbyoon:

    I think I found the solution for RRD Quality gateway ip change with just slightly changing "/etc/inc/pfsense-utils.inc" file.

    Thanks sbyoon, that did it on my boxes!

    The 100% loss part is from an unpingable IP…

    Chris




  • Hi sbyoon!

    Thanks! Now my quality graphs are working as expected!

    Thanks again.



  • Dear pfSense developers,

    Could you correct /etc/inc/pfsense-utils.inc for futur version?

    Thank you.



  • Fixed.  Thanks for the detailed thread.



  • My RRD WAN quality was showing 100% loss I guess because my DSL modem is doing the PPPoE and it is on 192.168.0.1
    PFsense couldn't see the ISP gateway. So using this info here I was able to add the gateway the modem uses to my config.xml and now my RRD quality shows as it should. Guess it would have been simpler to put the modem in bridge mode and not have to do this. But I learned something!  ;)


Log in to reply