Voip односторонняя слышимость



  • Есть схема

    PBX-PfSense-Internet-Router-Voip шлюз

    Проброшены порты на Pfsense 5080 для сигнализации и 9000-9100 для RTP пакетов
    На Роутере так же проброшены эти порты

    При звонке на Voip шлюз я слышу человека а он меня нет.

    Tcpdump показывает что сигнализация проходит нормально а RTP пакеты идут только в сторону Voip шлюза от PBX.

    Помогите



  • У меня проблема была с Freeswitch. Может поможет..
    нужно установить пакет Freeswitch или igmpproxy(его проще) они нужны чтобы появилось в правилах фаервола галка "This allows packets with ip options to pass otherwise they are blocked by default i.e. with multicast routing/" (галка будет спрятана за кнопкой в advanced options).
    Так вот ставишь эту галку в правилах 9000-9100 для RTP. И все, пошел голос.

    PS. Если у тебя Freeswitch то проброс не нужно делать, просто разреши udp на wan с галкой, по портам 9000-9100. Ну и отдельным правилом на порт 5080.



  • Спасибо за совет,попробовал,не заработало.
    Делал trace на Wan вижу что пакеты на него приходят
    Делал trace на lan пакетов уже нет
    Правило на wan прописано
    Получается прикол в том что правило есть но pfsense все равно не пропускает дальше.



  • Решил я все таки проблему.
    Для тех у кого будут проблемы вообще с настройкой voip телефонии вот вам рецепт.
    Пробрасываете порты через NAT
    Заходите в правила фаервола и открываете правила для voip
    там есть параметр State Timeout in seconds спрятан за кнопочкой Advanced Options и выставляете там 1800.Все после этого разговор пойдет как положено.



  • Думал что решил проблему оказалось что нет.
    Вся проблема оказывается в states.
    Если очистить states то входящий или исходящий звонок проходит и голос идет в обе стороны,но при следующем например исходящем звонке уже происходит односторонняя слышимость.И так же перестает пропускать 5080.Очищаешь states  и опять работает на 1 звонок.



  • dp 80.234.35.228:5080 <- 192.168.10.2:5080 MULTIPLE:MULTIPLE
    udp 192.168.10.2:5080 -> 192.168.0.1:5080 -> 80.234.35.228:5080 MULTIPLE:MULTIPLE
    udp 80.234.35.228:9000 <- 192.168.10.2:9010 NO_TRAFFIC:SINGLE
    udp 192.168.10.2:9010 -> 192.168.0.1:9010 -> 80.234.35.228:9000 SINGLE:NO_TRAFFIC
    udp 80.234.35.228:9001 <- 192.168.10.2:9011 NO_TRAFFIC:SINGLE
    udp 192.168.10.2:9011 -> 192.168.0.1:9011 -> 80.234.35.228:9001 SINGLE:NO_TRAFFIC

    так выглядят states



  • @Wame140:

    dp 80.234.35.228:5080 <- 192.168.10.2:5080 MULTIPLE:MULTIPLE
    udp 192.168.10.2:5080 -> 192.168.0.1:5080 -> 80.234.35.228:5080 MULTIPLE:MULTIPLE
    udp 80.234.35.228:9000 <- 192.168.10.2:9010 NO_TRAFFIC:SINGLE
    udp 192.168.10.2:9010 -> 192.168.0.1:9010 -> 80.234.35.228:9000 SINGLE:NO_TRAFFIC
    udp 80.234.35.228:9001 <- 192.168.10.2:9011 NO_TRAFFIC:SINGLE
    udp 192.168.10.2:9011 -> 192.168.0.1:9011 -> 80.234.35.228:9001 SINGLE:NO_TRAFFIC

    так выглядят states

    Дак у тебя pbx на одной машине с pfsense или на разных?



  • Проблему решили.Помог Evgeny.



  • Если не секрет, то как?



  • У меня оказывается исходящий трафик шел через OPT1 а входящий через WAN.
    Исправили добавлением 2х правил на LAN
    UDP LAN net * * 5080 *    
    UDP LAN net * * 9000 - 9200 *



  • Спасибо!


Log in to reply