Can't ping 1.0.1-SNAPSHOT-01-24-2007 built on Tue Jan 30 02:26:31 EST 2007



  • Can't ping anything that resides on WAN interface or should be reachable with WAN nic.
    Can ping gateway residing on the OPT1 interface.
    The above pings are done from the pfSense console.

    But…

    I have no problem of pinging the same addresses from a client computer that uses
    pfSense as it's gateway. Traceroute from the client computer confirms that the
    correct route/NIC is used to reach each destination.

    Did first a firmware upgrade from build 25-01-2007. Totally slowed down the pfSense after reboot.
    Did a factory reset. pfSense worked much faster, but ping issue was still there.
    Did a complete reinstall with reformat of harddrive. Same issue.

    Have WAN, LAN and OPT1.
    When i am writing this i have not yet enabled Load Balancer for failover support, so it's as very basic
    configuration on the pfSense box. I probably won't be able to use Load Balancer with failover support,
    because if it can't get a ping response(it's one of the addresses i tested above), it will go into failover mode.

    The funny part is that traceroute from the pfSense console works on both destinations, and it to
    confirms the same route path as the client computer did, but the client can ping.
    Ping can't be broken because it works when pinging the OPT1 gateway. Sounds a little bit
    as a firewall issue that only the pfSense computer experiences, as it does not allow ping on the WAN interface.



  • Try todays snapshot, please.



  • I updated today.
    Is SNAPSHOT-01-24-2007 built on Tue Jan 30 02:26:31 EST 2007 the latest snapshot?
    It's the only one i could find :(.

    I did not see this behavior with snapshot 01-24-2007 that was built 01-25-2007.

    I have for now done a workaround:
    Added a firewall rule to the WAN interface for allowing echo reply and that solved the problem
    thus making the failover monitoring work.

    Could it be that my primary WAN is interface xl1 and my secondary WAN(OPT1) is xl0 and only xl0 got
    permission to ping with the default config with this snapshot?



  • I have now done a clean reinstall with 1.0.1-SNAPSHOT-01-30-2007 built on Tue Jan 30 18:30:20 EST 2007.

    Did a minimal basic configuration with loading pfSense to harddrive, setting hostname, dns servers, changed
    maximum number of states to 15000, different NTP time server, time zone, enabled SSH server.

    At this point i was running with OPT1 interface disabled, and still it would not work to ping
    www.google.se from the pfSense console, nor my WAN gateway.
    But doing a ping from a client computer that uses pfSense as a gateway worked.

    But using the same workaround as before(adding echo reply to WAN rules), the problem went away.



  • Using 1.0.1-SNAPSHOT-02-02-2007 built on Sat Feb 3 20:14:47 EST 2007 now.
    The ping issue is gone :).

    Thanks to hoba for the heads up about it being fixed and to everyone working on the pfSense project.


Log in to reply