PfSense 2.0 RC1 problème squid cachemgr.cgi et mrtg



  • Bonjour à tous,
    Je suis en train de tester la version 2.0 RC1.
    J'ai actuellement une version 1.2.3 en production qui marche sans problèmes.
    La configuration:

    • int WAN : 192.168.0.4 branchée sur un modem / routeur ayant une IP lan 192.168.0.37
    • int LAN : 192.168.0.5 branchée sur le lan
    • HAVP en mode transparent sur port int LAN:8080, parent de squid
    • squid en mode transparent sur port int LAN:3128
    • squidGuard avec blacklists shallalist
      Configuration fonctionnelle aussi bien en 2.0 RC1 lastest build que 1.2.3

    J'ai besoin de monitorer le cache de squid et j'ai donc remis en place la fonction cachemgr.cgi que j'ai sur mon pf 1.2.3 de prod, à savoir

    • cachemgr.conf > 192.168.0.5
    • Services > proxy server > external cache manager > 192.168.0.5
      J'accède bien à la page cachemgr.cgi qui me demande le login et mdp mais quand je fais connexion, il m'indique "Accès interdit, La configuration du contrôle d'accès interdit à votre requête d'être acceptée à cette heure-ci. Veuillez contacter votre prestataire de service si vous pensez que ceci n'a pas lieu d'être."
      Le même accès sur mon pf 1.2.3 fonctionne.

    J'ai aussi installé mrtg pour grapher le cache squid:

    • dans Services > proxy server > custom options > never_direct allow all;cache_peer 127.0.0.1 parent 8080 0 name=havp no-query no-digest no-netdb-exchange default;acl aclname snmp_community public;snmp_access allow aclname;acl pfsense src 192.168.0.5/255.255.255.255;http_access allow manager pfsense;cachemgr_passwd none all;
    • accès à la page mrtg par http://192.168.0.5/mrtg fonctionne mais je n'ai aucune stats dans les graphiques
    • ajout du port 3401 dans acl safe ports et idem

    Si quelqu'un a une idée, je suis preneur! Cela fait maintenant 2 jours que je me bat avec et je ne sais plus où chercher…
    Merci à vous!



  • Personne?



  • Vraiment personne?


Log in to reply