Port Forwarding



  • Hy ich bin Neu hier, weil ich ein Problem habe.

    Am Anfang steht ein Speedport 701V (nicht mit Speed2Fritz geflasht) mit einem DynDNS Account.
    Dann ein ESX4.1 mit einer Windows 2008 ADDS Domäne mit IIS7 MySQL PHP und Joomla.
    Dann ein Ubuntu 10.04.1 LTS Server mit LAMP und Typo3 und Kerberos.

    Solange ich nur die NAT vom Speedport Router als Firewall hatte war alles OK, Windows Web und  Ubuntu WEB Rechner war unter dem Gleichen Namen anzusprechen nur nicht Port 80 sondern 8080. Es hat also alles funktioniert.

    Dann habe ich mit pfSense 2.0 installiert - zuerst habe ich den Speedport als DSL Router benutzt, bis ich merkte das das ja keinen "Sense" macht hinter einer NAT. Also machte ich PPPoE und es geht auch alles, selbst das Windows Remote RDP Protokoll geht auf Linux und Windows ein wand Frei. Zwar ist jetzt meine Windows Site durch die Installation zerschossen "no conection to MySQL" aber das hat nix mit rooting zu tun.

    Über die IP bekomme ich im Firefox meine Typo3 seite geöffnet, nicht aber über den DynDNS Namen.
    Die IP`s stimmen, nur mein Web Zugang über Port 80 funktioniert nicht.

    Ich probiere schon fast 2 Tage habe schon meine komplette IP Infrastruktur umgestellt auf DHCP von pfSense (Funktioniert) DynDNS von pfSense  (Funktioniert) mit Aliase .

    Wodrauf muß ich achten, wo ist meine Denkblokade ?
    Ich fange jetzt erst an mich mit der Materie auseinander zu setzen.

    Help needet !
    Olly



  • tag,

    ich lege mir mal eben deine Infrastruktur für mich gedanklich zurück …

    • Der Rechner mit pfSense übernimmt die Einwahl in das Internet und bindet die Rechner dahinter mit NAT ans Inet an.
    • Auf dem ESX Server läuft ein Windows Server und ein Ubuntu Server
    • Auf dem Windows Server läuft ein IIS (Port 80)
    • Auf dem Ubuntu läuft ein Apache (Port 80)
    • Auf pfSense wird der Port 80 auf den Windows Server an Port 80 weitergeleitet
    • Auf pfSense wird der Port 8080 auf den Ubuntu Server an Port 80 weitergeleitet
    • Gibt man von extern im Browser die aktuelle öffentliche IP mit Port 8080 ein, dann erscheint die Webseite vom Ubuntu Server.
    • Gib man von extern im Browser den DynDNS-Hostnamen mit Port 8080 ein kommt "nix".

    soweit richtig?



  • Jep Shine :-),

    Obwohl, nicht extern sondern Intern über IP.

    Grüße

    ![Heimisches Netz IP.jpg](/public/imported_attachments/1/Heimisches Netz IP.jpg)
    ![Heimisches Netz IP.jpg_thumb](/public/imported_attachments/1/Heimisches Netz IP.jpg_thumb)



  • hi,

    kann nichts problematisches erkennen; die LAN-Rules wären noch interessant.

    Wenn du von innen testest; z.b. vom WS-IBM-T40-W7; dann ist die pfSense gar nicht involviert? Oder wie testest du?

    => Im Browser 192.168.88.160  <- sollte Joomla anzeigen
    => Im Browser 192.168.88.161  <- sollte Typo2 anzeigen



  • Hy,

    Die rules sind nicht auf pass, aber das ändert nichts.

    Wenigtens läuft meine IIS site (configuration.php von joomla hatte falsche ip).

    aber mein rooting geht immer noch nicht. Fahre jetzt zu einem IT secuity guru.

    grüße.




  • Hi,

    jut jut .. bring' dei Webs erst einmal in einen funktionierenden Zustand … am einfachsten versuchst du die Webseite direkt auf dem Server selber aufzurufen .. weil dann weder die lokale Firewall auf Server und Client stört, noch die pfSense, die aber bei internen Tests eh außen vor ist.

    Wenn die Webs laufen .. dann den Test von einem Notebook testen; über IP und evtl. über den Hostnamen.

    Wenn die internen Aufrufe auch klappen, dann von außen über die IP und dann mit dem DynDNS-Hostnamnen testen.



  • Hy,

    Win Web und Linux Web funktionieren (über Ip vom DHCP gefüttertev WS) !
    Wen ich die von Telekom IP und die von DynDNS IP vergleiche sind sie gleich, funktioniert perfekt.
    FW vom Windowsserver ist aus Intern und extern.
    Wenn ich den DynDNS Namen im Browser eingebe erscheint beim Windowsserver das login von pfsense via port 443, auch wenn ich das S nicht eingebe, oder den cache von firefox lösche und mit Ipconfig /flushdns den DNS cache von der WS lösche. Also definitiv pfSense, ich hab Mist in derpfSense cofig gemacht :-(

    Grüße



  • hi,

    es gibt einen Schalter für "Raus-Rein" Verbindungen … wenn du von intern die externe IP aufrufst, die dann wieder nach intern geforwardet wird, kann es Problemchen geben.

    Schau die Einstellung "Disable NAT Reflection for port forwards" unter "System" | "Advanced" -> "Firewall and NAT" -> "Network Address Translation" an ...

    Evtl. schaust du dir die Einstellung "WebGUI redirect" unter "System" | "Advanced" auch noch an.

    .. gut wäre auf jedem Fall noch ein Test von einem Rechner der von der WAN-Seite auf die Webs zugreift.



  • In Out, wo finde ich den ?

    NAT reflection habe ich immer aus !



  • hi,

    NAT reflection habe ich immer aus !

    Und, was meinst du, ist die Einstellung für deine Test gut oder schlecht?  ;D



  • Hy,

    Ich komme der Sache schon näher.
    Jetzt erscheint das login für pfSense nicht mehr :-)

    greetings


Log in to reply