VMware 7 Lab Setup - Cant Connect to the Internet



  • After searching for a few hours and installing pfSense 2.0 RC1 and updating it to the latest I'm still having issues. I believe it’s because I’m trying to use my internal network as an external network (fake ISP) and pfSense doesn’t know how to or like to route to two 192.168.x.x networks.

    1. I try to add a gateway to the static WAN interface and it looks like the add gateway option but just hangs there saying "one moment please". I change it back to DHCP and I can ping from the Diagnostics > Ping menu but I can’t ping out from the VM that is on the same virtual network (VMnet2).  I found this. No luck.

    2. When I reinstalled the second time I set my virtual pc that is on the virtual network to DHCP and was able to get an address, ping the pfSense virtual machine and was able to resolve DNS but couldn’t ping  anything outside the network or browse the web.

    3. I tried adding an “allow all “rule and I’m still unable to connect to the internet.

    Current pfSense Version: 2.0-RC1 (i386) built on Sun Apr 17 04:28:14 EDT 2011. Also tried 1.2.3 RELEASE

    Diagram:
    [Below]



  • The ACSII version didnt turn out so well. :P




  • On pfSense check all your interfaces and ensure that you have Block Private Networks UNChecked.

    Seth



  • Thanks for the response. I do have the unchecked on the WAN interface and there inst one on the LAN interface.






  • I'm certain that its a VMware Workstation issue and not a pfSense issue.  I use this setup extensively; NATed and Bridged.

    The WAN side:
    Host only?  This wont let you out of the VMware Host
    NAT enabled?  This will work.  Tripled NATed.  WRT54G|VMware|pfSense.  Least desirable
    Bridged?  This will work. More config on your part.  Double NATed.  WRT54G|pfSense.  This is more desirable

    On the VMware Host, has the Windows firewall been disabled/configured to allow traffic in/out?

    Do you have a subnet overlap?

    –Seth



  • I have it set up as a bridge for the "external" pfSense connection. The second picture is the server on the "internal" network.

    What do you mean by "Subnet Overlap"?






  • Looks like it is working. I ended up changing the subnet to 10.0.0.x instead of 192.168.20.x.

    Thanks for the help.


Locked