Error 500 and /index.php: [DEBUG] Lock recursion detected.



  • Hello!
    We use pfsense 1.2.3 with Captive Portal for 3000 users.
    Sometimes error 500 appears for all users coming to CP page.
    It fixes only with restarting of lighthttpd.
    And in log in same time error: /index.php: [DEBUG] Lock recursion detected.
    And in lighttpd.error.log:
    (mod_fastcgi.c.2880) socket failed: No buffer space available 6660 11095
    (mod_fastcgi.c.3538) all handlers for  /index.php on .php are down.
    How to fix it?



  • Upgrade to 2.0RC1 which has improvements for this!



  • @ermal:

    Upgrade to 2.0RC1 which has improvements for this!

    2.0 was worse.
    But what is this?



  • You are sure?

    Can you give me any errors or logs from 2.0 latest snapshot?



  • @ermal:

    You are sure?

    Can you give me any errors or logs from 2.0 latest snapshot?

    Is this count ? I trying to fix this issue, but got tired.

    2011-06-05 15:37:39: (log.c.166) server started
    2011-06-05 15:39:44: (mod_cgi.c.590) cgi died, pid: 17259
    2011-06-05 15:39:45: (mod_cgi.c.590) cgi died, pid: 17262
    2011-06-05 15:39:45: (mod_cgi.c.590) cgi died, pid: 17540
    2011-06-05 15:40:00: (mod_cgi.c.590) cgi died, pid: 1561
    2011-06-05 15:40:01: (mod_cgi.c.590) cgi died, pid: 2363
    2011-06-07 13:04:00: (connections.c.137) (warning) close: 12 Connection reset by peer
    2011-06-07 13:30:24: (connections.c.137) (warning) close: 12 Connection reset by peer
    2011-06-08 06:00:09: (connections.c.137) (warning) close: 12 Connection reset by peer
    2011-06-08 08:39:17: (server.c.1396) [note] graceful shutdown started
    2011-06-08 08:40:29: (server.c.1512) server stopped by UID = 0 PID = 17803
    2011-06-08 08:40:32: (log.c.166) server started
    2011-06-08 13:40:09: (mod_fastcgi.c.1734) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    2011-06-08 13:40:09: (mod_fastcgi.c.3027) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 391
    2011-06-08 13:40:09: (mod_fastcgi.c.1734) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-0
    2011-06-08 13:40:09: (mod_fastcgi.c.3027) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 1 load: 391
    2011-06-08 13:40:09: (mod_fastcgi.c.3597) all handlers for /sgerror.php?url=403%20&a=xxx.xxx.xxx.194&n=&i=&s=default&t=Proxy_Facebook&u=http://www.facebook.com/plugins/like.php?href=facebook.com/doviz&layout=button_count&show_faces=false&width=450&action=like&colorscheme=light&height=21 on .php are down.
    2011-06-08 13:40:11: (mod_fastcgi.c.2785) fcgi-server re-enabled:  0 /tmp/php-fastcgi.socket
    2011-06-08 13:40:11: (mod_fastcgi.c.2785) fcgi-server re-enabled:  0 /tmp/php-fastcgi.socket
    2011-06-08 13:40:45: (mod_fastcgi.c.1734) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    2011-06-08 13:40:45: (mod_fastcgi.c.3027) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 391
    2011-06-08 13:40:45: (mod_fastcgi.c.1734) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-0
    2011-06-08 13:40:45: (mod_fastcgi.c.3027) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 1 load: 391
    2011-06-08 13:40:45: (mod_fastcgi.c.3597) all handlers for /sgerror.php?url=403%20&a=xxx.xxx.xxx.233&n=&i=&s=Orxxxx&t=Proxy_Facebook&u=http://www.facebook.com/plugins/likebox.php?id=114291218610934&width=300&connections=10&stream=false&header=false&height=287 on .php are down.
    2011-06-08 13:40:47: (mod_fastcgi.c.2785) fcgi-server re-enabled:  0 /tmp/php-fastcgi.socket
    2011-06-08 13:40:47: (mod_fastcgi.c.2785) fcgi-server re-enabled:  0 /tmp/php-fastcgi.socket
    2011-06-08 13:40:48: (mod_fastcgi.c.1734) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    2011-06-08 13:40:48: (mod_fastcgi.c.3027) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 391
    2011-06-08 13:40:48: (mod_fastcgi.c.1734) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-0
    2011-06-08 13:40:48: (mod_fastcgi.c.3027) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 1 load: 391
    2011-06-08 13:40:49: (mod_fastcgi.c.3597) all handlers for /sgerror.php?url=403%20&a=xxx.xxx.xxx.233&n=&i=&s=Orxxxx&t=Proxy_Facebook&u=http://www.facebook.com/plugins/like.php?channel_url=http://static.ak.fbcdn.net/connect/xd_proxy.php?version=3 on .php are down.
    2011-06-08 13:40:50: (mod_fastcgi.c.2785) fcgi-server re-enabled:  0 /tmp/php-fastcgi.socket
    2011-06-08 13:40:50: (mod_fastcgi.c.2785) fcgi-server re-enabled:  0 /tmp/php-fastcgi.socket



  • Please state version of the snapshot?
    Where this log comes from?

    Any other system log?



  • I was upgraded my system to last week (05 June) and some service/packet got issues, packet reinstallation fix that.  Everything was OK till today enabled Secure Shell. After that my webgui crashed and i restart to the webconfigurator. That log come from lighttpd.error.log. But after restart full system, everything work fine now.


Locked