PfSense won't install as Xen VM at HP Microserver



  • Got a HP Microserver at home. Deployed XenServer on it and want to set up a pfSense to use it as home router.

    But have no luck with it. Getting kernel panic with any ISO available: http://dropmocks.com/mUeFg <- this screenshot done while trying 2.0rc amd64 iso.

    Any ideas?



  • I´m having the exact problem with and Amd Opteron CPU. Crash at the same time with the same message. I also tried http://forum.pfsense.org/index.php/topic,30593.0.html
    but that wont work for me.

    Its the same with both 2.0 32bit and amd64.



  • Summoning developers in da thread! Abracadabra-boom!



  • Others may be able to help, were to you to mention such details as with version of Citrix XenServer you're using. It would also be useful to know whether you can get FreeBSD 8 working in Xen on that same host.



  • Xenserver 5.6fp1
    I've got the following *nixes flying well:
    FreeNAS 8.0 Release
    Centos 5.6
    FreeBSD 8.2 x64 (yes, it works well)
    FreeBSD 8.2 x86 (same as above)
    m0n0wall (but I want PFSense!)

    thank you in advance.



  • I´m not using Xen, instead I´m using Hyper-V on Win 2008 R2.



  • @Nuub:

    I´m not using Xen, instead I´m using Hyper-V on Win 2008 R2.

    Then your problem may not be the same and you should start your own thread to avoid creating confusion.



  • @Cry:

    @Nuub:

    I´m not using Xen, instead I´m using Hyper-V on Win 2008 R2.

    Then your problem may not be the same and you should start your own thread to avoid creating confusion.

    Well I could do that of course, but since I got the exact same error message I think the problem is not related to Xen/Hyper-V. My guess some function in the AMD cpu´s
    If you don´t know I can inform that Xen/Hyper-V is very close to each other in function.
    Some code on Hyper-v is Xen based.



  • Has anyone had any success running pfSense on the HP Microserver using the VMware ESXi hypervisor?

    I know that ESXi installs on this hardware without any problems.



  • @suncheez:

    Got a HP Microserver at home. Deployed XenServer on it and want to set up a pfSense to use it as home router.

    But have no luck with it. Getting kernel panic with any ISO available: http://dropmocks.com/mUeFg <- this screenshot done while trying 2.0rc amd64 iso.

    Any ideas?

    Any luck during testing yet suncheez?



  • Hi,

    I've got exact same problem. I'm also using Xenserver 5.6fp1 on a AMD Phenom x64 cpu. Pfsense 2.0 AMD64 gives me the same error as suncheez. Pfsense 1.2.3 is working just fine.

    Edit:

    Tried a couple of things to narrow down:
    -Tried updating 1.2.3 to 2.0 RC3 through WebGui but it fails the same: http://dropmocks.com/mUeFg
    -Installing 2.0 in Virtualbox on Intel Q6600 CPU host works just fine
    -Updated my Asus M3A78EM (AMD CPU) mobo to latest firmware, to no avail



  • Hi,

    I am also using Xenserver running on the HP Microserver and want to install pfSense 2 on it.
    And after a lot of searching and reading i have found a work around to get it working.
    This is what i did:

    At the boot menu choose option 7 "Escape to loader prompt"

    set hw.clflush_disable=1
    boot

    Install pfSense.

    After the installation, add the following line to /boot/loader.conf.local by running the following command from the shell prompt.

    echo "hw.clflush_disable=1" >> /boot/loader.conf.local



  • Hey wmlaros, thanks for sharing your solution. Didn't work for me though (Athlon II Neo 64)



  • @wmlaros:

    …set hw.clflush_disable=1
    boot...

    You made my day! Thank you very much!



  • wmlaros you are a true hero!

    I have been looking for a solution for this at least a year now, and until I read you post a couple of hours ago I had found nothing at all that even came close to solve that problem.

    My setup, which now works:

    Xenserver 5.6sp2
    AMD Phenom™ II X4 955 Processor, 4 cores
    pfsense 2.0-AMD64 (installed with 4 cpu kernels)

    Thank you ever so much!



  • Yes! Absolutely awesome. Running pfsense 2.0 release on XenServer 5.6 SP2 on AMD Athlon 64 x2




  • Are you planning on upgrading to XenServer 6.0?



  • When it's stable. BETA software is fun, but not always the best decision. I lost all my guest systems once because I wasn't careful.



  • Works like a charm! Thank you so much wmlaros!!



  • @tommyboy180:

    When it's stable. BETA software is fun, but not always the best decision. I lost all my guest systems once because I wasn't careful.

    It's released


Locked