PPPoE over WLAN is very slow



  • Hi, on our Boarding School our Internet is distributed over WLAN wich we have to use for a PPPoE connection. Unfortunately the WLAN Router does not Support tcp_window_scaling so every client needs to disable this option otherwise its extremely slow.

    I have a pfsense machine connecting to this wlan sharing the connectin to my linux computers and to use the squid webcache because we have very strict traffic limitations. I have created the pppoe interface and everything works but awfully slow although tcp window scaling is disabled. Browsing is good, i can enter very fat websites relatively fast. but thats all, http downloads and everything else are at 5 to 7 kilobytes per second.

    I have no clue what to do. The connection speed should be at 1 to 10 megabit

    edit : I have pfsense 2.0 rc1(updates are nearly impossible because its just too slow)



  • Nobody got an answer?



  • @llennac:

    Hi, on our Boarding School our Internet is distributed over WLAN wich we have to use for a PPPoE connection. Unfortunately the WLAN Router does not Support tcp_window_scaling so every client needs to disable this option otherwise its extremely slow.

    Sorry I don't understand your configuration. In particular, I don't understand why a router would be looking inside TCP packets that its routing and take notice of TCP options. Perhaps an annotated diagram would help me.


Log in to reply