Portal captivo en nodo SIN salida a internet



  • Hola buenos dias, soy del proyecto buenos aires libre (buenosaireslibre.org), nos dedicamos a montar redes wifi comuniarias.

    Levante un nodo y estoy implementando pfsense que hasta ahora va de mil maravillas ecepto por una cosa, el portal captivo.

    La red no tiene ningun tipo de salida a internet (sencillamente por que no hay), el portal captivo solo aparece cuando voy a una direccion de la red local castor.oncelibre.bal pero no cuando pongo google.com lo que sea .com .org, bueno se entiende.

    La dificultad esta en crear una regla que al no resolver el nombre por que no hay internet todas las peticiones que se hagan al .com, .com.ar, etc vayan al portal captivo.

    muchas gracias.



  • Services - Captive portal - Allowed IP addresses

    Igual te falta poner la IP de tu DNS interno ahí, si no es tu pfSense.

    Adding allowed IP addresses will allow IP access to/from these addresses through the captive portal without being taken to the portal page. This can be used for a web server serving images for the portal page or a DNS server on another network, for example.

    Traducción…

    Añadiendo direcciones IP permitidas tendremos acceso hacia (to) desde (from) estas direcciones a través del portal cautivo, sin necesidad de pasar por la página del portal. Esto puede emplearse para acceder a un servidor web con imágenes para el portal cautivo o a un DNS situado o otra subred, por ejemplo.

    Prueba, a ver...



  • Me parece que no se entendio, el dns teoricamente es el mismo pfsense…, ojo que no quiero bloquear la salida a internet por que no hay internet, lo unico que quiero armar es una wlan en un lugar donde internet no existe, si un vecino se conecta a mi essid abierto y ponga google.com u holaquetal.net vaya al portal cautivo. es algo que no estoy logrando con el pfsense sin internet.



  • Por ejemplo seria correcto hacer este procedimiento?

    Creating dnsmasq.conf is easy:
    1. In the webGUI, go to Diagnostics > Edit File;
    2. In the Edit File file contents window, type the configuration options you want, one per line (see links below);
    3. In the Save/Load from path field, type /usr/local/etc/dnsmasq.conf and hit Save;
    4. In Status > Services, restart dnsmasq.

    agregar al dnsmasq.conf lo siguiente?

    Add domains which you want to force to an IP address here.

    The example below send any host in double-click.net to a local

    web-server.

    #address=/double-click.net/127.0.0.1

    address=/google.com/192.168.0.245 (ip del servidor donde esta el portal captivo)
    address=/google.com.ar/192.168.0.245 (ip del servidor donde esta el portal captivo)
    address=/hotmail.com/192.168.0.245 (ip del servidor donde esta el portal captivo)

    etc.

    gracias



  • La página de CP no te aparece porque no hay servicio DNS.

    Hay un artículo por ahí que explica cómo hacer lo que quieres:

    http://doc.pfsense.org/index.php/Creating_a_DNS_Black_Hole_for_Captive_Portal_Clients



  • Me hago de informacion ahora por que cuando vaya al nodo no voy a tener internet. el procedimiento que me pasaste es lo que estoy buscando. te agradesco por el link, igual te voy a consultar 2 o 3 cosas mas
    Por cierto, muy buena la guia que dejaste de instalacion y configuracion de pfsense, fue por eso que lo empeze a usar, jaja

    $TTL    604800
    @      IN      SOA    . root.localhost. (
                                  1        ; Serial
                            604800        ; Refresh
                              86400        ; Retry
                            2419200        ; Expire
                            604800 )      ; Negative Cache TTL

    IN NS .
    . IN A 192.168.1.5
    *. IN A 192.168.1.5 #podria reemplazar esta liena por esta?
    *.com IN A 192.168.1.5 #de aca…

    y lo otro, en la guia que me pasaste explica esto otro

    Test a host that exists:

    host www.google.com 127.0.0.1

    Using domain server:
    Name: 127.0.0.1
    Address: 127.0.0.1#53
    Aliases:

    www.google.com has address 192.168.1.5

    eso ultimo tambien se carga en el archivo /etc/namedb/db.catchall, claro que si el *.com funciona lo segundo no tendria razon de ser.


Log in to reply