Ayuda con configuración "peculiar"



  • Hola a todos:

    A ver si me podéis ayudar / aconsejar con la configuración de mi pfsense.

    Tengo 3 NIC en mi pfsense, 1 a LAN, y las otras 2 cada una a una ADSL distinta. Mi objetivo no es tener balanceo de carga, sino Failover, tanto de entrada como de salida. Ahora lo tengo todo configurado y funciona, pero creo que se están perdiendo paquetes o algo por el estilo porque me cuesta mucho conectarme cuando las 2 ADSL funcionan. Si apago una de las 2, todo funciona mucho mejor.

    Os explico un poco la configuración para ver si alguien puede encontrar "el" o "los" fallos:

    1 - Asociar las 2 IPs publicas a un nombre de subdominio:

    En las DNS de mi dominio he creado un subdominio con dos entradas tipo A, de manera que el mismo una IP no contesta, el servidor DNS resuelva la otra

    server.midominio.com    A      88.88.88.88
    server.midominio.com    A      99.99.99.99

    2 - NAT (Port Forward):

    El direccionamiento de los puertos de mis aplicaiones lo he duplicado para las 2 ADSL:

    WAN        TCP        TerminalServerPort        IPServer    TerminalServerPort
    WAN2      TCP        TerminalServerPort      IPServer      TerminalServerPort
    …...

    3 - NAT (Outbound):

    WAN      192.168.1.0/24  *    *    *    *    *    NO
    WAN2    192.168.1.0/24  *    *    *    *    *    NO

    4 - Rules (LAN):

    *    LAN net      *    *    *    10.10.10.10  <- IP del Router de ADSL 1
    *    LAN net      *    *    *    10.10.20.10  <- IP del Router de ADSL 2

    5 - Rules (WAN):

    TCP    *      *      IPServer    TerminalServerPort      10.10.10.10
    .....

    6 - Rules (WAN2):

    TCP    *      *      IPServer    TerminalServerPort      10.10.20.10
    .....

    Y nada mas, esto es todo.

    Siento mucho el rollo que acabo de poner, pero no se que mas probar o que mas hacer.

    ¿Se puede hacer lo que intento hacer? Y ¿se puede hacer con pfsense o tengo que buscar alguna alternativa?

    Muchas gracias por vuestro tiempo
    .



  • Por lo que he leido, tienes la misma subnet para ambas ADSL (192.168.1.0 /24) ¿es esto así?, si es así, puede ser ese el problema



  • Perdona, he leido con más calma y he visto que esa es tu LAN, las prisas me han jugado una mala pasada. La verdad es que no veo cual puede ser el fallo.



  • ¡Hola!

    ¿Tiene tu servidor la IP de la LAN de pfSense como puerta de enlace determinada y DNS?

    Saludos,

    Josep Pujadas



  • Como puerta de enlace predeterminada si. Los DNS no, ya que mi servidor es un Windows Server 2003 con Active Directory y el mismo es servidor DNS.

    La que intento es tener Failover, no Balanceo de carga. Ahora he desactivado el enlace WAN2 (solo estoy trabajando con LAN y WAN) y todo funciona perfectamente, sin retardos y a una velocidad muy correcta.

    No se si lo que he configurado esta bien o no, lo que intento es que todo el trafico salga por WAN, y si WAN no funciona, que salga por WAN2, pero solo si no funciona. Y el tema de las conexiones entrantes, pues si un cliente se conecta por WAN, que los datos entre servidor y cliente se envien por WAN, y si se contecta por WAN2, pues por WAN2, no quiero balanceo de carga.

    La sensacion que estoy teniendo es la siguiente: un cliente se conecta por WAN2, el servidor atiende la peticion pero al salir, sale por WAN y el software con el que se conecta no entiende o rechaza la conexion de una IP diferente, reintenta y reintenta hasta que el servidor sale por WAN2 y entonces todo funciona.

    A ver si me podeis ayudar, porque no veo solucion a mi problemas.

    Otra solucion seria comprar este aparato:
    http://www.alvaco.es/index.php?option=com_content&task=view&id=38&Itemid=125

    Pero a parte de que es muy muy caro, no se si me va ha dar algo mas que pfsense o si voy a seguir teniendo los mismos problemas.

    No se, no se.



  • ¡Hola de nuevo!

    ¿Has mirado como hacer failover?

    Está en http://doc.pfsense.org/index.php/Multi-Wan/Load-Balancing

    Las pantallas que hay no cuadran con mi pfSense (1.0.1) …

    La documentación es del 05-feb. Ello quisiera decir que han añadio la posibilidad de separar el balanceo del failover en los "pools".

    Lo he mirado en los dos pfSense que tengo montados (embedded y LiveCD -completa-). En ninguno de ellos tengo los botones de [Behavior].

    Lo que sí es seguro es que para hacer lo que deseas tienes que definir un "pool".

    Tendrás que probar con la "developers edition":

    http://pfsense.com/mirror.php?section=downloads/developers

    ¡Ánimo! pfSense es magnífico y cambiante …

    ;)

    Saludos,

    Josep Pujadas



  • Voy a probar la versión del 07/02/2007, a ver si esta si tiene el opcion de [Behavior] y se me solucionan los problemas.

    Gracias por todo  ;)

    Y hablando de alternativas (es que ya estoy un poco desesperado), ¿algun Firewall Hard o Soft que soporte varios enlaces WAN y que permita Failover? ¿Alguna alternativa a pfSense de pago o no?



  • ¡Hola de nuevo!

    La verdad es que yo estuve mirando mucho y necesitaba "algo" para organizar el tráfico de tres LAN con tres ADSL …

    Terminé con pfSense porque es de código abierto y está basado en FreeBSD, con el que trabajo en mis servidores desde el año 2000.

    pfSense tiene todavía algunos problemillas pero es un buen proyecto. Lo demás que encontré es cerrado (propietario) y carísimo. Y otros proyectos de código libre parecen menos "marchosos".

    Si quieres algo propietario, he trabajado con Kerio (http://www.kerio.com) bajo Windows 2000 Server (ignoro si está disponible en otras plataformas) y es una maravilla. Tendrías que ver si se ajusta a lo que necesitas.

    No sé qué tiempo/paciencia dispones, pero también puedes acceder a la última versión de desarrollo de pfSense en:

    http://snapshots.pfsense.com/FreeBSD6/RELENG_1/

    Saludos,

    Josep Pujadas



  • Hola de nuevo:

    Bueno, creo que ya tengo el tema solucionado aunque no con pfSense. Con la ultima versión de pfSense y configurando el Failover no soluciono nada. Creo que todavía tienen que pulir un poco mas este tema.

    La solución para mis problemas: ClarkConnect 4.0 Enterprise (de pago, eso si, aunque hay versiones Free sin MultiWan)

    ClarkConnect hace muchas cosas (Servidor Web, Email, etc…) pero yo lo tengo todo desactivado, solo lo utilizo de Firewall. Configuras los 2 adaptadores y a uno de ellos le das mas "peso" que al otro (configurando uno como principal y el otro como backup). Todo el tráfico sale por la ADSL principal y solo en el caso que falle sale por la de Backup. Cuando la principal vuelve a funcionar, pues todo el trafico sale por la principal.

    Y el tema de las conexiones externas, el solo actualiza un registro DNS Dynamico tipo "miservidor.pointclark.net" con la IP de la ADSL en uso. Solo hay que decirle a los clientes que se conecten a este nombre de host.

    Si alguien tiene problemas similares y quiere saber mas cosas, aquí estoy para echar un cable.

    Muchas gracias a todos por la ayuda prestada  ;)


Log in to reply