Wireless not allowing connection to internet



  • Hi All,

    I'm new to Pfsense and was hoping that someone could help me.

    I've got an atom board with two gigabit nic's which i've set up for WAN and LAN - there is also a mini pci-e slot in which i have a Athros wireless card insalled.
    I've set up pfsense with DHCP on the WAN (to get an ip from the isp) and the lan also used dhcp to give ip's to my wired clients. the Wireless also uses dhcp to give ips to the wireless clients.
    The wireless is setup with no security features (for testing) and the wireless clients (in this testing case, my ubuntu laptop and my phone) and they get an ip ok but they cannot connect to the internet (the wired is ok)

    here's my details;

    WAN interface (re0)
    Status up
    DHCP up 
    MAC address
    IP address
    Subnet mask 255.255.255.0
    Gateway
    ISP DNS servers

    Media 100baseTX <full-duplex>In/out packets 6433/4284 (7.10 MB/588 KB)
    In/out errors 0/0
    Collisions 0
    LAN interface (re1)
    Status up
    MAC address
    IP address 192.168.1.1 
    Subnet mask 255.255.255.0
    Media 1000baseTX <full-duplex>In/out packets 5355/8140 (763 KB/8.77 MB)
    In/out errors 0/0
    Collisions 0
    OPT1 interface (ath0)
    Status associated
    MAC address
    IP address 192.168.2.1 
    Subnet mask 255.255.255.0
    Gateway 192.168.1.1
    Media autoselect mode 11g <hostap>Channel 1
    SSID WirelessAP
    In/out packets 341/231 (61 KB/26 KB)
    In/out errors 106/0
    Collisions 0

    Hopefully that makes sense and hopefully someone can help

    Cheers</hostap></full-duplex></full-duplex>



  • Have you set up some firewall rules yet?  If so, please post, if not, that might be your problem since any interface after the lan and wan have no default rule base (opt##), like pass all.



  • @LostInIgnorance:

    Have you set up some firewall rules yet?  If so, please post, if not, that might be your problem since any interface after the lan and wan have no default rule base (opt##), like pass all.

    Hi LostInIgnorance,

    There was no rule set by default so i have added the following;

    action - pass
    interface - OPT1
    sourse - any
    destination - any
    gateway - 192.168.1.1

    Still no luck, Any ideas?

    [edit] looking at the system logs- the traffic is being blocked by

    The rule that triggered this action is:

    @70 block drop in log quick all label "Default deny rule"

    [edit/]



  • try using the below rule without specifying the gateway

    @Origin_Unknown:

    action - pass
    interface - OPT1
    sourse - any
    destination - any
    gateway - 192.168.1.1

    Also, have you done any manual setup with nat, or have you left it as the default of pfsense creating the nat rules for you?

    Another thing you can try is pinging google.com from the firewall gui directly [Diagnostics>Ping]

    EDIT: Are you trying to bridge the wired lan and the wireless?  Just wondering since on the wireless (opt1) interface you are specifying the gateway of the lan.  If they are two separate networks (like my "pube-lic" wifi is at the house [don't need friends crapboxes screwing up my local lan]) then the gateway does not need to be specified since pfsense uses the wan gateway as its link.
    If you're looking to bridge the two so you have lan resources, let me know and I can walk you through how to configure it.



  • cheers for the replys LostInIgnorance,

    I really appreciate the help! At the moment the pfsense box isn't plugged in but what ill do is post up some screenshots of my config pages tomorrow and hopefully that will be better than me trying to post information.

    thanks again



  • Righty, Hopefully these can help.

    Lan interface

    Opt1 interface

    DHCP on Lan

    DHCP on opt1

    Nat Outbound

    Interface Status (WAN has no carrier as i only plugged the box in to get the screenshots)

    Wan Firewall rules

    LAN Firewall rules

    Opt1 Firewall Rules

    Opt1 firewall rules expanded

    Hope this helps.



  • Yeah, looks like you wanna bridge.  When I get home in another hour, I'll post an easier how to, otherwise, see if this makes any sense.
    http://forum.pfsense.org/index.php?topic=7946.0



  • One thing that is easy to forget after changing firewall rules is that it is often necessary to reset firewall states after the rule change: see Diagnostics -> States and click on the Reset States tab.



  • Cheers for the help guys, it's very much appreciated!

    @LostInIgnorance:

    Yeah, looks like you wanna bridge.  When I get home in another hour, I'll post an easier how to, otherwise, see if this makes any sense.
    http://forum.pfsense.org/index.php?topic=7946.0

    I was sure that i tried bridging before but ill have a look through that link later on when i'm back from work and see how it goes

    @wallabybob:

    One thing that is easy to forget after changing firewall rules is that it is often necessary to reset firewall states after the rule change: see Diagnostics -> States and click on the Reset States tab.

    Ill have a look at that one first before the bridging as it appears alot simpler.

    ill let you know how i get on, thanks again



  • @LostInIgnorance:

    Yeah, looks like you wanna bridge.  When I get home in another hour, I'll post an easier how to, otherwise, see if this makes any sense.
    http://forum.pfsense.org/index.php?topic=7946.0

    Just been having a look at Bridging the OPT1 to the LAN and it appears the DHCP is only functioning on LAN so anything that tries to connect to the wireless will not get an IP so doesn't connect.

    OPT1 interface (ath0)
    Status associated
    MAC address 00:1f:3a:52:ef:58
    IP address 0.0.0.0 
    Subnet mask 255.0.0.0
    Gateway 192.168.1.1
    Media autoselect mode 11g <hostap>Channel 1
    SSID LocalWAP
    In/out packets 64/409 (15 KB/283 KB)
    In/out errors 127/380
    Collisions 0
    Bridge (bridge0) learning</hostap>



  • Oh, Nevermind - after i posted the above i managed to fix it!

    I turned off "Allow intra-BSS communication"
    Under - "General configuration" Changed 'Type' from DHCP to Static and added an ip address then it is now working.



  • I forgot to say - thatnks for the help on this one guys but i've decided to just stick with my current wireless router - there's just too much messing about to be done to get pfsense working properly - after i got wireless working, VNC stopped working on my internal network


Locked