Manual update never goes ahead on alix and nanobsd



  • i have noticed this from past 2 months or so, sometimes to update to a latest snapshot, i download it manually and try to update pfsense using the manual update method on the web interface, as soon as i browse for the file and hit upgrade firmware, the page just never goes ahead, usually u get a warning of not signed file and when u click yes it used to proceed but since these last 2 months this manual method update doesn't work, page status keeps saying waiting for 192.168.0.1.

    auto update works fine



  • i guess it seems me only, what could be wrong in my setup, i have used auto update most of the time since 1.2.3



  • Never tried a manual update before tonight, but I do get the same results.  I can see my pc network activity uploading the firmware to my ALIX but once it finishes, nothing happens.  No update, no new/next web gui page.



  • it also has issues if u upload from shell


  • Banned

    This version "2.0-RC2 (i386) built on Sat Jun 4 22:23:29 EDT 2011" crashes on auto update from webGUI. The box needs a hard reset to function.



  • @Supermule:

    This version "2.0-RC2 (i386) built on Sat Jun 4 22:23:29 EDT 2011" crashes on auto update from webGUI. The box needs a hard reset to function.

    Did you try a manual update first?  Mine just ugraded fine, but if I try a manual update nothing happens and if I try a auto update right after that without rebooting nothing will happen as well.



  • issue still there



  • try updating from terminal



  • its the same, only auto update works



  • did you allow unsigned updates?



  • yup, earlier it used to even give a page that says its not signed, would u like to continue but now there is no response once u start uploading the firmware



  • I'm having the exact same problem with manually updating from RC1 to RC3. I can see the file being uploaded by watching the network traffic, but nothing happens after the upload finishes. The web interface becomes unresponsive. If I ssh in and run top, the system is basically idle. Restarting the Webconfigurator through ssh gets the web interface working again. I've tried both with and without the allow unsigned images checkbox checked.


  • Rebel Alliance Developer Netgate

    In all of these cases, are you all sure you are using the right type (upgrade slice) and size NanoBSD firmware update file when you're trying to do the manual update?

    Trying to upload a full image as an upgrade file will fail in some interesting ways, including the symptoms described here.



  • yes im dead sure its the proper file coz it used to work earlier since v1.2.3


  • Rebel Alliance Developer Netgate

    It would be interesting to know if it was something in the image file that changed that made it stop working or with the system being upgraded from. Nothing has really changed in that code in quite a while, it doesn't make a lot of sense why it would have just stopped working one day. Unfortunately it would be quite cumbersome to do any kind of regression testing there on a live system. VMs would be faster but may not accurately represent the issues that could be seen on real hardware (for instance, if something is timing out, that would likely work in a VM but not on, say, and ALIX).



  • I upgraded my 2D3 (from 1.2.3) last week to late a June snapshot.  Other than losing the RRD graphs, it was flawless.  I've been upgrading to later snapshots ever since without incident.  One thing I will say, the copy (and presumably the unzipping) takes several minutes for my 2GB CF card.  I can only imagine how long it's taking for the 4GB ungrades  ::)  The browser spins with no feedback of progress until the unsigned package dialog appears.  Any advice on what file can be tailed during upgrade that will show the copy and unzip?

    Thanks



  • it hasnt been recent snaps, its from a very long time and earlier i though it might have been certain snaps but after more than  a month i realized that it still doesnt work, basically on the webgui the page keeps going on and on, doesnt say done nor does it show the unsigned page, once u start the upload it just doesnt end and then if u eve check after sometime, it wont progress but the dashboard will show increased disk space usage which means the file get uploaded but mayb some bug in the php page code which might be preventing the unsigned page from loading which might be one of the issues coz if the message comes and u click yes then usually it would finish successfully and reboot.


  • Rebel Alliance Developer Netgate

    That would be easy to test - just check the box in the firmware settings to allow unsigned images, and then try again. No need for the box to show up then.



  • Argh, my problem was that I was using the full RC3 release instead of the upgrade and I wasn't being patient enough. After uploading the correct update file and leaving it for ~10 minutes, the upgrade applied fine and the router rebooted.



  • i ticked the box and tried again, even after 30mins nothing happening, 30mins after the firmware was uploaded which is when the network usage went zero. its the same issue from console as well if u select upgrade from console, it doesn't end ever.



  • i tried a second time now again and it took 12mins after upload just to give the message in console firmware being updated as well as the message in the gui, earlier it used to give message as soon as almost 3-5mins after upload or as soon as the click yes for unsigned page opens in the webgui which made u believe its working fine rather than waiting sometime without any message or prompt. During those 12mins i opened the shell and ran top and it showed all process close to 0% cpu usage which earlier used to show php consuming higher cpu which also made u believe there is still some activity going on in regards to the upgrade.

    all in all it works now but i guess giving a prompt or message earlier would be better


Locked