No logro NAT de la WAN a la LAN : ( AYUDA!



  • Saludos, He tratado de realizar NAT desde mi WAN hacia la LAN y no me resulta. :'(

    Interfaces:
    WAN: [IP PUBLICA]
    LAN: 192.168.217.2/24

    [WAN:444]    –-->  [LAN HOST]:443
    Quiero desde  [IP PUBLICA]:444 –-> 192.168.217.245:443

    Actualmente tengo algunas reglas en la interfaz WAN para conectarme al Pfsense por cualquier via (ssh,telnet,https).
    Y funcionan todas.

    –----------------------------------------------------------------------------------------------------------
    ID Proto Source Port     Destination Port Gateway Queue Schedule Description
    –------------------------------------------------------------------------------------------------------------------
                *        RFC 1918    *           *      *    *       *            -  Block private networks
                          networks

    *       Reserved/   *        *      *      *       *       * Block bogon networks
                        not assigned ----------------------------------------------------------------------------------------------------------------------
          TCP/UDP     *           *   192.168.217.245 443  *       none             NAT Acceso al Server

    TCP/UDP     *           *     WAN-IP   443  *       none       -   Permite HTTPs to PFsense

    TCP/UDP     *           *     WAN-IP           444  *       none          -        Permit Port 444

    TCP/UDP     *            *     WAN-IP   23          *       none          -        Permit  Telnet to Pfsense

    TCP/UDP     *           *     WAN-IP    22  *       none       -          Permit SSH to Pfsense

    Pero no he logrado llegar a una IP Privada (LAN) desde la IP PUBLICA (WAN)  :'( :'( ???

    Port Forward:
    –--------------------------------------------------------------------------------------------------------------------------
        If Proto Src. addr   Src. ports   Dest. addr Dest. ports NAT IP   NAT Ports Description

    WAN    TCP/UDP       *              *           WAN address         444     PROVISIONING 443

    Firewall Aliases:
    192.168.217.245  <===>  PROVISIONING

    Podrian decirme como  logro esto o que estoy estoy haciendo mal??

    IMPORTANTE: La interfaz WAN no da ping a ningun host de LAN solo responde la IP de la Interfaz LAN.
    Actualmente corro la version: Pfsense 2.0-RC1 (i386) built on Sat Feb 26 15:30:26 EST 2011
                                                                                                    Aun no realizo el Update.

    GRacias,



  • que puerta de enlace tiene el equipo para la nat? usaste ruler o creaste la regla por nat?

    Saludos



  • @cannivall:

    Saludos, He tratado de realizar NAT desde mi WAN hacia la LAN y no me resulta. :'(

    La dirección destino (Dest.addr), debe sen LAN



  • ok,.. pero entonces tendria que definir un gateway para mi propia LAN?? porque no aparece en los gateways disponibles…



  • Gateway para que??.No quieres hacer Port Forward??



  • Mira, actualmente tengo 2 NAT. Una para un Router (funciona) y otra para un server WEB (no funciona).

    El NAT hacia el  router es sobre el mismo puerto :  WAN:23 –-> LAN:23 y funciona!
    Aunque tuve que agregar la interfaz LAN en mis gateway!!  (esta bien raro eso..)

    Sin embargo el del WebServer es WAN:4343 ---> LAN:443. y esta en la misma red LAN.

    Lo que hago es crear la regla para el puerto a utilizar en la interfaz wan y luego realizar el NAT.
    Todos los puertos abiertos en la WAN funcionan, porque estan probados accesando a mi pfsense desde otra red.
    ... pero no doy el webserber  ???

    NAT RULES

    http://imageshack.us/photo/my-images/710/natrules.jpg

    FIREWALL WAN RULES

    http://imageshack.us/photo/my-images/804/firewallruleswan.jpg

    FIREWALL LAN RULES

    http://imageshack.us/photo/my-images/855/fireraillruleslan.jpg

    alguna sugerencia?



  • el webserver tiene a pfsense como gateway¿?



  • Si, el webserver esta en la misma red de la itnerfaz LAN que el Pfsense.

    PFsense LAN IP: 192.168.217.2
    WebServer IP: 192.168.217.245

    Tendria que hacer alguna regla en al interfaz LAN ??



  • Tienes que generarla en NAT, las reglas se activan automaticamente.

    Saludos

    Luis



  • Hola amigo

    http://forum.pfsense.org/index.php/topic,37554.0.html

    busca mi reply, un ejemplo de nat en 2.0 RC1

    saludos

    flosx



  • @flosx:

    Hola amigo

    http://forum.pfsense.org/index.php/topic,37554.0.html

    busca mi reply, un ejemplo de nat en 2.0 RC1

    saludos

    flosx

    hola amigos buen dia.. estoy tratando de implementar el portforwarding en una version 2.0 rc1 y no logro hacerlo , mi idea es entrar de una ip publica por ejemplo 10.10.10.1 a un servidor 192.168.0.15, y ya busque bastante por todos lados inclusive la forma que mencionan aqui arriba y no lo consigo.. no saben si este es un bug de esta version? o algo parecido?

    Saludos

    pd. mi configuracion actual es la siguiente despues de mil intentos (configuracion NAT)

    WAN  TCP/UDP  *  10000  192.168.0.15  80 (HTTP)  192.168.0.15  80 (HTTP)

    la regla del firewall fue amarrada con este con la opcion Filter Rules Association

    Saludos



  • Un ejemplo de nat en 2.0. Ojo la puerta de enlace en el equipo nateado tiene que ser la interfaz lan del pfsense.

    Configuracion de la regla para salida 80 pfsense via wan

    Nat

    Rules

    Viendo desde afuera

    Otro ejemplo (ssh)

    Tabla de enturamiento equipo NAT SSH

    Al crear la regla en nat se crean solas en rules. No se debe tocar nada mas.

    Saludos

    LOG



  • En el webconfigurator?
    que puerto tienes?
    WebGUI redirect lo tienes marcado?

    Podrías poner un patallazo de esto?



  • Gracias ya lo logre pero tengo un unico detalle de un pc me puedo conectar pero cuando trato desde otro me sale esto

    An HTTP_REFERER was detected other than what is defined in System -> Advanced (http://apintoah.dyndns.org:8181/system_advanced_admin.php). You can disable this check if needed in System -> Advanced -> Admin.

    Q puedo hacer?.

    Atte.



  • @locopepo:

    En el webconfigurator?
    que puerto tienes?
    WebGUI redirect lo tienes marcado?

    Podrías poner un patallazo de esto?

    puerto 80.



  • @locopepo:

    Gracias ya lo logre pero tengo un unico detalle de un pc me puedo conectar pero cuando trato desde otro me sale esto

    An HTTP_REFERER was detected other than what is defined in System -> Advanced (http://apintoah.dyndns.org:8181/system_advanced_admin.php). You can disable this check if needed in System -> Advanced -> Admin.

    Q puedo hacer?.

    Atte.

    http://en.wikipedia.org/wiki/HTTP_referrer

    Saludos

    LOG



  • Ah! olvide dar las gracias. Todo estaba bien en el Pfsense.
    El problema estaba en el server al que queria accesar. : ( Mala mia.

    Gracias de todos modos!


Locked