Horrible network performance with pfSense 2.0 and VMware



  • Hi there.

    I got a small setup in a datacenter, and im using NAT to isolate my local server-network from the internet. Before i used pfSense, my server were connected to the internet like this:

    Server [Realtek NIC] –> Physical Firewall (Dell R210 server with ubuntu) -> Internet

    The server also has another network interface [Zyxel NIC] that connects directly to the internet, in case that the R210 would go down.

    I decided to virtualize my firewall with pfSense since the R210 didnt do any other thing than routing so it was just waste of money to keep that running.. The server has a VMware server installation, and my web/dns/other servers are running as virtual servers. They connect locally to eachother on a 10.230.1.0/25 subnet.

    I use RDP to connect to the VMware host (its running WS2008R2) and when i used the old firewall everything were running smoothly. Now, everything runs like, well, just very bad. The virtual servers seems to be running just fine, and so are my vpn/pfSense firewall. The host system runs very bad even though that theres no cpu/memory/network/disk load.

    The network schema is now:

    Servers [Realtek NIC] –> [Realtek NIC] pfSense Firewall [Zyxel NIC] –> Internet

    I have tried to put an IP Address on the Zyxel NIC and then connect to the host system through that address, and that runs just smooth as it could. Ive tried to take a speedtest, it gives me 300Mbit/s down but only 0,2-15Mbit/s up. Before, it were around 900 mbits up and down. I have installed the open-vm-tools package..

    Thanks in advantage..



  • Seriousl can't anyone help me out with this..?



  • Did you mess around with traffic shaping? Take it off and see if it works any better.



  • I am a home user with a 15Mb down 1Mb up plan from my ISP, so unless I misread Mbits as Kbits my reply might not be too helpful.  However I have a near identical setup to yours, W2K8R2 with PFSense & Debian Web Host running in VMWare Server, I have experienced no slowdowns in internet speeds, and local speeds appear to be the same as before.


Locked