Bandwidthd



  • I haven't managed to get bandwidthd to record any data as yet.

    Skip intervals

    Graph cutoff  150
    Graph cutoff is how many k must be transfered by an ip before we bother to graph it 
    promiscuous  on
    Put interface in promiscuous mode to score to traffic that may not be routing through the host machine. 
    output_cdf  on
    Log data to cdf file htdocs/log.cdf 
    recover_cdf  on
    Read back the cdf file on startup 
    filter 
    Libpcap format filter string used to control what bandwidthd see's. Please always include "ip" in the string to avoid strange problems. 
    Draw Graphs  on
    This default to true to graph the traffic bandwidthd is recording. Usually set this to false if you only want cdf output or you are using the database output option. Bandwidthd will use very little ram and cpu if this is set to false. 
    Meta Refresh  150
    Set META REFRESH seconds (default 150, use 0 to disable).

    I have no idear what settings are needed but I have tryed a few and it doesn't record anything.  What could I be doing wrong.

    Thanks



  • your could start with the default settings

    then go to " status -> service " to check that the service is running

    look in " status -> system logs " for errors

    your also might need to edit /usr/local/bandwidthd/etc/bandwidthd.conf

    to do that go to " diagnostics -> edit file "

    save and restart service



  • Tryied that and it still doesn't work  :(

    Feb 12 14:16:16 bandwidthd: Packet Encoding: Ethernet
    Feb 12 14:16:16 bandwidthd: Opening xl0
    Feb 12 14:16:16 bandwidthd: Packet Encoding: Ethernet
    Feb 12 14:16:16 bandwidthd: Opening xl0
    Feb 12 14:16:16 bandwidthd: Packet Encoding: Ethernet
    Feb 12 14:16:16 bandwidthd: Opening xl0
    Feb 12 14:16:16 bandwidthd: Packet Encoding: Ethernet
    Feb 12 14:16:16 bandwidthd: Opening xl0
    Feb 12 14:16:16 kernel: xl0: promiscuous mode enabled
    Feb 12 14:16:16 bandwidthd: Monitoring subnet 10.255.0.0 with netmask 10.255.0.0
    Feb 12 14:16:15 kernel: xl0: promiscuous mode disabled
    Feb 12 07:49:07 snort2c[1102]: attack detected non-whitelisted ip: 219.133.62.192 blocked !
    Feb 12 07:49:07 snort2c[1102]: attack detected non-whitelisted ip: 219.133.62.192 blocked !
    Feb 12 01:00:00 check_reload_status: check_reload_status is starting
    Feb 10 03:00:00 check_reload_status: check_reload_status is starting
    Feb 10 02:55:00 check_reload_status: check_reload_status is starting
    Feb 10 00:35:00 check_reload_status: check_reload_status is starting
    Feb 9 21:22:00 kernel: WARNING: pseudo-random number generator used for IPsec processing
    Feb 9 20:53:32 syslogd: kernel boot file is /boot/kernel/kernel



  • Can i use this package wit next configuration?

    • bridge(1 wan + 1 lan)
    • squid


  • is xl0 your lan



  • no I have an internal interface as rl0 which I have changed in the log since I posted it



  • Hmmm no when I goto see the charts I get a blank screen.



  • if your .conf looks like this

    Subnets to collect statistics on.  Traffic that

    matches none of these subnets will be ignored.

    Syntax is either IP Subnet Mask or CIDR

    subnet 10.255.0.0/24

    Device to listen on

    Bandwidthd listens on the first device it detects

    by default.  Run "bandwidthd -l" for a list of

    devices.

    dev "rl0"
    dev "xl0"

    try deleting the xl0 line
    save and restart service



  • This file was automatically generated by the pfSense

    package management system.  Changing this file

    will lead to it being overwritten again when

    the package manage resyncs.

    ####################################################

    Bandwidthd.conf

    Commented out options are here to provide

    documentation and represent defaults

    Subnets to collect statistics on.  Traffic that

    matches none of these subnets will be ignored.

    Syntax is either IP Subnet Mask or CIDR

    subnet 10.255.0.0/24

    Device to listen on

    Bandwidthd listens on the first device it detects

    by default.  Run "bandwidthd -l" for a list of

    devices.

    dev "rl0"

    ###################################################

    Options that don't usually get changed

    An interval is 2.5 minutes, this is how many

    intervals to skip before doing a graphing run

    Graph cutoff is how many k must be transfered by an

    ip before we bother to graph it

    #Put interface in promiscuous mode to score to traffic
    #that may not be routing through the host machine.

    #Log data to cdf file htdocs/log.cdf
    output_cdf true

    #Read back the cdf file on startup
    recover_cdf true

    #Libpcap format filter string used to control what bandwidthd see's
    #Please always include "ip" in the string to avoid strange problems

    #Draw Graphs - This default to true to graph the traffic bandwidthd is recording
    #Usually set this to false if you only want cdf output or
    #you are using the database output option.  Bandwidthd will use very little
    #ram and cpu if this is set to false.

    #Set META REFRESH seconds (default 150, use 0 to disable).

    This is strange because sometimes when you click access bandwidthd it doesn't load up anything. Then other time it will load but just say no details have been collected.



  • I have been testing bandwidthd and come to the following, for whatever it is worth.

    If I install Pfsense with xl0=wan and xl1=lan, bandwidthd will listen to wan.
    If I install Pfsense with xl0=lan and xl1=wan, bandwidthd will listen to wan. (Can be seen in system logs.)
    No logging of  in either case.

    However, if I go to interfaces assign and swap interfaces there, it works like a dream. But if I change any settings and save, bandwidthd goes back to listen to wan and stops logging.

    I tried to set the interface in the configfile with no luck. I did notice a notice stating that it will chose the first interface it seas, and that this is set in the startup script an will override the configfile.



  • Same behavior over here.

    I run pfSense with 3 NICs (Realtek…) with rl0 being LAN and rl1 assigned to WAN. rl2 is currently unassigned.

    A checkbox on the config page to tell bandwithd the port to listen on would be really helpful.



  • See the original thread.  There are many bugs in bandwidthd.



  • As i posted yesterday IN the original thread before it was deleted, I cannot get the latest package to install.

    It just hangs on this step:

    "Executing custom_php_install_command()…"

    As i said, im not sure if its just me, but i could install the old package fine and i just thought id let you know.

    Cheers,



  • @Omega:

    As i posted yesterday IN the original thread before it was deleted, I cannot get the latest package to install.

    It just hangs on this step:

    "Executing custom_php_install_command()…"

    As i said, im not sure if its just me, but i could install the old package fine and i just thought id let you know.

    Cheers,

    Upgrade to the latest snapshot.  I cannot reproduce this issue here.



  • I have the same problem. It hangs on custom_php_install_command()

    Heres the logs:
    Feb 19 21:47:13 php: /pkg_mgr_install.php: Beginning package installation for bandwidthd.
    Feb 19 21:47:15 php: /pkg_mgr_install.php: You should specify a interface for bandwidthd to listen on. exiting.



  • @LawnMowerGuy1:

    I have the same problem. It hangs on custom_php_install_command()

    Heres the logs:
    Feb 19 21:47:13 php: /pkg_mgr_install.php: Beginning package installation for bandwidthd.
    Feb 19 21:47:15 php: /pkg_mgr_install.php: You should specify a interface for bandwidthd to listen on. exiting.

    Update to the latest snapshot.



  • Fixed a few installation issues as well.  Please try again



  • Warning: fopen(/usr/local/bandwidthd/etc/bandwidthd.conf): failed to open stream: No such file or directory in /usr/local/pkg/bandwidthd.inc on line 172



  • Im still getting the "No Data to Graph Error" i was getting prior to the update. (though the updated version does install now again).

    Log shows this:

    Feb 19 21:24:19 bandwidthd: Packet Encoding: Ethernet
    Feb 19 21:24:19 bandwidthd: Opening rl0
    Feb 19 21:24:19 bandwidthd: Packet Encoding: Ethernet
    Feb 19 21:24:19 bandwidthd: Opening rl0
    Feb 19 21:24:19 bandwidthd: log.3.0.cdf is corrupted, skipping
    Feb 19 21:24:19 bandwidthd: log.3.0.cdf is corrupted, skipping
    Feb 19 21:24:19 bandwidthd: Packet Encoding: Ethernet
    Feb 19 21:24:19 bandwidthd: Opening rl0
    Feb 19 21:24:19 bandwidthd: log.1.0.cdf is corrupted, skipping
    Feb 19 21:24:19 bandwidthd: log.1.0.cdf is corrupted, skipping
    Feb 19 21:24:19 bandwidthd: Packet Encoding: Ethernet
    Feb 19 21:24:19 bandwidthd: Opening rl0
    Feb 19 21:24:19 bandwidthd: log.2.0.cdf is corrupted, skipping
    Feb 19 21:24:19 bandwidthd: log.2.0.cdf is corrupted, skipping



  • I did:
    mkdir /usr/local/bandwidthd
    mkdir /usr/local/bandwidthd/etc
    touch /usr/local/bandwidthd/etc/bandwidthd.conf

    Now it installs.



  • I have done an update so I will test it when I get home.



  • @LawnMowerGuy1:

    I did:
    mkdir /usr/local/bandwidthd
    mkdir /usr/local/bandwidthd/etc
    touch /usr/local/bandwidthd/etc/bandwidthd.conf

    Now it installs.

    That should not be needed.  The FreeBSD package has all of this in it..



  • Now I get a blank screen ??????


Log in to reply