Pfsense 2.0 makinesinin kendi dns sorunu



  • loadbalance+squid+squidguard kurulu
    3 tane adsl hat var
    Bir süredir internet bağlantısında sorunlar çıkmaya başladı. Kullanıcılar Web sitesi adresini yazıyorlar, ama sayfanın gelmesi uzun sürüyor ya da bazen hiç gelmiyor.
    Farkettim ki dns çözümlemesinde sorun var.
    1-Clientlara dağıtılan dns sunucusu ip numarası, bizim localdeki active directory çalıştıran dns sunucumuz 10.10.1.44
    2- Bu dns sunucuda forwarder olarak 8.8.8.8 yazıyor, aynı zamanda cache tutuyor

    Pfsense'in dns ayarları ekteki gibi
    Pfsense örneğin bir update yapıldığında açılırken "unable to connect pfsense, check your dns" diyor. Bazen ekte gördüğünüz gibi, update var diyor, 2 saniye sonra refresh edince, unable to check for updates diyor.

    Ne yaptımsa stabil bir şekilde dns çözdüremedim.

    Sorun ne olabilir ?












  • Hocam,  DNS serverda yazılı olan 8.8.8.8,  8.8.8.4 IP adreslerine karşılık gene Use Gateway'i None çekip denedin mi?..



  • -Bu sorunu ciddi bir sıkıntı vermese de ufak ufak bende yaşıyordum.. Bu sabah aklıma Genereal settings teki "Allow DNS server list to be overridden by DHCP/PPP on WAN" seçeneğini seçmek geldi seçip kullanmaya başladım düzelmeler var.. Tuzsuzdeli arkadaş sanıyorum senin sıkıntınını da giderebilir istersen bi aç orayı..
    -Ayrıca 2.0 da farkettimki packages bölümüde sağlıklı gelmeye başladı.. Hani proxy i balance'a soktuğumuzdan beri bi yavaşlık ve packages bölümü sağlıklı açılmıyor demiştiniz ya (bana da aynısı oluyordu) işte onu seçtiğimden beri o sıkıntılarda düzeldi.. ;)



  • ustadlar bu pfs 2 çok sıkıntılı sanırım, LB yaptığımda  internete çıkışlarda çok belirgin yavaşlamalar görüyorum, sırf bu yüzden LB den vaz geçtim. hala bitiremediler şu betayı, :-\



  • @CemX:

    -Bu sorunu ciddi bir sıkıntı vermese de ufak ufak bende yaşıyordum.. Bu sabah aklıma Genereal settings teki "Allow DNS server list to be overridden by DHCP/PPP on WAN" seçeneğini seçmek geldi seçip kullanmaya başladım düzelmeler var.. Tuzsuzdeli arkadaş sanıyorum senin sıkıntınını da giderebilir istersen bi aç orayı..
    -Ayrıca 2.0 da farkettimki packages bölümüde sağlıklı gelmeye başladı.. Hani proxy i balance'a soktuğumuzdan beri bi yavaşlık ve packages bölümü sağlıklı açılmıyor demiştiniz ya (bana da aynısı oluyordu) işte onu seçtiğimden beri o sıkıntılarda düzeldi.. ;)

    Ne yazık ki onu hem geçmişte hem de sizin tavsiyeniz üzerine bugün tekrar denedim ama derdime derman olmadı.

    Bir fkural yazarak, DNS sorgularını da loadbalance'dan çıkarıp tek bir hatta filan da yönlendridim (hatlarda mı sorun oluyor diye) o da olmadı.

    Bu konu, çok sıkıntı yaratıyor şu an.
    İşin ilginç tarafı 1 gün hiç sorun yok iken, hiçbirşey değiştirmediğimiz halde bi sonraki gün atıyorum öğleden sonra hiçbir yere sağlıklı bağlanamıyor hale geliyoruz vsvs


Locked