Running PFSense 2.0 RC1 in Hyper-V



  • I can get version 1.2.3 to run in Hyper-V but it will not run 2.0 RC1.  It will not run the upgrade or off of the ISO.

    I am running Windows Server 2008 with SP 2 and Hyper-V.

    I have attached a picture with how far it boots with either running off of the ISO or after it upgrades from 1.2.3 to 2.0

    Any suggestions on how to get it to work?


  • Banned

    Hyper-V sucks as a virtualization platform….use ESXi or Xen.



  • I am using hyper-v.  Comes out of the box, and does what I want (virtualize 3 servers).  Maybe it's not as good somehow, but it does work with no issues on any windows boxes.
    I was planning on downing the pfsense box and switching that box to hyper-v.  I seem to see all sorts of issues, as developers like vmware, so they make it work with vmware.
      I think I'd rather keep the stand alone pfsense box, than go through the work of switching to vmware.

    Anyone have any luck getting pfsense 2.0 working on hyper-v?  I've seen people have 1.2.3 working, with the dhcp issues as the main problem.



  • After setting the virtual HD to 20GB, it's working (at least installing right now) in Hyper-V.  It failed saying it couldn't find the hard drive either IDE or SCSI saying it was the wrong number of cylinders.


Locked