Captive-portal voucher "active users"



  • I'm using version 2.0-RC1 (i386) built on Sat Feb 26 15: 30: 26 EST 2011.
    Setup vouchers to authenticate users who are patient in a hospital.
    I realize that the voucher expires but the user continues as "active user".
    If I try to use the voucher … actually this expired but need to manually delete the user that is as "active user"
    thanks....



  • IT gets disconnected when the voucher end time is reached.



  • Accurate. When the voucher expires, I tested, the user need to enter another voucher. But even he has gone, the information page of the captive it remains active. Thank you for your return. Below the image.

    ![Screenshot-pfsense.bpinternet - Status: Captive portal - Mozilla Firefox.jpg](/public/imported_attachments/1/Screenshot-pfsense.bpinternet - Status: Captive portal - Mozilla Firefox.jpg)
    ![Screenshot-pfsense.bpinternet - Status: Captive portal - Mozilla Firefox.jpg_thumb](/public/imported_attachments/1/Screenshot-pfsense.bpinternet - Status: Captive portal - Mozilla Firefox.jpg_thumb)



  • Please update to tomorrows snapshots this should be fixed.



  • Ermal … ....I returned the configs of "factory" and only went back up vouchers. In a first test with vouchers for 5 minutes "seems that it worked." The ip was gone as soon as the voucher has expired. I have an ip address that will expire tomorrow. Monday I'll have more information if it was resolved after changing or not. A thank you to all of you ... the community note 10.



  • Ermal …Really .... the voucher to 1440 minutes or 1 day kept the ip address as if it were still active, even if the voucher has been expired. Already the voucher generated for 5 minutes, it functioned normally. Any tips? A thank you.



  • next image…..thanks

    ![Screenshot-pfsense.bpinternet - Status: Captive portal - Mozilla Firefox-1.png](/public/imported_attachments/1/Screenshot-pfsense.bpinternet - Status: Captive portal - Mozilla Firefox-1.png)
    ![Screenshot-pfsense.bpinternet - Status: Captive portal - Mozilla Firefox-1.png_thumb](/public/imported_attachments/1/Screenshot-pfsense.bpinternet - Status: Captive portal - Mozilla Firefox-1.png_thumb)



  • Can you please do a

    cat /var/db/captiveportal.db

    when this happens.
    I just put some other improvements in the captiveportal code that might help this sitation as well.



  • Ok…....

    thanks...

    ![Screenshot-10.1.10.40 - PuTTY.png](/public/imported_attachments/1/Screenshot-10.1.10.40 - PuTTY.png)
    ![Screenshot-10.1.10.40 - PuTTY.png_thumb](/public/imported_attachments/1/Screenshot-10.1.10.40 - PuTTY.png_thumb)



  • Everything seems ok.
    Other than check with 'ps -ax | grep minicron' if you have the pruning process alive.



  • closing case. Not showed any ip address. I generated other vouchers and all quiet. Thank you.

    I came up that had formatting and Redid the settings.

    PFSENSE-DOES NOT HAVE WHAT TO SAY, IS A COMPLETE SYSTEM.



  • Sorry i cannot understand what you mean?



  • Hi,

    i have exactly the same problem. What I could observe is the follow:

    If the device is connected and the ticked expired, than all works fine.
    If the device isn connected and the ticked expired (1440 minutes Tickets), than the ticked is expired but the device can reconnect and go to the internet till i run the /etc/rc.prunecaptiveportal script.

    
    [2.0-RC3][root@pfSense.xxxxxxx.local]/root(9): cat /var/db/captiveportal.db
    1309756940,2,192.168.100.50,xx:xx:48:16:xx:xx,UC67pqCCyrh,8145ce9f8d1fe74f,,120,,0
    
    
    
    UC67pqCCyrh (10000/3) already used and expired
    
    

    If i run /etc/rc.prunecaptiveportal then the ticket/device will be disconnected and the device didn´t can reconnect to the internet with the device till i enter a new ticket.

    The settings in "idle timeout" and "hard timeout" are both not filled. Thats the settings i want.

    Regards, Valle



  • rc.prunecaptiveportal is run every minute so i do not think there is an issue there.


Locked