WebGui hangs



  • Hey

    I'm trying to access the WebGui of a pfsense server, but after the browser check the SSL certificate it hangs til forever.

    Here is my lighty-webConfigurator.conf

    
    #
    # lighttpd configuration file
    #
    # use a it as base for lighttpd 1.0.0 and above
    #
    ############ Options you really have to take care of ####################
    
    ## FreeBSD!
    server.event-handler            = "freebsd-kqueue"
    server.network-backend          = "writev"  ## Fixes 7.x upload issues
    
    ## modules to load
    server.modules              =   (
    
                                      "mod_access", "mod_accesslog",
                                      "mod_fastcgi", "mod_cgi"
                                    )
    
    ## Unused modules
    #                               "mod_setenv",
    #                               "mod_compress"
    #                               "mod_redirect",
    #                               "mod_rewrite",
    #                               "mod_ssi",
    #                               "mod_usertrack",
    #                               "mod_expire",
    #                               "mod_secdownload",
    #                               "mod_rrdtool",
    #                               "mod_auth",
    #                               "mod_status",
    #                               "mod_alias",
    #                               "mod_proxy",
    #                               "mod_simple_vhost",
    #                               "mod_evhost",
    #                               "mod_userdir",
    #                               "mod_cgi",
    #                                "mod_accesslog"
    
    ## a static document-root, for virtual-hosting take look at the
    ## server.virtual-* options
    server.document-root        = "/usr/local/www/"
    
    ## where to send error-messages to
    server.errorlog             = "/var/log/lighttpd.error.log"
    
    # files to check for if .../ is requested
    server.indexfiles           = ( "index.php", "index.html",
                                    "index.htm", "default.htm" )
    
    # mimetype mapping
    mimetype.assign             = (
      ".pdf"          =>      "application/pdf",
      ".sig"          =>      "application/pgp-signature",
      ".spl"          =>      "application/futuresplash",
      ".class"        =>      "application/octet-stream",
      ".ps"           =>      "application/postscript",
      ".torrent"      =>      "application/x-bittorrent",
      ".dvi"          =>      "application/x-dvi",
      ".gz"           =>      "application/x-gzip",
      ".pac"          =>      "application/x-ns-proxy-autoconfig",
      ".swf"          =>      "application/x-shockwave-flash",
      ".tar.gz"       =>      "application/x-tgz",
      ".tgz"          =>      "application/x-tgz",
      ".tar"          =>      "application/x-tar",
      ".zip"          =>      "application/zip",
      ".mp3"          =>      "audio/mpeg",
      ".m3u"          =>      "audio/x-mpegurl",
      ".wma"          =>      "audio/x-ms-wma",
      ".wax"          =>      "audio/x-ms-wax",
      ".ogg"          =>      "audio/x-wav",
      ".wav"          =>      "audio/x-wav",
      ".gif"          =>      "image/gif",
      ".wav"          =>      "audio/x-wav",
      ".gif"          =>      "image/gif",
      ".jpg"          =>      "image/jpeg",
      ".jpeg"         =>      "image/jpeg",
      ".png"          =>      "image/png",
      ".xbm"          =>      "image/x-xbitmap",
      ".xpm"          =>      "image/x-xpixmap",
      ".xwd"          =>      "image/x-xwindowdump",
      ".css"          =>      "text/css",
      ".html"         =>      "text/html",
      ".htm"          =>      "text/html",
      ".js"           =>      "text/javascript",
      ".asc"          =>      "text/plain",
      ".c"            =>      "text/plain",
      ".conf"         =>      "text/plain",
      ".text"         =>      "text/plain",
      ".txt"          =>      "text/plain",
      ".dtd"          =>      "text/xml",
      ".xml"          =>      "text/xml",
      ".mpeg"         =>      "video/mpeg",
      ".mpg"          =>      "video/mpeg",
      ".mov"          =>      "video/quicktime",
      ".qt"           =>      "video/quicktime",
      ".avi"          =>      "video/x-msvideo",
      ".asf"          =>      "video/x-ms-asf",
      ".asx"          =>      "video/x-ms-asf",
      ".wmv"          =>      "video/x-ms-wmv",
      ".bz2"          =>      "application/x-bzip",
      ".tbz"          =>      "application/x-bzip-compressed-tar",
      ".tar.bz2"      =>      "application/x-bzip-compressed-tar"
     )
    
    # Use the "Content-Type" extended attribute to obtain mime type if possible
    #mimetypes.use-xattr        = "enable"
    
    #### accesslog module
    #accesslog.filename          = "/dev/null"
    #accesslog.filename          = "/dev/null"
    
    ## deny access the file-extensions
    #
    # ~    is for backupfiles from vi, emacs, joe, ...
    # .inc is often used for code includes which should in general not be part
    #      of the document-root
    url.access-deny             = ( "~", ".inc" )
    
    ######### Options that are good to be but not neccesary to be changed #######
    
    ## bind to port (default: 80)
    server.port                = 9091
    
    ## error-handler for status 404
    #server.error-handler-404   = "/error-handler.html"
    #server.error-handler-404   = "/error-handler.php"
    
    ## to help the rc.scripts
    server.pid-file            = "/var/run/lighty-webConfigurator.pid"
    
    ## virtual directory listings
    server.dir-listing         = "disable"
    
    ## enable debugging
    debug.log-request-header   = "enable"
    debug.log-response-header  = "enable"
    debug.log-request-handling = "enable"
    debug.log-file-not-found   = "enable"
    
    #### compress module
    #compress.cache-dir         = "/tmp/lighttpd/cache/compress/"
    #compress.filetype          = ("text/plain", "text/html")
    
    #server.network-backend = "writev"
    
    server.upload-dirs = ( "/root/", "/tmp/", "/var/" )
    
    server.max-request-size    = 2097152
    
    #### fastcgi module
    ## read fastcgi.txt for more info
    fastcgi.server = ( ".php" =>
            ( "localhost" =>
                    (
                            "socket" => "/tmp/php-fastcgi.socket",
                            "min-procs" => 1,
                            "max-procs" => 2,
    
                            "bin-path" => "/usr/local/bin/php"
                    )
            )
    ) 
    
    #### CGI module
    cgi.assign                 = ( ".cgi" => "" )
    
    ## ssl configuration
    ssl.engine = "enable"
    ssl.pemfile = "/var/etc/cert.pem"
    
    

    I enabled debug on lightppd confs.. Here is the lighttpd.error.log:

    
    2011-06-15 13:28:22: (request.c.294) fd: 6 request-len: 365 
    GET / HTTP/1.1
    Host: acessoleducarj.no-ip.org:9091
    User-Agent: Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip, deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 115
    Connection: keep-alive
    
    2011-06-15 13:28:22: (response.c.221) -- splitting Request-URI 
    2011-06-15 13:28:22: (response.c.222) Request-URI  :  / 
    2011-06-15 13:28:22: (response.c.223) URI-scheme   :  https 
    2011-06-15 13:28:22: (response.c.224) URI-authority:  acessoleducarj.no-ip.org:9091 
    2011-06-15 13:28:22: (response.c.225) URI-path     :  / 
    2011-06-15 13:28:22: (response.c.226) URI-query    :   
    2011-06-15 13:28:22: (response.c.254) -- sanatising URI 
    2011-06-15 13:28:22: (response.c.255) URI-path     :  / 
    2011-06-15 13:28:22: (mod_access.c.135) -- mod_access_uri_handler called 
    2011-06-15 13:28:22: (response.c.391) -- before doc_root 
    2011-06-15 13:28:22: (response.c.392) Doc-Root     : /usr/local/www/ 
    2011-06-15 13:28:22: (response.c.393) Rel-Path     : / 
    2011-06-15 13:28:22: (response.c.394) Path         :  
    2011-06-15 13:28:22: (response.c.442) -- after doc_root 
    2011-06-15 13:28:22: (response.c.443) Doc-Root     : /usr/local/www/ 
    2011-06-15 13:28:22: (response.c.444) Rel-Path     : / 
    2011-06-15 13:28:22: (response.c.445) Path         : /usr/local/www/ 
    2011-06-15 13:28:22: (response.c.462) -- logical -> physical 
    2011-06-15 13:28:22: (response.c.463) Doc-Root     : /usr/local/www/ 
    2011-06-15 13:28:22: (response.c.464) Rel-Path     : / 
    2011-06-15 13:28:22: (response.c.465) Path         : /usr/local/www/ 
    2011-06-15 13:28:22: (response.c.482) -- handling physical path 
    2011-06-15 13:28:22: (response.c.483) Path         : /usr/local/www/ 
    2011-06-15 13:28:22: (response.c.490) -- file found 
    2011-06-15 13:28:22: (response.c.491) Path         : /usr/local/www/ 
    2011-06-15 13:28:22: (response.c.640) -- handling subrequest 
    2011-06-15 13:28:22: (response.c.641) Path         : /usr/local/www/ 
    2011-06-15 13:28:22: (mod_indexfile.c.151) -- handling the request as Indexfile 
    2011-06-15 13:28:22: (mod_indexfile.c.152) URI          : / 
    2011-06-15 13:28:22: (mod_access.c.135) -- mod_access_uri_handler called 
    2011-06-15 13:28:22: (mod_fastcgi.c.3671) handling it in mod_fastcgi 
    

    After that last message it hangs and my firefox keeps trying to connect til forever.

    I tried to disable, enable SSL, to change the ports, to disable some modules to, but no deal.

    Anyone have a idea how can I fix it?

    ps.: I tried to connect using firefox, chrome, iexploder… Connect from the internet, localhost, lan, vpn and the problem persist.



  • Almost forgot… I tried the same thing in this topic below, but it didnt work.

    http://forum.pfsense.org/index.php/topic,3079.0.html


Locked