PFSense on Xen - weird behaviour when using multiple interfaces



  • Using:

    • XenCenter 5.5.2
    • PFSense 2.0 RC3
    • 2 X Broadcom gigabit interfaces

    I tested this extensively today and noticed that I can't have two interfaces working at the same time.

    When I have interfaces re0 and re1 on the PF firewall, re1 does not work.  (When pinging from another host on the same virtual switch, re1 does not respond to arp requests.  Tcpdump shows that re1 is either not receiving the arp requests or not aware of the arp requests…)  I can ping and ARP normally from re0.

    If I remove re0 from the virtual host where PF is installed, then the remaining interface (formerly re1) can ping and arp without problems.

    I don't think there's anything wrong with my virtual switch or Xen setup, because (a) other hosts can ping each other on re1's network and (b) when re0 is removed from the PF firewall, re1 can ping and ARP as normal.

    Has anyone else had this problem where only one interface can work, or know what I'm doing wrong?



  • Bump, and let me see if I can rephrase the question

    Do I need to do anything special when installing PFSense on Xen?  All I did was install from the iso.  In particular, has anyone needed to tweak their nic drivers or startup scripts before it would work?  I chose "new VM -> other install media"

    Also, was anyone able to successfully install XenTools?  (According to this thread http://forum.pfsense.org/index.php?topic=17622.0 no, but I'm wondering if anyone got it working)



  • Ang,
    I build a ISO libary.  Added the PF-Sense ISO image to that libary.  You need to add to two interfaces.  What I did was add broadcom card or a dual port intel adatper.  I had tried two different cards for the different ways I wanted to install it.

    I use a managed switch and created two vlan's.  1 - that contains 2 switch ports(1 for modem connection and the other from the wan port from the XEN server)

    What I did was first was I added my wan adapter, then added the LAN adpater.  I left the adapter that I planned to use for the WAN adapter disconnected leaving the LAN connection connected.  I ran my installer and selected the disconnected port as the WAN connection and selected the connected port for the lan switch is connected to vlan 2.

    I selected 99 to do the custom installlation and installed on the vdisk thatwas created for the xen enviroment.  I been glad to work with you.  Please send me a personnel email and I we can setup some time to work togethor.
    RC



  • Hi RC,

    Thanks for the bump, I forgot that I posted this. What I ended up doing was trying the exact same installation on Xen 5.6, and it worked the way I expected it to.  (ie. Able to have multiple interfaces and ping out, etc.)

    I suspect there was something wrong with the virtual interface or interface drivers when running on Xen 5.5.

    Since I've got it working, I don't think any further troubleshooting is necessary.  Thanks for the response :)

    • ang -

Locked