IMSpector upgrade



  • Hi could some one advise me on how too upgrade imspector to the latest snapshot. The current package seems not too be logging  live messenger 2010 but it is logging the older versions fine. This is apparently corrected in a snapshot after 27-10-2010

    Thanks



  • Same here with live messenger 2011 and ICQ 7.2.
    Running 2.0-RC3 (i386) built on Tue Jun 21 17:40:54 EDT 2011
    And doesn't mind what settings applied, after 3 or 5 minutes the messenger disconnects, ICQ doesn't.



  • Hi yea I just upgraded my pfsense upto 2.0-RC3 i386 and reinstalled inspector too see if it helped but it seems the same.



  • Maybe a proxy problem?
    I have HAVP parent for Squid. Squid is running as transparent proxy. Snort is installed without any chat filter rule.
    Imspector was the last package installed.


  • Rebel Alliance Developer Netgate

    IMspector is getting updated, but the developer working on the updated package is away at the moment. There is an updated package on amd64 (imspector-wip) but it's a work-in-progress.



  • As jim-p notes, there is an AMD64 package of IMspector 0.9 for 2.0 in the repos currently.  I'll get an i386 build out today if at all possible (I think it just needs the master repo package file updated).  Summary of my testing:

    | protocol | logs | notice of logging | content filtering | notes |
    | jabber | Yes | Yes | Yes | |
    | jabber-ssl/gtalk | Yes | Yes | Yes | Apple iOS Push notifications break due to man-in-the-middle cert |
    | Yahoo IM | Yes | No | Maybe | Yahoo appears to disconnect the client when IMspector changes/injects content |
    | MSN | Untested | Untested | Untested | No MSN account to test with |
    | Gadu Gadu | Untested | Untested | Untested | No Gadu-Gadu account to test with |
    | IRC | Yes | No | Yes | IMspector appears to be able to change/filter content, but not to inject it |

    –Bill



  • How many users look forward to this update, but just installed the mute button to save the setting, another question how can I help improve this package



  • I'm sorry, I don't understand what you are trying to say.  There is now an i386 package available for 2.0.  Please test, if all looks good, I'd like to replace the 0.8 package with this.  Thanks

    –Bill



  • @billm:

    I'm sorry, I don't understand what you are trying to say.  There is now an i386 package available for 2.0.  Please test, if all looks good, I'd like to replace the 0.8 package with this.  Thanks

    –Bill

    I think he was trying to say is there is no save button. I installed it last night and noticed I there was no save button. I will be able to confirm MSN once its up and running.



  • Apologies billm, but it's true, the button does not appear to save

    Is there any way to help you?



  • Yeah the save-button is definetly missing, but it also doesnt log to file (atleast not msn). Dont have time to test other protocols just now,but i would guess its the same for others. In debug mode it doesnt catch it all so the problem lies in saving it to file. Configuration ok so its not that. Also tried deleting the previous /var/imspector and letting the package generate it but no dice.

    Im on 2.0 i386



  • Hmm, I'll recheck that when I get home, but I absolutely had a save button on my test system! :-/  Wonder if I managed to break the xml when I pushed it.

    –Bill



  • Scroll to the bottom of the page - there's a 'Change' button there (at least for me).  I haven't had the time to determine if this can be moved or renamed, but it's what I used for all my testing.  If you didn't save the settings via the package screen, there will be no logging because pfSense won't pass traffic to IMSpector (I'm assuming this was launched manually, from the command line).

    –Bill



  • Seems to be a package missing for IMSpector-WIP:

    Downloading http://files.pfsense.org/packages/8/All/mysql-client-5.5.14.tbz …  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-release/All/mysql-client-5.5.14.tbz.
    of imspector-0.9 failed!





  • i opened a ticket on it http://redmine.pfsense.org/issues/1729



  • @samba:

    Hi could some one advise me on how too upgrade imspector to the latest snapshot. The current package seems not too be logging  live messenger 2010 but it is logging the older versions fine. This is apparently corrected in a snapshot after 27-10-2010
    Thanks

    I installed IMspector 0.10, and have the same problem.
    that can NOT log messages from Live messenger 2010 and when user log-in Live messenger2010 ,
    it will log-out automatically in few seconds.  ???



  • @a8556008:

    @samba:

    Hi could some one advise me on how too upgrade imspector to the latest snapshot. The current package seems not too be logging  live messenger 2010 but it is logging the older versions fine. This is apparently corrected in a snapshot after 27-10-2010
    Thanks

    I installed IMspector 0.10, and have the same problem.
    that can NOT log messages from Live messenger 2010 and when user log-in Live messenger2010 ,
    it will log-out automatically in few seconds.  ???

    I assume you mean 0.8-10 ?  The reason for the upgrade to 0.9 is to (hopefully) fix MSN and enable some of the other IMSpector features.  I don't intend to fix any issues in the 0.8 package, the new 0.9 package will replace it as soon as I can confirm it's not outright broken/breaking anything.

    Working on the MySQL issue now - looks like the package build system picked up a new version of the MySQL package, but that didn't get pushed up to the distribution server.  I think we intend to stay with the 5.1 client, so we'll need to rebuild the IMSpector package.  Thanks

    –Bill



  • @billm:

    Working on the MySQL issue now - looks like the package build system picked up a new version of the MySQL package, but that didn't get pushed up to the distribution server.  I think we intend to stay with the 5.1 client, so we'll need to rebuild the IMSpector package.  Thanks

    Thanks Bill!

    Stephen



  • This is the menu that I have been previously mentioned, does not bring the button to save  ???



  • Rebel Alliance Developer Netgate

    Look at the very top or very bottom of the page - do you have a PHP error shown there? How about in /tmp/php_errors.txt ?

    I suspect there is a connection between your empty certificates box and the missing page content.



  • Check the option and nothing, the file is clean php_errors.txt Tested with firefox and ie 9


  • Rebel Alliance Developer Netgate

    Should be fixed now, reinstall.

    The package was pulling the imspector.inc file from imspector/imspector.inc instead of imspector-wip/imspector.inc



  • Thank You Jimp and Billm, This recording the conversations of the new msn, very good ;D ;D ;D ;D



  • Woot. Nice news. Reinstall package on the way. Thanks.



  • Can anyone confirm that this works for MSN 2011 (Build 15.4.3508.119)?

    Takes a while for MSN to connect.. And about 5 mins for a txt msg to appear on the other side with no logging…

    I did remove the old package before upgrading.. Still testing but would like to know if this is working for other users.



  • Are recording normal conversations here, I think the problem that remains is to disconnect a few times and also noticed a certain slowness in the reconnection



  • @rafael.cardoso:

    Are recording normal conversations here, I think the problem that remains is to disconnect a few times and also noticed a certain slowness in the reconnection

    Its recording conversations for you I take it.

    Your still seeing disconnects and slow reconnect times?



  • I installed this package on my freshly installed pfSense 2.0-rc3 - but I'm not getting any logging at all. Is there anything I have to do in addition to edit the configuration on the imspector config page to make this work?

    Thanks :)

    Edit: Disregard this. It suddenly started working out of the blue. I have no explanation to provide, because I didn't do anything - it just suddenly worked. :P



  • I'm on the last 2.0-rc3 from august version i386 and I can't get imspector to work with msn. it wont show contact list on any msn client. gtalk works flawless but msn simply doesn't work at all. I'm using the squid antivirus as well, not sure if its related anyway…

    EDIT: Well it seems that somehow it doesn't work on adium (mac), trillian (windows) and other few 3rd party clients. With msn from microsoft it works great.

    @Caledorn:

    I installed this package on my freshly installed pfSense 2.0-rc3 - but I'm not getting any logging at all. Is there anything I have to do in addition to edit the configuration on the imspector config page to make this work?

    Thanks :)

    Edit: Disregard this. It suddenly started working out of the blue. I have no explanation to provide, because I didn't do anything - it just suddenly worked. :P



  • Hi, I have installed latest version of Imspector (i.e: 0.9-4). It is logging yahoo and msn chats perfectly. I have configured SSL certificate and SSL CA certificate both. But I can't see any Gtalk chats.

    When I checked with system log I found below entries.

    kernel: pid 53873 (imspector), uid 0: exited on signal 11 (core dumped)
      imspector: SSL get peer certificate error: error:00000000:lib(0):func(0):reason(0)
      imspector: SSL get peer certificate error: error:00000000:lib(0):func(0):reason(0)

    Are there anybody facing the same problem. Please somebody help me to resolve this issue.
    Thanks in advance



  • @rambabu_mail:

    Hi, I have installed latest version of Imspector (i.e: 0.9-4). It is logging yahoo and msn chats perfectly. I have configured SSL certificate and SSL CA certificate both. But I can't see any Gtalk chats.

    When I checked with system log I found below entries.

    kernel: pid 53873 (imspector), uid 0: exited on signal 11 (core dumped)
       imspector: SSL get peer certificate error: error:00000000:lib(0):func(0):reason(0)
       imspector: SSL get peer certificate error: error:00000000:lib(0):func(0):reason(0)

    Are there anybody facing the same problem. Please somebody help me to resolve this issue.
    Thanks in advance

    I haven't heard of anyone else with this issue.  From what I can see in the code, this error would happen if the upstream server didn't present a certificate.

    –Bill



  • Thank you very much for your reply bill,
    Can you please explain how to configure it properly. I can see yahoo and msn chats but not gtalk. I have created the certificate through Cert Manager gui as an internal certificate and provided the same in Imspector configuration. Is this correct. Are there any steps required. Pls help.



  • @rambabu_mail:

    Thank you very much for your reply bill,
    Can you please explain how to configure it properly. I can see yahoo and msn chats but not gtalk. I have created the certificate through Cert Manager gui as an internal certificate and provided the same in Imspector configuration. Is this correct. Are there any steps required. Pls help.

    You configured the Certificate Authority and the system cert?  That's all you should need.  Again the error implies that the Google server didn't present a cert (which is rather odd).  Maybe something else is intercepting your chats?

    –Bill

    --Bill


Log in to reply