Pfsense 1.2.3 under vmware server not showing 2 processsors?



  • In my quest to convert my physical box to a vm, I am now on vmware server since it runs as a service.

    I've got everything running, but my cpu load when I am doing large downloads is worrying me a bit.  My internet service is getting updated to 50mb from 8, so at this rate the pfsense box will be pegged at 100% load.
      So I checked and found that pfsense (1.2.3) seems not not be finding 2 processors like I configured in vmware.  In vmware I set the processors to 2.  I also confirmed that I am running the smp kernel in my install.

    Top shows only thread 1 on all items.  On my phsical box, it was spread throughout.
    I also tried dmesg from a previous thread post to confirm..

    $ dmesg | grep cpu
    cpu0: <acpi cpu="">on acpi0
    acpi_throttle0: <acpi cpu="" throttling="">on cpu0
    cpu0: <acpi cpu="">on acpi0
    acpi_throttle0: <acpi cpu="" throttling="">on cpu0

    Not sure what is going on..

    Anyone have suggestions on what I could try?</acpi></acpi></acpi></acpi>


  • Rebel Alliance Developer Netgate

    Make sure that you have installed the SMP kernel:
    http://doc.pfsense.org/index.php/Switching_Kernels



  • I did.  It was my first thing I checked.  I did a check as per a previous post and it showed I was on smp kernel.
    Could be related to my hardware (e-350)?
      2.0 is no issues, so I might as well try sticking to that plan instead.  Now if I can just get openvpn working in 2.0 like it worked in 1.2.3….......


  • Rebel Alliance Developer Netgate

    2.0 is definitely the way to go. OpenVPN has done nothing but work better for me on 2.0 than it ever did on 1.2.3 so it shouldn't be too hard to move forward.



  • Thanks for the info.  Even though it showed the kernel was smp, it did not show 2 processors.  I ran the commands anyways to switch it, and on the next reboot it showed smp again, but this time both processors were shown.  So 1.2.3 worked in vm.
      As I now have a good vm setup, I eventually got 2.0 working and settled on 2.0.  Seems to work better, and it is the future.
    Part of the vm idea to me is also the ease of use of it.  take snapshot, then try upgrades.  If all dies, revert to a saved image.  My windows boxes has always been this way, but switching the router over was a bit of a conceptual change for me.    Physical boxes only good for NAS setups/vm boxes for me from now on.

    Thanks again for the tips.  It's appreciated when the developers have time to help us out!


Log in to reply