Captive Portal Vouchers



  • Hi everyone,
        I did test the pfsense 2.0 rc3 with Captive Portal Vouchers, and I found some problem as below:-
    1. When I press log out button from windows log-out page. The time of that voucher still count down until expires, so when I would like to continue internet again I must use a new voucher to log-in. I'm not sure this is voucher's feature or bug.
    2. When I would like to stop using Captive Portal Vouchers, I dis-select option "Enable Vouchers" button and scroll down then click save. But when i click another Tabs and back to tab Vouchers, the "Enable Vouchers" still selected. So I cannot go back to use Captive Portal User instead of Captive Portal Vouchers. I may not know how to disable "Captive Portal Vouchers". Let me know please.



  • @ninnin:

    Hi everyone,
        I did test the pfsense 2.0 rc3 with Captive Portal Vouchers, and I found some problem as below:-
    1. When I press log out button from windows log-out page. The time of that voucher still count down until expires, so when I would like to continue internet again I must use a new voucher to log-in. I'm not sure this is voucher's feature or bug.

    Feature: the voucher time is an elapsed time not a connect time. If the voucher timeis 300 minutes then the voucher expires 300 minutes after first use, regardless of how long the voucher user is connected.



  • Thank you very much for your help.  :D  :D  :D  your answer made me clear for question 1. Could you or anybody please recommend me how to disable Captive Portal Vouchers and go back to use Captive Portal User. Thank you again.



  • @ninnin:

    Thank you very much for your help.  :D  :D  :D   your answer made me clear for question 1. Could you or anybody please recommend me how to disable Captive Portal Vouchers and go back to use Captive Portal User. Thank you again.

    Suggestion (I haven't tried this so can't vouch for it working; I would have done what you did): cancel existing vouchers by changing a voucher parameter. See the text at the bottom of Services -> Captive Portal, Vouchers tab.

    If you really want to have the Enable Vouchers tick go away you could try disabling vouchers, disabling captive portal, enabling captive portal.

    I had the impression that vouchers were an alternative to login so if you cancel existing vouchers and don't issue any new ones you have effectively disabled vouchers.



  • Your recommend is the way that I tried before, and it is not successful. I tried deleted all vouchers, disable vouchers, disable captive portal, restart the pfsense and enbale captive portal. But when I go to internet explorer the voucher log in page still appear, and when I go to check at the tab vouchers the "Enable Vouchers" still enable.

    But if it is not the way to disable, I'll set it back to default factory and re-setup it. I'll try to enable and disable the feature "Vouchers" again, because I would like to know this is a bug on 2.0rc3 or not!! I ever read other posted about he/she can enable and disable this feature as well on 2.0rc1. By the way, thank you very much for all of your recommend. I'll post the result again after test.  :)  :)  :)



  • @ninnin:

    Your recommend is the way that I tried before, and it is not successful.

    I took your request "I would like to stop using Captive Portal Vouchers" to mean you would like to prevent using vouchers to authenticate to the captive portal. My suggestion was intended to prevent authentication to the captive portal. My suggestion was not offered as a suggestion for a way to get the captive portal to say vouchers were disabled though I can see it could have been taken that way.

    Would you mind clarifying what you meant by "not successful": did you mean that you could still authenticate to the captive portal after changing a voucher parameter and supplying a voucher code generated before the change, or did you mean the captive portal still said vouchers were enabled after you changed a voucher parameter or did you mean the captive portal home page was still prompting for a voucher code?

    The captive portal login page is entirely under your control. If you don't want that login page to prompt for a voucher then YOU have to change it. This is a feature, not a bug!

    If the captive portal still allows use by someone supplying a voucher code generated before voucher parameters were changed (and saved) then that is a bug.

    If the web GUI doesn't say Vouchers have been disabled after the appropriate check box is "unticked" and saved then I think there is a bug unless some explanation is provided.



  • Further to my previous reply: I'm using the "official" RC3 build: 2.0-RC3 (i386)
    built on Tue Jun 21 17:40:54 EDT 2011
    and when I clear the Enable vouchers box and click save the next page that comes up shows Enable vouchers clear.

    Do you get different results if you use a different browser (not IE)? Another reader recently reported that IE didn't show the blue disc to upload vouchers but Mozilla Firefox did.



  • hi wallabybob,
    Sorry if my english language made you confuse, cause I'm not good in english langauge, and thank you in your trying to understand my english language.

    For my word "Your recommend is the way that I tried before, and it is not successful.", I mean all of you suggestion as below :-
    "Suggestion: cancel existing vouchers by changing a voucher parameter. See the text at the bottom of Services -> Captive Portal, Vouchers tab.
    If you really want to have the Enable Vouchers tick go away you could try disabling vouchers, disabling captive portal, enabling captive portal."

    It was the thing that I did by myself before come to post here, like this word "I tried deleted all vouchers, disable vouchers, disable captive portal, restart the pfsense and enbale captive portal.", and it is not successful, I mean I ever try to change it and it's not successful.

    For your doubt: "I took your request "I would like to stop using Captive Portal Vouchers" to mean you would like to prevent using vouchers to authenticate to the captive portal." No, I'm not mean that. My problem is when I enable Captive Portal Vouchers and try this feature, after I knew how it works, then I would go back to Captive Portal User Authenticate but I cannot change it back. I try many times to unticked and save to disable "Enable Vouchers", everything seem like o.k., but when I go to another tabs and go back to "Vouchers" tab, the "Enable Vouchers" always "ticked". That's why I come to post my topic because I don't know my question is the pfsense feature or bug, now I knew that my question 1 is feature, but question 2 still not sure.

    Now, I just restore to default factory and I'll test it again. I'll post result later.

    Thank you very much.  :)



  • While captive portal is enabled, I can untick enable vouchers and save and the the next page shows Enable vouchers unticked. I then click on the Captive Portal tab and then the vouchers tab and Enable Vouchers is still unticked.

    I'm curious what is different about your system that we get different behaviour.
    What build are you using (as reported by the Dashboard on the home page of your pfSense box)? Have you ever generated any vouchers?

    Is the only outstanding issue that you can't get the web GUI to say vouchers are disabled?



  • After restore to default and re-configuration, the problem of Captive Portal Vouchers as previous posted still exist. My pfsense release is 2.0RC3 as attached file.

    If my problem cannot solve, don't be serious. because it may problem only my system, may wrong configure, or something wrong. and I will re-set up again without enable Vouchers feature.  :D

    By the way, thank you very much for your kind, and I respect you that you take your time to reply answer.
    Thank you very much.




  • I just put a fix on this.
    Please test later snapshots.



  • @ermal:

    I just put a fix on this.
    Please test later snapshots.

    Thank you very much, I'll wait for next snapshots and test it again.  ^^


Locked