Cant get pfsense work as an accesspoint



  • System: pfSense 2.0 RC3

    ISP ->pfSense –->Switch
                        ---> Wifi??????
    Ale0 -> WAN
    Re0 -> LAN DHCP 192.168.0.1 /24
    Opt1 -> D-Link DWA-547 Wireless card

    LAN is working fine, DHCP works and internet connection also works. The Wireless work if I had it as an own DHCP, 192.168.1.1 but then the computers on the LAN cant talk to the wireless computers, both are in the same subnet, 255.255.255.0.

    My question, how do I bridge so all settings for LAN automatically will be used by the wireless card? And all computers can talk to each other, use the same DHCP?

    I have take a look at some other threds here but some dont work and some of them I dont understand. Sorry for my english.



  • Not sure what you did wrong but they should be on different network and still communicate since those are local interfaces on the router, check Diagnostic>Routes.

    You can bridge the two interface under Interface(assign) look for the bridge tab.



  • You can have them as separate networks but still be able to talk to each other without the need for bridging, would allow you to have it so that WiFi users need to authenticate before access is given (Captive Portal) if all you want is to have the WiFi and LAN Networks be on the same broadcast domain then bridging would be the route to go. All computers can talk to each other and would use same DHCP range. What do you mean by same settings?

    To set up bridging you need to go to Interfaces->OPT1 and then under IP Configuration theres an option to bridge, select Re0. You will need to setup firewall rules to allow WiFi clients to get a DHCP address.

    Go to Firewall -> Rules -> OPT1 Click the Plus sign. Under protocol select any. That should be it.



  • Thanks for the help! I finally bridge the interfaces and then add a rule in the fire wall and then it worked:)
    But now I got another problem, after a few days the wireless was down, when i reboot the system it worked again. What could that be? The log says "Log/System: kernel: ath0: stuck beacon; resetting (bmiss count 4)"



  • I also have an ath wireless NIC on my pfSense. My Linux laptop reports the wireless link down from time to time and it recovers if I disable/enable wireless on the netbook. Windows laptops used by other family members don't seem to have this problem. I suspect the Linux driver, only because one form of WPA2 crypto stopped working when I did a Linux upgrade.

    I also see the "bmiss" message from time to time. It doesn't seem to be anything to worry about (once in the last 21 hours).



  • I see it from time to time, read somewhere on the forum where jimp stated what it was but cant remember. As long as it seems to be working fine otherwise I would say you can ignore it, I do.



  • Now it seems to work just fine and i ignore the bmiss shit ;D Thanks for the help



  • It doesent work, after 4 days the wireless just dont work, after a rebot it works again. any suggestions?



  • I had the same problem with a EMP-8602+S High Power 802.11a/b/g miniPCI atheros based Radio Card on an ALIX system. I eventually sent it back to the manufacture and called it defective, after testing it themselves, they agreed. might want to consider trying another radio.



  • After another two days the whole system died. I returned the wireless adapter and now have a standard router as AP. my patience ran out, it might have gone to get it but so much trouble, it should not have to be. Google Translate <3 Thanks everybody


Log in to reply