Redirecionamento de acesso



  • Pessoal, Boa tarde!
    sou novo aqui no forum por isso ja peço desculpas se violei alguma norma ou regra daqui.

    vou ao problema que tenho:
    tenho o pfsense instalado e funcionando aqui na empresa.
    tenho um servidor web (iis) que esta rodando a nossa aplicacao (ip do servidor IIS - 192.168.0.1)
    temos ip fixo.
    o link de internet fixo esta na porta WAN do pfsense e o que sai para a rede interna é a porta LAN.
    quem acessa de fora da nossa rede a aplicacao, pelo ip fixo, consegue o acesso tranquilamente.
    porem, aqui internamente, nao conseguimos isso.
    por exemplo: se estou na minha casa e tento acessar: 200.10.1.189/aplicacao (ip ficticio para a WAN), consegui acessar perfeitamente.
    agora quando estou dentro da rede, com ip 192.168.0.x, e tento acessar 200.10.1.189/aplicacao, aparece como pagina nao encontrada.
    como iremos disponibilizar este serviço via web para o publico, precisamos "liberar" internamente tb.
    ja pesquisei e tentei algumas coisas mas nao consegui fazer funcionar.

    sei que parece estranho, pois o acesso terá que sair da rede e voltar…mas nao sei o que fazer mais.
    se puderem me auxiliar eu agradeço.
    se precisarem de alguma informacao a mais me avisem.



  • Correto seria você ter um Servidor de DNS . Mais se você colocar o IP interno 192.168.0.1 ele não entra?



  • sim…se eu digitar no browser 192.168.0.1/aplicacao funciona perfeitamente...mas eu preciso que, na rede interna, se digite o ip externo/aplicacao (no exemplo que eu falei 200.10.1.189/aplicacao )

    ja começo a pensar que é alguma coisa com o modem da gvt...



  • Não um problema da GVT. Bom ainda não entendi sua ideia mais caso seja necessário utilizar o IP de dentro da rede Interna faça uma regra de NAT . Tudo que for encaminhado pela LAN com destino ao IP QUENTE seja desviado para o 192.168.0.1.



  • Felipe!
    ja fiz isso…

    segue um print da tela...
    o problema é que temos o nosso site, hospedado fora daqui..
    no site, disponibilizamos serviços onlines...estes estao rodando aqui no nosso servidor.
    no site, tem um link para o ip_externo/aplicacao.
    da rua para ca funciona...de dentro nao..
    precisamos disso para atender os telefones e para trabalhar via web...
    se colocarmos o ip interno (192.168.0.1/aplicacao) funciona parcialmente, pois algumas coisas acessam o ip externo.




  • Ali você fez para conexões entrantes.
    O Nat que sugeri para LAN devera ser adicionado e feito assim

    LAN  TCP    LAN    ADDRESS    *    200.10.1.189    80    192.168.0.1    80



  • Fiz isso ai e nada..inclusive perdi o acesso a interface web do pfsense, vou restaurar o backup e tentar novamente

    tenho ip fixo, que sai do modem da gvt. neste modem, sai para o pfsense um ip da faixa 10.1.1.100.
    no pfsense, a WAN é 10.1.1.100 e a lan é 192.168.0.100.

    ja nao sei mais o que pode ser…



  • Qual e nossa ideia então com esse NAT e tentar desviar sem que ele sai para fora da lan.
    tente então
    LAN  TCP    *    *    200.10.1.189    80    192.168.0.1    80



  • Bom dia!
    acabo de criar, exatamente assim e continua a mesma coisa..
    se eu uso o ip externo diretamente no browser ele remete para a tela do router da gvt…se eu coloco o ip_externo/apliacacao..da pagina nao pode ser exibida...

    ta muito estranho isso...hehehe



  • :o aparece a tela do roteador ?
    estranho porque ele não deveria passar do firewall

    LAN  TCP    ! 192.168.0.1    *    200.10.1.189    80    192.168.0.1    80

    Tenta fazer com o not(!)

    Tambem use o capture packet

    para acompanhar como esta sendo realizado esse encaminhamento



  • LAN  TCP  ! 192.168.0.1  *  IP externo 80 (HTTP)  192.168.0.1  80 (HTTP)

    coloquei isso e nada…continua a mesma coisa...



  • Tente assim
    LAN  TCP  ! 192.168.0.1  *  * 80 (HTTP)  192.168.0.1  80 (HTTP)

    Caso não funcione poste o resultado do packet capture pra ver o que ocorre.



  • Cara…tentei isso ai...
    com isso liberou o acesso...porem, perdeu a navegacao a todos os outros sites..
    resumo, restaurei o firewall e ainda ta na mesma...



  • sim sim isso era fato que iria acontecer
    porque qualquer acesso para site via HTTP vai ser desviado para ele
    coloque Wan Address me poste o resultado da captura pra ver por onde ele vai



  • LAN  TCP  ! Wan adress  *  * 80 (HTTP)  192.168.0.1  80 (HTTP)
    seria isso que tu falou para colocar?



  • Tire seu PFSense da porta 80 jogue para 443 assim você pode realizar os testes

    LAN  TCP    ! 192.168.0.1    *    Wan Address  80    192.168.0.1    80

    Ainda não entendi porque ele tem que ser acessado pelo IP Quente dentro da LAN



  • Procure pelo campo Disable NAT Reflection for port forwards, desmarque esse item e conseguirás o acesso interno ao ip externo que procuras… na versão 2 está em advanced



  • Bem lembrado Rafael  ;)
    Tem realizar os teste com o NAT Reflection desligado



  • Bom dia pessoal!
    desmarquei a opcao Disable NAT Reflection for port forwards e confgurei conforme o felipe falou e continua tudo igual
    LAN  TCP  ! 192.168.0.1  *  WAN address  80 (HTTP)  192.168.0.1  80 (HTTP)

    parece estranho mas precisamos disso pelo fato de esta aplicacao funcionar tanto externamente (que esta funcionando) quanto internamente. se eu colocar o ip interno da aplicacao ela da varias bugs..pois no fonte dela esta configurado para o ip externo.



  • retire essas regras da lan, como está a questão do seu nat? automatico ?

    Detalhe -> Disables the automatic creation of additional NAT redirect rules for access to port forwards on your external IP addresses from within your internal networks. Note: Reflection for port forward entries is skipped for ranges larger than 500 ports.

    Deveria funcionar apenas desmarcando, tente setar o nat novamente e/ou resete o firewall, mas não esqueça de remover as regras da lan, não são necessárias.



  • na parte advanced do NAT, onde é para desmarcar  o refletion esta tudo desmarcado:

    Disables the automatic creation of additional NAT redirect rules for access to port forwards on your external IP addresses from within your internal networks. Note: Reflection for port forward entries is skipped for ranges larger than 500 ports.

    Disables the automatic creation of additional NAT 1:1 mappings for access to 1:1 mappings of your external IP addresses from within your internal networks. Note: Reflection for 1:1 NAT might not fully work in certain complex routing scenarios.

    Automatically create outbound NAT rules which assist inbound NAT rules that direct traffic back out to the same subnet it originated from.
    Currently only applies to 1:1 NAT rules. Required for full functionality of NAT Reflection for 1:1 NAT.

    estas 4 opcoes estao desmarcadas.

    nas configuracoes de NAT nao tenho nada mais sobre isso…tenho duas para acesso remoto aos servidores e uma para a VPN..so isso


Log in to reply