[SOLVED] ath0 problems (Atheros 5212 chipset no carrier)



  • Hello,

    I've assembled a small pfsense box for my home, wanting to schedule wifi for the kids. But i can't get wifi to work.
    It seems that my chipset (atheros 5212 from a DLink DWL-520G/FR card) won't just work fine with FreeBSD. Pfsense interface status says "no carrier".
    On the rear of my box, the power and activity leds both blink.

    Shall i change my wireless card or try to figure out what happens ?

    Here's my additionnal info:

    $ dmesg | grep ath

    ath0: <atheros 5212="">mem 0xfdfe0000-0xfdfeffff irq 17 at device 8.0 on pci0
    ath0: [ITHREAD]
    ath0: AR2413 mac 7.9 RF2413 phy 4.5</atheros> 
    

    $ athstats

    
    athstats: ath0: Invalid argument
    athstats: ath0: Invalid argument
    6412     data frames received
    355      data frames transmit
    136      mib overflow interrupts
    1M       current transmit rate
    2485     rx failed 'cuz of bad CRC
    53       rx failed 'cuz of PHY err
        53       CCK restart
    -0/+0    TDMA slot adjust (usecs, smoothed)
    9        avg recv rssi
    -96      rx noise floor
    355      tx frames through raw api
    Antenna profile:
    [1] tx      354 rx     6412
    
    

    $ ifconfig ath0

    
    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 34:08:04:xx:xx:xx
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    re0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=389b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_ucast  ="" ,wol_mcast,wol_magic="">ether 00:30:18:xx:xx:xx
            inet6 fe80::230:18ff:xxxx:xxxx%re0 prefixlen 64 scopeid 0x2
            inet 192.168.1.13 netmask 0xffffff00 broadcast 192.168.1.255
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    re1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=389b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_ucast  ="" ,wol_mcast,wol_magic="">ether 00:30:18:xx:xx:xx
            inet 192.168.0.254 netmask 0xffffff00 broadcast 192.168.0.255
            inet6 fe80::230:18ff:xxxx:xxxx%re1 prefixlen 64 scopeid 0x3
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
            nd6 options=3 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
            syncpeer: 224.0.0.240 maxupd: 128
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    enc0: flags=0<> metric 0 mtu 1536
    ath0_wlan0: flags=8c43 <up,broadcast,running,oactive,simplex,multicast>metric 0                                                                                                                      mtu 1500
            ether 34:08:04:xx:xx:xx
            inet6 fe80::3608:4ff:xxxx:xxxx%ath0_wlan0 prefixlen 64 scopeid 0x8
            inet 192.168.10.254 netmask 0xffffff00 broadcast 192.168.10.255
            nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: no carrier
            ssid TestBadNet channel 10 (2457 MHz 11g)
            regdomain ETSI country FR indoor ecm authmode WPA1+WPA2/802.11i
            privacy ON deftxkey UNDEF txpower 30 bmiss 7 scanvalid 450 bgscan
            bgscanintvl 300 bgscanidle 250 roam:rssi 7 roam:rate 5 protmode OFF
            burst roaming MANUAL
    ath0_wlan1: flags=8c43 <up,broadcast,running,oactive,simplex,multicast>metric 0                                                                                                                      mtu 1500
            ether 34:08:04:xx:xx:xx
            inet6 fe80::3608:4ff:xxxx:xxxx%ath0_wlan1 prefixlen 64 scopeid 0x9
            nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: no carrier
            ssid test channel 10 (2457 MHz 11g)
            regdomain ETSI country FR indoor ecm authmode OPEN privacy OFF
            txpower 30 scanvalid 60 protmode OFF burst -apbridge dtimperiod 1 -dfs
            bintval 0</hostap></performnud,accept_rtadv></up,broadcast,running,oactive,simplex,multicast></performnud,accept_rtadv></up,broadcast,running,oactive,simplex,multicast></promisc></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_ucast></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_ucast></up,broadcast,running,simplex,multicast></hostap></up,broadcast,running,simplex,multicast> 
    

    I do find ath0 mtu 2290 value quite strange. But i'm not able to change this anyway (ifconfig ath0 mtu 1500 giving me an error).
    I'm a bit stuck here. Has anybody experienced ath0 trouble out there ? …and solved it ?



  • My ath interface seems similar to yours:```

    dmesg | grep ath

    ath0: <atheros 5212=""> mem 0xee000000-0xee00ffff irq 12 at device 8.0 on pci0
    ath0: [ITHREAD]
    ath0: AR2413 mac 7.9 RF2413 phy 4.5
    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)
    #</atheros>

    
    Any reason for the two "virtual" interfaces? How about dropping back to one configured as an AP?
    Here's what my interface looks like:```
    # ifconfig ath0 
    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
    	ether 00:19:e0:68:31:4b
    	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    # ifconfig ath0_wlan0
    ath0_wlan0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	ether 00:19:e0:68:31:4b
    	inet6 fe80::219:e0ff:fe68:314b%ath0_wlan0 prefixlen 64 scopeid 0xc 
    	nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    	ssid Rivendell channel 1 (2412 MHz 11g) bssid 00:19:e0:68:31:4b
    	regdomain ROW country AU indoor ecm authmode WPA2/802.11i
    	privacy MIXED deftxkey 2 AES-CCM 2:128-bit AES-CCM 3:128-bit
    	txpower 30 scanvalid 60 protmode OFF burst dtimperiod 1 -dfs
    #</hostap></performnud,accept_rtadv></up,broadcast,running,promisc,simplex,multicast></hostap></up,broadcast,running,simplex,multicast> 
    


  • Hello,

    Thanks for your answer.
    Actually i added another virtual wlan just for testing.

    I finally got everything working. I guess i just configured stuff i shouldn't have to in the first place.
    Now i got a wireless AP bridged with lan working great.

    Thanks :)


Log in to reply