Multi-WAN load balancing y multi-WAN failover



  • Saludos. Utilizo pfsense 2.0 RC3
    Necesito ambas cosas: load balancing y failover.

    Una vez configurado un sistema multi-WAN load balancing con dos gateways (prioridad Tier 1 en ambos casos)… ¿es necesario configurar un multi-WAN failover o bien cuando se utiliza load-balancing se ejecuta el failover por defecto? Es decir, se supone que pfsense sabrá cuándo una gateway está caída, con lo que la excluirá del grupo y quedándose con la restante.

    No sé si me explico...

    Gracias por todo


  • Rebel Alliance

    En pfSense 2.0 con crear el grupo para balanceo ( los 2 GW en Tier 1 ) es suficiente ( si cae una de las wan, pasa a funcionar como failover ).

    En la version 1.2.3 habia que crear los grupos para failover y balanceo.

    Saludos



  • Gracias por la respuesta y por la rapidez de la misma.


  • Rebel Alliance

    Para eso estamos en este foro, para compartir conocimiento / experiencias….

    Un "Tip" mas, ya que estamos, en caso de que tus WAN no sean simetricas, ejemplo WAN1-->10mb  WAN2-->5mb
    puedes "regular" el balanceo con el "Weight" ( esta en la opcion "Advanced" en System:Gateways ).

    Para el caso anterior, lo pondrias así: WAN1--> weight 2  y WAN2--> weight 1

    Saludos



  • Y hay algún howto de cómo crear en pfSense 2.0 el grupo para balanceo ( los 2 GW en Tier 1 ) ?
    No me aclaro mucho, vengo de la release 1.2.3 y es completamente distinto :(



  • System -> Routing -> Groups -> Añadir

    Group Name:Wan1BalanceWan2
    Gateway Priority:  Tier1 para los dos
    Trigger Level: Packet Loss or High latency
    Description:Load balance on WAN1 & WAN2

    Ahora nos vamos a Firewall -> Rules -> Nat
    Y creamos una regla nueva, deja todo como viene por defecto menos:
    Protocol: any
    Gateway:Wan1BalanceWan2

    Ahora solo nos queda añadir monitores a las puertas de enlace:
    System -> Routing
    Edita una puerta, en Alternative monitor IP pones la ip del servidor DNS de tu proveedor, con la puerta WAN2 haces lo mismo y listo



  • Muchas gracias nivedimca, lo he logrado. Es relativamente fácil!
    A parte de haber seguido tus pasos he mirado en esta web: http://www.bunkerhollow.com/blogs/matt/archive/2011/07/27/pfsense-2-0-multi-wan-failover-with-clear-wireless-internet.aspx
    Lo que no he logrado es hacerlo funcionar con proxy en la LAN .. hmmmm… any idea?



  • hola.

    Les explico mi problema a ver si me pueden ayudar, tengo un pfsense v1.2.3 en modo balanceador el cual me ha funcionado muy bien hasta ahora, tiene conectada wan0, wan1, wan2, wan3, wan4 y una lan, wan0 es un dedicado y las demas son adsl, no tengo squid, ni proxi, solo hago balanceo, doy acceso a internet y tengo alrededor de 100 clientes. Hay algunos clientes que usan para su correo pop3 autentificacion en el servidor de salida por el puerto 587 y presenta problemas para enviar ya que el error dice que mis ip publicas aparecen en spamhaus, decidi conectar un wan5 que tiene ip limpias (no aparecen en spamhaus), y crear una regla de firewall para que el trafico por el puerto 587 pasara unicamente por alli y asi solucionar el problema, una vez hecha la configuracion de la wan5 voy a crear la regla y me doy cuenta que al elejir en el gateway solo aparece hasta la wan4, en interface aparece la wan5 y con su ip, si la anexo al balanceador genera trafico, pero no aparece como gateway en el firewall, reinicie el pfsense, reestableci las conexiones, pero nada parece funcionar, pareciera que no admite una conexion mas. si me pueden ayudar.

    gracias de antemano.



  • Por lo que cuentas, parece un error… El problema es que la 1.2.3 está "cerrada" y aunque lo reportes no lo corregirán. La cuestión es si en la 2.0 ocurre lo mismo o no.

    A ver si alguien pudiera comprobarlo...

    Hay quien modifica el código PHP para solventar estas cosas. Otra solución es guardar la configuración, editar el archivo XML y volver a cargarlo. Esto permite "retocar" cosas que el configurador web no permite.

    Pero tiene la pega que, según como, al reconfigurar vía web se pierden los cambios. No siempre... A probar.



  • Hola a todos:

    Estoy teniendo problemas con pfsense rc3 y load balancer y failover.
    He realizado la configuracion tal y como comentais:
    System -> Routing -> Groups -> Añadir

    **Group Name:Wan1BalanceWan2
    Gateway Priority:  Tier1 para los dos
    Trigger Level: Packet Loss or High latency
    Description:Load balance on WAN1 & WAN2

    Ahora nos vamos a Firewall -> Rules -> Nat
    Y creamos una regla nueva, deja todo como viene por defecto menos:
    Protocol: any
    Gateway:Wan1BalanceWan2

    Ahora solo nos queda añadir monitores a las puertas de enlace:
    System -> Routing
    Edita una puerta, en Alternative monitor IP pones la ip del servidor DNS de tu proveedor, con la puerta WAN2 haces lo mismo y listo**
    Pero no consigo navegar desde la lan.
    En la reglas de LAN si cambio al gateway del grupo que he creado no navego, si pongo otro de los 3 gateways que tengo navego sin problemas pero como indico si pongo el gateway del grupo creado para load balancing o failover no consigo navegar.
    ¿alguna idea?
    Gracias por la colaboracion.
    Saludos.



  • Yo tengo el balanceo funcionando bien,, pero cuando activo el squid solo me navega con una WAN y no con la otra..

    Alguna sugerencia?



  • Hola:
    ¿pero tienes el balanceo configurado como he puesto?
    ¿puedes decirme tu version de pfsense exacta.

    Gracias!!

    Wjordi10.



  • Estoy con Pfsense 2.0 ..
    EL balanceo funciona bien junto con el failover,,,el problema es cuando activo el squid,, solo me navega por una wan…
    Atte.


  • Rebel Alliance

    En la seccion en ingles, ecuentras temas acerca de Squid y multi WAN

    http://forum.pfsense.org/index.php/topic,37083.0.html



  • Probando descubri q el squid me bloquea solo las conexiones para navegar del puerto 80,, pero por otros puertos si puedo navegar..

    Atte.



  • Según la página web recomendada (http://www.bunkerhollow.com/blogs/matt/archive/2011/07/27/pfsense-2-0-multi-wan-failover-with-clear-wireless-internet.aspx) ninguna de las gateways ha de ser configurada como por defecto. Los que lo habéis probado y os funciona, cómo lo tenéis.

    Gracias



  • El problema radica en el Squid,, por que solo navega por una WAN…



  • """Les explico mi problema a ver si me pueden ayudar, tengo un pfsense v1.2.3 en modo balanceador el cual me ha funcionado muy bien hasta ahora, tiene conectada wan0, wan1, wan2, wan3, wan4 y una lan, wan0 es un dedicado y las demas son adsl, no tengo squid, ni proxi, solo hago balanceo, doy acceso a internet y tengo alrededor de 100 clientes. Hay algunos clientes que usan para su correo pop3 autentificacion en el servidor de salida por el puerto 587 y presenta problemas para enviar ya que el error dice que mis ip publicas aparecen en spamhaus, decidi conectar un wan5 que tiene ip limpias (no aparecen en spamhaus), y crear una regla de firewall para que el trafico por el puerto 587 pasara unicamente por alli y asi solucionar el problema, una vez hecha la configuracion de la wan5 voy a crear la regla y me doy cuenta que al elejir en el gateway solo aparece hasta la wan4, en interface aparece la wan5 y con su ip, si la anexo al balanceador genera trafico, pero no aparece como gateway en el firewall, reinicie el pfsense, reestableci las conexiones, pero nada parece funcionar, pareciera que no admite una conexion mas. si me pueden ayudar"""

    gracias ballera por tu ayuda, probe eso y a pesar de motrar el cambio no funciono, y no funciono porque la wan5 tiene un ip estatica, si es estatica no la muestra como gateway, si es dinamica la muestra como gateway, ya hice la prueba, no se si es un error del programa o es asi por alguna razon.

    ahora bien, ya que dinamica me muestra la wan5 en rules probe asi, hice una regla pero sigo sin resultados positivos, como hago para que el trafico de correos salientes que usan servidores de autenificacion con contraseña (smtp puerto 587 TLS) salga unicamente por la wan5, esta wan5 esta fuera del balanceador y tengo una sola lan, ya no se que hacer.

    gracias de antemano


Log in to reply