Bogons file from july 1-st contained google netblock

  • last time this was updated, 30-36 days ago, it used to contain such netblocks:

    file updated from crontab @ july 1:

    -rw-r–r--  1 root  wheel  146 Jul  1 05:08 /etc/bogons <<<<<<<< google has spiders @

    and todays manual update produced again ok bogons file:

    -rw-r--r--  1 root  wheel  132 Jul 20 20:13 /etc/bogons

    does anyone have versions/backups of what has been served at ?
    did this data came originally from iana?
    this fluke blocked effectively (and quietly, one might add) google from spidering our websites for 20 days and all of them lost their nice pagerank and moved wayyy deep in google search too :)


  • It's pulled automatically from Cymru's bogon listing here.  Their change log shows no updates since February, and checking 10 boxes that last updated the same as everyone's on July 1, none of them have that in there. No record of that ever being on the server. No idea how you could have gotten that there short of leaving your firewall open with a weak password and someone screwing with you.

  • indeed… 4 other pfsense machines had bogons file from same day and no such network in it.
    no permanent long-lasting log to look for about webif/ssh accesses, just circular logs?

  • yeah not unless you're syslogging.

  • did not, fixed that now. changed passwords too everywhere, just in case. thanks man

    PS. if someone else looks for webif access logs combined with remote syslog (perhaps that guy:,22171.msg113966.html)

    server.errorlog-use-syslog  = "enable"
    accesslog.use-syslog        = "enable"
    …restart lighttpd
    plus log settings > remote logging etc

  • that's weird… good remedial actions, you may want to backup your config, check it for sanity, and wipe out and reinstall it if you don't really trust it and restore the validated config.

  • 37 days old install. but nevertheless, old config along with old password was indeed restored when this fw replaced old one. will go over the conf with finetooth comb.

Log in to reply