Concerns Running pfSense 2.0 RCx on Hyper-V



  • I know there are issues running pfSense on Hyper-V because BSD is not a supported OS on that platform, but with pfSense 1.2.3 we had a very usable solution provided that Legacy Network Adapters were used and the interfaces were "rebooted" (ifconfig <interface>down, ifconfig <interface>up, dhclient <interface>[if necessary]). If the necessary commands were placed in a .sh file in /use/local/etc/rc.d then things worked pretty much transparently.

    What I have done is some rudimentary testing using 2.0 RC1 and RC3 with the same set up as I successfully used with 1.2.3:

    • RC1: When pfSense is started there is long delay at "Configuring WAN interface". If configuration changes are made through the webConfigurator, then the interfaces need to be manually recycled - the script in rc.d doesn't seem to be effective as it was with 1.2.3. Alternatively things work if pfSense is rebooted following a configuration change.

    • RC3:  When pfSense is started there is long delay at "Configuring WAN interface" and at "Starting OpenNTP time client". Even though the startup reports that the script in rc.d has been run, there is no DHCP lease obtained by the WAN interface and there is no connection through the LAN interface until they are manually recycled. On a reboot the WAN interface does seem to obtain a lease, but there is still no connection through the LAN interface until both the WAN and LAN interfaces are recycled, though the dhclient de0 command is not required.

    With the 2.0 RCs things seem to have gone backwards a bit and I'm wondering if anyone else's experience matches mine or if I'm missing something?

    • Richard</interface></interface></interface>


  • Hi Richard,

    I am having the exact same issues as you with 1.2.3, RC1, and RC3.  I was able to get the startup script working though by giving the file execute permissions (chmod +x).  I don't know what changed from prior versions, but that seemed to do the trick.

    Here's the contents of the script:  /usr/local/etc/rc.d/startup.sh

    ifconfig de2 down
    ifconfig de2 up
    

    After creating/saving the file, I then ran:

    chmod +x /usr/local/etc/rc.d/startup.sh
    

    "de2" is my LAN, de0 and de1 are WANs in my setup (none use DHCP).  I haven't found it necessarily to reset the WANs at boot…  but you may have to?

    Hope that helps!  It would be nice to not have to worry about whether the NICs were going to work under hyper-v, but that's always been the case... :P  I think it's probably more to do with MS's lack of support for FreeBSD in Hyper-V than pfSense...

    Andy



  • Andy,

    Thanks very much for the detailed response. I've tried the chmod +x and it looks like it has worked. It still takes a while to boot pausing at "Configuring WAN interface" and at "Starting OpenNTP time client" but at least once it starts it works!

    Yes, I'm pretty sure that the underlying issue is that there is limited OS support in Hyper-V. I'm no expert in this but I think that MS is using a type of virtualization that works best when there is operating system support. I've not had problems with pfSense on ESXi or VirtualBox to name two competitors, but there are reasons beyond pfSense why Hyper-V makes best sense for me.

    Thanks again.

    Richard


Locked