I want to run two xbox 360 on one network?



  • I have one xbox working with basic nat/port forwarding.
    How can I open those ports to both xbox's?



  • usually by using aliases, but if you're using port forward it might not work at all



  • @frenchsquared:

    I have one xbox working with basic nat/port forwarding.
    How can I open those ports to both xbox's?

    You can only do that with multiple public IPs, you can't do that with a single public IP with any firewall as there's no way to determine which traffic goes to which Xbox if they require the same ports.



  • @cmb:

    @frenchsquared:

    I have one xbox working with basic nat/port forwarding.
    How can I open those ports to both xbox's?

    You can only do that with multiple public IPs, you can't do that with a single public IP with any firewall as there's no way to determine which traffic goes to which Xbox if they require the same ports.

    Ummm not true, before pfSense, I used Kerio, its called UPnP, but due to lack of understanding (myself included), it seems to be a dud in pfSense.

    See, UPnP if that port is already in use will use a different port, and take care of all the port mappings, etc, etc.

    I keep posting about the UPnP issues on the submit bug, but they keep rejecting it. Most likely to hard for them to solve!!! lol



  • No I'm rejecting it because it's a support request, not a bug report. If you want to dig into it and find the real cause, I welcome a real bug report with a patch to fix it attached. I don't care about online gaming, though would be glad to commit a fix. I'm not going to dedicate our limited resources to fixing your Xbox, we have much more important things to work on.

    If they can use different ports, uPNP should work, in that case it's probably an issue in miniupnpd with two Xboxes somehow.



  • There is no dud, or bug. uPNP works superb in pfsense.

    Under "Services" -> "UPnP & NAT-PMP Settings"
    Enable "Enable UPnP & NAT-PMP"
    Enable "Allow UPnP Port Mapping"
    Enable "Allow NAT-PMP Port Mapping"
    Interfaces (generally LAN) "LAN"
    Restart both xbox's.
    That should get you working.


    To secure it,
    Make both xbox's have either static DHCP reservations, or static IP's.
    Enable "By default deny access to UPnP & NAT-PMP?"
    For "User specified permissions 1" enter something like "allow 1024-65535 1ST-XBOX-IP-ADDRESS 1024-65535"
    For "User specified permissions 2" enter something like "allow 1024-65535 2ND-XBOX-IP-ADDRESS 1024-65535"

    I forgot to add, undo the current port forwarding that you have done for your xbox's.



  • Same as djroketboy stated but make sure the xboxes or ps3s are set to dhcp let pfsense assign the ips through static dhcp reservations. This will work like a charm, running 2 boxes at the same time from a single cable connection. ;D


Log in to reply