Imposible hacer funciona la red local básica



  • Hola!

    Estoy un poco desesperado por que no consigo hacer funcionar lo más básico en pfSense, el red LAN.

    Os cuento un poco como es mi red. El direccionamiento es 192.168.0.0/16. Las IPs que entran en juego aquí son:

    192.168.2.1/16 -> Router Draytek SDSL
    192.168.2.2/16 -> pfSense 2.0-RC3 <– el problematico
    192.168.3.2/16 -> Router ASDL estandard
    192.168.3.10/16 -> Equipo con Windows desde donde se configura todo

    El equipo tiene como gateway el router ADSL y funciona perfectamente. El equipo puede hacer ping a todo.

    Intento configurar el pfSense para que use el router ADSL como su salida a internet para los paquetes, chequeo de versiones, ntp, etc ... vamos, el default gateway. No hay nada mas configurado, ningún otro puerto ethernet.

    La configuración de la boca LAN es esta:

    La configuración del gateway:

    Con esto se supone que el pfSense ya debería tener conectividad, no ? Pues no. El estado del gateway:

    Está offline. Intento hacer ping desde el pfSense y puedo hacer pings a todo, MENOS AL ROUTER ADSL:



    Vamos, que por algún motivo el pfSense no puede "ver" el router ADSL, que es un Comtrend normal y corriente. El firewall de la LAN es el normal:

    Pero no puede ser problema de firewall, por que puedo hacer pings a otros hosts. Es solo al router ADSL el que no puedo. Pero desde otros equipos puedo hacer pings a router ADSL y funciona.

    He probado hasta a cambiar la IP del router ADSL a la 192.168.2.3/16 y TAMPOCO.

    Estoy un poco desesperado, no consigo dar con el problema.

    Alguien tiene una idea ?

    Gracias !!!





  • Gracias LEPM, pero son situaciones diferentes. En este caso mi pfSense no hace de router entre la ADSL y la LAN. Simplemente, quiero que el pfSense tenga internet através de la LAN.

    Básicamente, bastaría con poner el gateway por defecto con la IP del router ADSL que está en la propia LAN, pero por algún motivo el pfSense no ve el router, tenga la IP que tenga. Sin embargo, si que ve el resto de dispositivos en la red. Todo está dentro de la misma subred, así que no entiendo nada.

    Se me ocurre algún tipo de problemas en entre las tarjetas de red del pfSense (realtek) y el router Comtrend, pero es bastante raro.

    Curiosamente, hago ping desde la consola del router ADSL al pfSense y tampoco lo ve.

    Alguna idea mas ?

    Gracias!



  • Que ip tiene la Wan de pfsense?



  • Cuando dices: 192.168.2.1/16 -> Router Draytek SDSL y 192.168.3.2/16 -> Router ASDL estandard, estas ip pertenecen a los modem/router en si, o son las las ip configuradas en las interfaces de tu PfSense?

    Entonces tienes 2 wan? Que ips tienen esas interfaces?

    Recuerda que si wan esta en la misma subred de lan, ésto te genera un conflicto.

    Una cosa, para el tipo de configuración que quieres implementar, siendo LAN un gateway en sí mismo para los equipos conectados precisamente a la LAN, no es necesario que le asignes un gateway a éste (LAN), ya que las conexiones en LAN saldrán justamente por el gateway predeterminado que está configurado en interfaces WAN; prueba quitándole el gateway a LAN, (ponle none), fíjate en los otros datos que te dije al principio y comenta como te va.  ;)

    Saludos.



  • Como dice Skid el problema es que tus wan estan en el mismo segmento de red. (Problema de capa 8 ) Lo otro no se si tu red sea tan grande como para usar una mascara 16 me parece muy exagerado y un desperdicio de ip. debeias una mascara mas pequeña.
    Red 192.168.0.0 solo tienes una red muy grande 192.168.0.1 -192.168.255.254 con estamascara 255.255.0.0
    saludos


Locked