Version 1.2.3 in ESX 4 with only one NIC and VMs with public IP address



  • I'm going crazy with this. Sorry about my English. I'm trying to setup pfSense 1.2.3 in a ESX Server 4. There is only one NIC available.

    I have pfSense VM with 2 virtual NICs (WAN x.x.x.2, LAN x.x.x.3), and severals VMs (x.x.x.6, x.x.x.7, x.x.x.8). All virtual NICs have a public IP address with same gateway (x.x.x.1). I tried configuring LAN pfSense and VMs in a vSwitch with no physical adapters, but all VMs lost connection in that vSwitch (all ping lost, default gateway unreachable).

    If I create a new Port Group in same vSwitch with a VLAN ID 2, all VMs lost connection again.

    I search in this forum and I googled for different configuration for firewalls in ESX with one NIC, but no one talks about using public IP addresses in protected VMs.

    Anyone can help me with my issue? Thank you very much in advance.


  • Rebel Alliance Developer Netgate

    You can't have two interfaces in the same subnet.

    What it looks like you want to do is bridge LAN to WAN. In that case, LAN has no IP address. (Enter 'none' for the ip), and select WAN from the bridge drop-down.



  • I cannot enter "none" for IP address in LAN interface. It requires a valid IP address. I was trying with WAN bridge before I post first message. Do you believe there is any solution to my issue?


  • Rebel Alliance Developer Netgate

    When you bridge, only one interface gets an IP address in the same subnet.

    I had thought on 1.2.3 we had a little hack that let you put in "none" for the IP, haven't tried it in a while though. You can always put in an IP from another subnet, it doesn't matter, it shouldn't get used. So long as it's an IP in another subnet it should behave.


Locked