Some gaming and pfsense battle.net/starcraft



  • Hi there..

    I'm trying to play starcraft, I can, but limited only.

    With no settings set at all I get theese results:
                Bw  |  Wc3
    1:1      Yes  |  Yes 
    2:2      No    |  Yes
    Create  No    | No

    With nat settings 6112-6119 tcp/udp and 4000 tcp and only 6112 tcp/udp+ 4000 tcp = same results

    Bw  |  Wc3
    1:1      Yes  |  Yes 
    2:2      No    |  Yes
    Create  Yes    | No

    My 2:2 is very limited, VERY, some users work, yesterday I play´d a 1:1 clanwar game, and won 2:0 aswell though, but had 6 persons watching my game, and worked, I said to them, I think my router loves you guys, cuz only 5% of the people i meet can be in my game when player limit exceed 2 ^^

    Well..

    Now another issue aswell though, well.. its not an issue for me anymore :D

    Ventrilo 3874 tcp/udp, okey worked sometime ago, long time ago when i started using it.
    suddenly tcp failed.. hmm.. woot woot.. hadnt changed settings at all for 80 days, uptime 80 days on the pfsense. no changes at all.

    udp have been very polite to me through pfsense though :)

    Now I'm using teamspeak instead of ventrilo ts uses only udp, got more users for freebie, and is easy'r to manage, and appears to use less of my connection at higher codec quality <3

    Got any suggestions.

    UPnP is installed at my system.



  • as another thingy I wanna do :D

    i got now 5 network cards in my comp, 3-4 of them is going for my self study things by doing diffrent subnets and some advanced networking with servers etc, anyway..

    The thing I cant get to work is to do dual wan kinda the way i want at all :S

    I wanna do this cuz of lame starcraft b.net system :S

    2:2 on same connection doesnt work( same wan ip) but both can play starcraft online, but not together.

    So i wanna have 2 computers on same switch, same subnet.

    but all starcraft/b.net traffic goes on is splitted.

    i got permission to use 3 Ip's from my isp, and want xx.xxx.xx.68 to go to comp 1
    xx.xxx.xx.69 to go to comp2 so both can play in the same game.. possible ?



  • Try removing the nat settings and make sure upnp is enabled and configured, upnp should open up its own ports.  I don't know that starcraft supports upnp though, it is pretty old school these days.



  • hehe.. no kidding..

    Well.. it doesnt support upnp, and got same issue on other routers aswell.. thomson/alcatel

    Hmm…

    Seriously want it to work



  • hmm.. got my tcp natting to work properly now.. any application that can test UDP ports ?


Log in to reply