PFSense in VMWare Workstation won't get WAN IP



  • Hi everyone,

    I'm trying to migrate my PFSense 2.0 install from a dedicated laptop to a Virtual Machine running in VMWare Workstation 7.1.4. Originally I was going to use the USB NIC that I had on the laptop for the WAN connection, however it seems Workstation 7.1.4 has some USB problems that won't allow the device to run in 2.0 mode, and fails in low speed mode (same issue as this: http://communities.vmware.com/thread/310401). I decided to try using bridged connections to a PCI NIC instead, but am still having no luck. Here is what I have done:

    • Onboard NIC (eth0) is connected to internal HUB, host Fedora 15 box has an IP of 192.168.0.100

    • PCI NIC (eth1) is connected to external cable modem (pass-through settings) and has a static IP of 169.254.1.1 (This is to keep the host from pulling an IP from the Cable Modem)

    • The VMWare Virtual Network Editor is setup as follows: vmnet0:bridged:eth0, vmnet10:bridged:eth1

    • On the guest, em0 (Network Adapter) is set to "Bridged", with a guest static IP of 192.168.0.1

    • On the guest, em1 (Network Adapter 2) is set to "Custom:vmnet10" with DHCP running on the guest

    When booting, the virtual machine connects to the internal network fine using em0, but it never aquires an IP from em1. I've tried powering things down, back on, etc. No luck.
    Any ideas?

    Thanks,
    B.



  • So nobody has tried to use Virtual network adapters for PFSense?

    edit
    Figured it out. First, set the host adapter to manual IP of 172.16.0.1, Subnet of 255.255.255.0, gateway of 0.0.0.0. Use VMnet2, not 10 or higher. I'm not sure which of these changes made things work, but it does work.


Locked