Error using ClientExport: certificate can't be found (solved)



  • I'm running pfSense 2.0RC3 in VirtualBox (for testing, before putting it on real iron).
    When I go to VPN -> OpenVPN -> Client Export to download configuration, I get message
    "Could not locate certificate.
    Failed to export config files!"

    I have created an Internal CA, using that for OpenVPN Roadwarrior Server.
    I have created client certificates using this CA, both in user manager and under System -> Cert Manager -> Certificates.
    If I go to User Manager, or System -> Cert Manager -> Certificates, I can save both certificate and key-files.
    I checked these downloaded files they seem to be correct.
    Under Client Export I can see all my created users & certs.
    I've read all docs & how-to's about how to configure OpenVPN Roadwarrior, doing exactly as I should - but always same result.
    Is this a bug, or what am I missing?



  • Hi,

    you need two certs - one for your OpenVPN server and one for the client, both signed by the same CA.

    Then under Client Export Utility I just download "Configuration archiv" or "Windows Installer". There are no problems for me with this snapshot:
    2.0-RC3 (amd64)
    built on Mon Aug 8 18:38:15 EDT 2011

    Which snapshot are you using ?



  • I know I need 2 certificates, that's what I have.
    I'm using 2.0-RC3 (i386) built on Tue Jun 21 16:50:25 EDT2011



  • Not sure where the problem is.
    In the past I had sometimes problems with the browsercache. Perhaps try another browser to download the config file.

    When and where does this error occure ?
    Are you downloading the "Configuration Archiv" or the "Windows installer" ?

    Could you provide screenshots of your Certificates, your OpenVPN server config and the Export utility (when showing this error) ?

    Or you just try with an actual snapshot.



  • I upgraded to latest snapshot and recreated certificates, now it works fine!
    So just an already fixed bug then.
    Thanks for your help!


Locked