Back to the rc2 captive portal method



  • Hello.

    Recently I've updated from RC2 to RC3 and discover a change in the captive portal login method. In RC2 the captive portal (with built in voucher system) only ask for the voucher code but in RC3 it's needed to give a user name too.

    There is some way to skip the username request to only enter the voucher code, just as RC2 does?.

    Thanks in advance.



  • @Mandinga:

    Recently I've updated from RC2 to RC3

    Which RC3 build? I'm running 2.0-RC3 (i386)
    built on Wed Jul 20 01:31:15 EDT 2011
    and I can "login" to captive portal with either a username and password OR a voucher - no need to use both.



  • Sorry, I was unable to explain me correctly.

    I'm using the RC3 (i386) 20110621-1650.

    How can I select the login method via username and password or voucher?. What I need to configure to use one or another method?.



  • To use vouchers you need to have vouchers enabled (web GUI: Services -> Captive Portal enable captive portal and save, click on Vouchers tab, enable Vouchers and save.)

    To use login by username and password you need to have the appropriate username and password entered in the System -> User Manager page.

    The Captive Portal home page needs to allow entry of username and password (if you are using that method of authentication) or vouchers (if you are using vouchers for captive portal authentication).  Here is a captive portal home page I put together for a colleague:```

    more portal.html

    <center>

    Terramungamine Internet Cafe

    </center>

    <form method="post" action="$PORTAL_ACTION$">
    Please enter your authorisation information:

    Username: and
      Password:

    OR

    Voucher Code:

    Then click the Continue button below:

    </form>

    The Captive Portal home page needs to be uploaded to the pfSense box through the _Portal Page Contents_ field on the _Services_ -> _Captive Portal_ page.


  • This is exactly what I need. Thank you very much.



  • My RC3 portal also stopped working just after I upgraded from RC2, and I've been pulling out my hair (as well as my managers pulling my hair) trying to get it fixed.  Turns out I just needed to add the auth_voucher as a hidden input, even though I'm not using it, and it started working again.

    Thanks for the hints, I figured it was worth a try!


Locked