проброс портов на esxi



  • Доброго времени суток.
    Долго не могу решить проблему с пробросом портов на rdp.
    Читал на форуме подобные темы, ничего не дало.
    Поставил на сервер ESXI 4.1, сделал еще один свич, установил виртуалку windows xp.
    вобщем все как описано в этом топике : http://blog.romant.net/technology/configuring-nat-on-esx-and-esxi/.
    Интернет машинам раздает, пинги из виртуалок идут, а вот из вне ни телнет ни пинг на статический адрес pfsense не работают. Фаерволл на виртуалках отключил, в веб интерфейсе pfsense на вкладке system > advensed снял галку disable nat reflection, nat построил, . rdp на машинах включил.
    Пробросы нужны как на RDP так и на почтовый сервер freebsd в будущем.
    Скриншоты прилагаю.
    Спасибо за внимание.











  • делай Port Forward
    у меня всё работает esxi 4.1



  • @vagiff:

    делай Port Forward
    у меня всё работает esxi 4.1

    A можешь скинуть скриншоты настроек? support@univer.ua



  • топикстартеру :

    Хмм, у меня pf стоит на Vsphere 4.1 (Free) (уже 5-ка доступна :) ) уже хз сколько и все ок. У сервера пять физических сетевух. Для pf используются три - LAN, WAN (pppoe), OPT1. По одному switch-у на каждую реальную (!) сетевуху. Куча портмаппингов как для WAN-to-LAN, так и для OPT1-to-LAN, в том числе и по RDP. Pf настраивал как обычно, не смотря на то что он "виртуальный".

    ЧЯДНТ ?

    Сколько у вас ФИЗИЧЕСКИХ сетевых на сервере с гипервизором ?

    P.s. По ссылке на статью - она от July 11th, 2010 ?! Попробуйте сделать бэк-ап ВМ с pf, поставить гипервизор Vsphere 5.0 (Free), импортировать туда вашу ВМ с PF.

    У меня нет проблем с NAT на Vsphere 4.1, а статья ,указананная вами, видимо для старых версий гипервизора от Вмвари.

    P.s.s. И что это за правило для LAN на первом скрине ?! Там src-ом указан IP уж точно непринадлежащий LAN-сетям (212.109.ххх.ххх).



  • @werter:

    топикстартеру :

    Хмм, у меня pf стоит на Vsphere 4.1 (Free) (уже 5-ка доступна :) ) уже хз сколько и все ок. У сервера пять физических сетевух. Для pf используются три - LAN, WAN (pppoe), OPT1. По одному switch-у на каждую реальную (!) сетевуху. Куча портмаппингов как для WAN-to-LAN, так и для OPT1-to-LAN, в том числе и по RDP. Pf настраивал как обычно, не смотря на то что он "виртуальный".

    ЧЯДНТ ?

    Сколько у вас ФИЗИЧЕСКИХ сетевых на сервере с гипервизором ?

    P.s. По ссылке на статью - она от July 11th, 2010 ?! Попробуйте сделать бэк-ап ВМ с pf, поставить гипервизор Vsphere 5.0 (Free), импортировать туда вашу ВМ с PF.

    У меня нет проблем с NAT на Vsphere 4.1, а статья ,указананная вами, видимо для старых версий гипервизора от Вмвари.

    P.s.s. И что это за правило для LAN на первом скрине ?! Там src-ом указан IP уж точно непринадлежащий LAN-сетям (212.109.ххх.ххх).

    По поводу P.s.s я делал как описано в теме за 2008год ;D. http://forum.pfsense.org/index.php/topic,7932.0.html, там написано делать так *Вход по RDP организуется мапингом порта 3389 на ваш внутренний терминальный сервер
    Соотв на WAN должен быть разрешено
    [src: * ][src port: * ] [dest: WAN ip ][dest port: 3389 (или др)]
    На Lan
    [src WAN IP][src Port ][dest TermSRV IP][dest port 3389]

    Физическая сетевуха одна. После нескольких часов борьбы с pf оказалось следующее: я все настроил за 5 минут,но не проверил с разных мест. pf по rdp пускает отовсюду, только не из офиса из которого я пытался коннектится. В офисе стоит cisco и я так понял что pf не пропуcкает cisco. Пока буду пробовать обойти cisco. как всегда тупит топикстартер :-[. Но пока проблема осталась. Теперь нужно добиться того чтоб пускало в офис.


Log in to reply