Postfix - antispam and relay package



  • Hi, marcelloc! I think I found some minor bugs

    1. Auto whitelist doesn't work until I created manually «postscreen_spf_whitelist.cidr» file

    2. When I try to watch postfix configuration files «relay_recipients» I see blank page.




  • @Igor:

    1. When I try to watch postfix configuration files «relay_recipients» I see blank page.

    You can see this only, if you have  "Enable LDAP/URL fetch" ind the Recipients tab enabled.



  • Bismarck, "Enable LDAP/URL fetch" is already enabled, file "relay_recipients" contains 248 emails.



  • @Igor:

    Bismarck, "Enable LDAP/URL fetch" is already enabled, file "relay_recipients" contains 248 emails.

    Mine is just working fine with aprox 750 lines, maybe you could have a look in /usr/local/www/postfix_view_config.php around line 33

            		'recipients'=> POSTFIX_LOCALBASE . "/etc/postfix/relay_recipients",
    

    and check the paths etc. the code is pretty self explained.



  • Yeah, I found mistake.

    Line 33 in my postfix_view_config.php is right
    But line 99```

    
    Should be```
    *   [relay_recipients](#)
    

    Not "relay", but "recipients"  ;)





  • This way?

    https://github.com/marcelloc/Unofficial-pfSense-packages/commit/833483889f73243affe6ba71ce4465bf3f325dec

    Yes

    What can i say about

    1)  Auto whitelist doesn't work until I created manually «postscreen_spf_whitelist.cidr» file

    I'm delete «postscreen_spf_whitelist.cidr» file, and start test again.
    Domains in file "auto_whitelisted_domains" and CIDR in "auto_whitelisted_cidr" created automatically (previously has been the same), but recipients has not received emails (stasus "soft bounce") from this domains again.

    I swapped the lines "cidr:/usr/local/etc/postfix/auto_whitelisted_cidr" and "cidr:/usr/local/etc/postfix/postscreen_spf_whitelist.cidr" in my "main.cf" (without creating file "postscreen_spf_whitelist.cidr")

    postscreen_access_list = permit_mynetworks,
    			cidr:/usr/local/etc/postfix/cal_cidr,
    			cidr:/usr/local/etc/postfix/auto_whitelisted_cidr,
    			cidr:/usr/local/etc/postfix/postscreen_spf_whitelist.cidr
    
    

    And now all emails were delivered to recipients, auto whitelisting works fine.



  • Hi Marcelloc,

    it appears that the FreeBSD repo has upgraded the MailScanner pkg to version 5.0.3 ( from 4.85.2 ). Unfortunately this breaks the mailscanner functionality. Since i'm not very good (i've actualy got no clue at all) in tracing back all the possible issues in the new package I thought I'd let you know.

    I only saw it removes (or doesn't create) the file /usr/local/sbin/mailscanner .

    fo now I've just downloaded the former package from http://pkg.freebsd.org/FreeBSD:11:amd64/release_0/All/MailScanner-4.85.2.txz and installed that on top of the 5.0.3 version, and that restores the mailscanner functionality.



  • @Rene.vandenBroek:

    it appears that the FreeBSD repo has upgraded the MailScanner pkg to version 5.0.3 ( from 4.85.2 ). Unfortunately this breaks the mailscanner functionality. Since i'm not very good (i've actualy got no clue at all) in tracing back all the possible issues in the new package I thought I'd let you know.

    Need some changed, I've already did some but it still have other things to fix.



  • Good Morning,

    has somebody tested the postfix installer script on the 2.4 RC Version?
    Just to be ready when the 2.4 is released.  ::)

    regards,
    Ralf



  • +1)
    Postfix is one of most important packages for me. I hope to see it on version 2.4  ::)



  • Hi Marcelloc,

    first of all thank you for your great work…

    While waiting for the package for 2.4 ;) I've upgraded pfSense to version 2.3.5 but postfix doesn't start, with the following message in the log:

    
    Nov 3 18:41:51 	php-fpm 	70404 	/pkg_edit.php: Postfix setup completed
    Nov 3 18:41:51 	php-fpm 	70404 	/pkg_edit.php: Reloading/starting postfix
    Nov 3 18:41:50 	php-fpm 	70404 	/pkg_edit.php: Writing rc_file
    Nov 3 18:41:50 	php-fpm 	70404 	/pkg_edit.php: The command '/usr/local/sbin/postmap /usr/local/etc/postfix/sender_access' returned exit code '1', the output was 'Shared object "libicuuc.so.58" not found, required by "postmap"'
    Nov 3 18:41:50 	php-fpm 	70404 	/pkg_edit.php: The command '/usr/local/sbin/postmap /usr/local/etc/postfix/transport' returned exit code '1', the output was 'Shared object "libicuuc.so.58" not found, required by "postmap"'
    Nov 3 18:41:50 	php-fpm 	70404 	/pkg_edit.php: Writing out configuration 
    
    

    What can I try?

    Thanks…
    R.

    Update: after a couple of reboot and a reinstallation now postfix starts and works correctly...
    I'll wait for the 2.4 version of the script... Thanks!



  • @pf-disa:

    What can I try?

    Try to reinstall the package. It's missing some libs from freebsd.



  • @marcelloc:

    @pf-disa:

    What can I try?

    Try to reinstall the package. It's missing some libs from freebsd.

    After update from 2.3.4 to 2.3.5, postfix need to be reinstalled:

    pkg install postfix
    

    or

    pkg install postfix-sasl
    

    will fix the missing libs, and postfix is operation normal again.



  • Hi! I installed postfix on my pf 2.4.1 with marcelloc script.

    I changed "2.3" to "2.4" at line 25 and run script, but packages was not found in repos.

    I unlock the FreeBSD repo in

    /usr/local/etc/pkg/repos/FreeBSD.conf > enabled: yes

    /usr/local/etc/pkg/repos/pfSense.conf > enabled: yes

    Then create xmlrpc.inc, because postfix.inc requires it

    touch /etc/inc/xmlrpc.inc

    I run script again, but have error "postwhite.conf not found"

    I do action from this post

    https://forum.pfsense.org/index.php?topic=40622.msg710038#msg710038

    and run srcipt again.

    In the end i have this error:

    updating soft bounce message status on databases..
    /var/db/postfix/20*dbError: near line 1: no such table: mail_noqueue
    ok

    I think it's not good, but postfix work fine. Massages transfered to my Exchange server, soft bounce work too.  ;)



  • @marcelloc Hi Marcello Hola Marcelloc, i just install pfsense 2.3.5 and postfix forwarder from your script, i can watch and edit postfix menu in pfsense but postfix no start, even pfsense no has the postfix command, i've tried to reinstall postfix from unofficial repo but got errors.
    0_1543369327094_posftfix.jpg

    please help



  • @winsonfa 0_1543371472131_posftfix.jpg unofficial repo no found postfix packets



  • Hi winsonfa, you can try my modded script for pfSense 2.4:

    cd /root
    
    https://raw.githubusercontent.com/spec1re/stuff/master/install_postfix_24.sh
    
    sh ./install_postfix_24.sh
    

    and here for MailScanner:

    cd /root
    
    https://raw.githubusercontent.com/spec1re/stuff/master/install_mailscanner_24.sh
    
    sh ./install_mailscanner_24.sh
    

    Both did work fine here with pfSense 2.4.3.



  • @bismarck said in Postfix - antispam and relay package:

    install_mailscanner_24.sh

    Hi Bismarck, thanks four your help, your saving my day, i've installed the version 2.4.4, postfix service is running now, when run the mailscanner script i got the following error:

    %(#000000)[fetch: https://github.com/extremeshok/spamassassin-extremeshok_fromreplyto/archive/master.zip: size of remote file is not known
    extremeshok_fromreplyto.zip 9292 B 150 kBps 00m00s
    fetch: https://github.com/smfreegard/DecodeShortURLs/archive/master.zip: size of remote file is not known
    DecodeShortURLs.zip 11 kB 167 kBps 00m00s
    pdfid.zip 100% of 9679 B 859 kBps 00m00s
    fetch: https://github.com/extremeshok/clamav-unofficial-sigs/archive/master.zip: size of remote file is not known
    clamav-unofficial-sigs.zip 76 kB 386 kBps 00m00s
    ./install_mailscanner_24.sh: rehash: not found
    ]



  • @winsonfa

    It should still work?

    Those errors are just cosmetic, you can ignore.

    On my machine, it gives that error but still works.